4 Replies Latest reply on Sep 13, 2019 12:36 PM by SkippT

    Disable the Managed Object Browser

    reist Lurker

      Good day,

       

      We are trying to disable the Managed Object Browser.  This solution Disable the Managed Object Browser (MOB) works good, but it is still checked checkbox in vmware client. We tried to restart ESXi host and VCenter, still the same. It doesn't work from CLI too:

       

      ~ # vim-cmd hostsvc/advopt/update Config.HostAgent.plugins.solo.enableMob bool false

      (vmodl.fault.InvalidArgument) {

         dynamicType = <unset>,

         faultCause = (vmodl.MethodFault) null,

         invalidProperty = <unset>,

         msg = "Received SOAP response fault from [<cs p:1f3042f8, TCP:localhost:443>]: updateValues

      A specified parameter was not correct.

      ",

      }

      ~ #

       

      What can we do?

       

      ESXi 5.5, VCSA 5.5

       

        • 1. Re: Disable the Managed Object Browser
          parmarr Expert
          Knowledge ChampionVMware Employees

          Also, To enable or disable the Managed Object Browser by using the vSphere Web Client, complete the following steps:

           

           

          Browse to the host in the vSphere Web Client navigator.

           

           

          On the Manage tab and click Settings.

           

           

          Under System, select Advanced System Settings.

           

           

          Select the Config.HostAgent.plugins.solo.enableMob option and click Edit to enable or disable the Managed Object Browser.

          1 person found this helpful
          • 2. Re: Disable the Managed Object Browser
            reist Lurker

            parmarr, thank you

             

            But for ESXi 5.5 it is not available - you can do it only through command line, and checkbox remains checked. We need it to uncheck to pass verification.

            • 3. Re: Disable the Managed Object Browser
              SkippT Novice

              Hi Reist

               

              Did you ever get this resolved?

              Would love to know as we have the same issue.

               

              Regards

              • 4. Re: Disable the Managed Object Browser
                SkippT Novice

                Hi Reist

                 

                I disabled this at the vcenter, as we had a host with exactly the same issue. Causing us to fail PSN. See below, might help you....

                 

                Fixed!!

                 

                Disabled by default in VS6, but enabled by default in vCenter 5.5. Can be disabled at the host following the many articles i seen, but i found a fix detailing how to disable it from vCenter. This was a PSN failure for us....

                 

                • C:\ProgramData\VMware\vCenterServer\cfg\vmware-vpx
                • Edit the vpxd.cfg file and add the following line under <vpxd> to disable MOB.

                <enableDebugBrowse>false</enableDebugBrowse>

                Requires the vcenter server service to be restarted