0 Replies Latest reply on Sep 22, 2017 12:08 PM by enpicket

    Cannot remove userGroup whose sourceId is not null by passing sourceId parameter as null

    enpicket Lurker

      Received an error when using the DELETE /api/auth/usergroups/{id} to remove an AD group. Granted, it states it is for 'local' group deletion. So, I attempted to pass in the parameter:




      and even tried to send in the json body



        "sourceId": "<ad_auth_source_id>"



      which also yielded the same result (Canoot remove userGroup).


      I thought I might use PUT /api/auth/usergroups


      to modify the group by setting the auth source to null so it could then be deleted, but the documentation is very light, and sending either name or id does not allow group modification:



        "id": "<group-id>",

        "sourceId": null






      "message": "Invalid request... #1 violations found."




      "failureMessage": "may not be empty"

      "violationPath": "name"


      "httpStatusCode": 400

      "apiErrorCode": 400



      Updating the original call with 'name' returns:



      "message": ""UserGroup" with identifier "<group_name>" already exists."

      "httpStatusCode": 422

      "apiErrorCode": 1508



      So it seems I am at an impasse. Assistance would be appreciated.