2 Replies Latest reply on Sep 6, 2017 11:29 AM by nlangione

    In ESXi 6 can you live vMotion between hosts with the same CPU, but from different vendors, without EVC enabled

    nlangione Lurker

      Hi,

       

      We have two clusters of Dell PowerEdge FC830 and three clusters of HP ProLiant DL560 Gen9 servers with the Intel(R) Xeon(R) CPU E5-4667 v4 @ 2.20GHz processors. I would like to set up a shared lun between these five clusters so we can balance load without downtime. With the processors being the same model, the vendor and family requirements are clearly met, but I haven't been able to find any documentation stating this is a safe practice.

       


      As a test I added an nfs lun to the five clusters, spun up a test VM, and initiated some vMotions via the web client. I saw no compatibility warnings or errors and the vMotion appeared to be successful. I then proceeded to test all possible vMotions between these clusters while pinging the network gateway from the test VM and pinging the test VM from a prod VM in the same vCenter on another network. During the vMotions I would see the ping time go from sub 1ms to as high as 20ms for 1 or two packets during the peak of the vMotion. The results of the ping tests are below and show packets dropping during the peak of some vMotions.

       

      c07 HP dl560 Intel(R) Xeon(R) CPU E5-4667 v4 @ 2.20GHz

      c08 HP dl560 Intel(R) Xeon(R) CPU E5-4667 v4 @ 2.20GHz

      c09 HP dl560 Intel(R) Xeon(R) CPU E5-4667 v4 @ 2.20GHz

      c10 Dell fc830 Intel(R) Xeon(R) CPU E5-4667 v4 @ 2.20GHz

      c11 Dell fc830 Intel(R) Xeon(R) CPU E5-4667 v4 @ 2.20GHz

       

      c11 > c07 0 packets dropped from test VM to gateway, 1 packets dropped from prod VM to test VM

      c07 > c11 1 packets dropped from test VM to gateway, 0 packets dropped from prod VM to test VM

      c07 > c10 0 packets dropped from test VM to gateway, 0 packets dropped from prod VM to test VM

      c10 > c07 0 packets dropped from test VM to gateway, 3 packets dropped from prod VM to test VM

      c10 > c08 1 packets dropped from test VM to gateway, 0 packets dropped from prod VM to test VM

      c08 > c10 0 packets dropped from test VM to gateway, 0 packets dropped from prod VM to test VM

      c08 > c11 0 packets dropped from test VM to gateway, 0 packets dropped from prod VM to test VM

      c11 > c08 0 packets dropped from test VM to gateway, 1 packets dropped from prod VM to test VM

      c11 > c09 0 packets dropped from test VM to gateway, 0 packets dropped from prod VM to test VM

      c09 > c11 0 packets dropped from test VM to gateway, 1 packets dropped from prod VM to test VM

      c10 > c09 0 packets dropped from test VM to gateway, 1 packets dropped from prod VM to test VM

      c09 > c10 1 packets dropped from test VM to gateway, 1 packets dropped from prod VM to test VM

       

      My fear is that the latency and packet loss may be enough to have a negative impact on our production applications. I know I'll need to do some production testing, but I'd like to avoid certifying every application in our environment if possible?

       

      Has anyone gone down this road before or currently do this in their environment? Any tips or suggestions for further testing?

       

      Thanks,

      Nate