6 Replies Latest reply on Dec 2, 2019 9:19 AM by booradlly

    Workstation 12 smart card reader not detected

    herveus Lurker

      I am running Workstation Player 12.5 on a Windows 7 system.

       

      When I start my Windows 7 VM, the list of devices in the frame show the keyboard card reader with a card in it and the card reader on the laptop itself.

       

      However, the OS in the VM doesn't see the card readers at all. I get no other error messages, and I could find nothing in the log to shed any light on this.

       

      This VM is a clone of one that works or worked fine on at least two other host machines. That leads me to suspect some sort of local policy issues, but I'm no expert on that, either.

       

      Can anyone point me in useful directions?

       

      yours,

      Michael

        • 1. Re: Workstation 12 smart card reader not detected
          bluefirestorm Master

          The default behaviour of Workstation Pro/Player is that smart card devices can be shared between VMs. (For Player it isn't relevant as only one VM can be open at any one time). For Windows VMs, the shared smart card reader should then appear as Microsoft Virtual CCID device in Device Manager. But for certain models of smart card readers, this shared behaviour does not result in the Microsoft Virtual CCID appearing nor does the smart card reader appear as a "Removable Device".

           

          Try adding the following two lines to the vmx configuration file of the VM to disable the sharing.

           

          usb.generic.allowCCID = "TRUE"

          usb.ccid.disable = "TRUE"

          • 2. Re: Workstation 12 smart card reader not detected
            herveus Lurker

            The first line does not appear to have had any useful effect. The second disabled sharing the card reader with the host OS as well.

             

            I have to be able to use the card in the host OS and in the VM.

             

            When the OS comes up in the VM, ActiveClient pops up a message that no card reader was detected. Something is preventing the

            VM from seeing the hardware at all.

             

            yours,

            Michael

            • 3. Re: Workstation 12 smart card reader not detected
              bluefirestorm Master

              It is hard to see how a VMX configuration change would disable the card reader at the host; unless somehow it got connected to the VM and you had not realised it. That would be the scenario where the card reader is not available on the host because it is connected to the VM. That is part of disable sharing of smart card reader does (aside from the card reader not being shared between VMs). To edit the VMX configuration, the VM has to be powered down, not suspended.

               

              Is the card reader connected through USB (whether internally or externally)? I imagine it would be as even built-in webcams and fingerprint readers on laptops would be wired internally through a USB controller. Assuming it is a USB based card reader, adding those two lines should make the card reader appear under "Removable Devices" menu that you can then connect to the VM.

               

              I don't know what ActiveClient is, I assume it is some sort of software that interacts with the card reader. So assuming those two lines did as expected and the card reader appears in the Removable Devices menu, you would then have to connect the smart card reader from the "Removable Devices" menu (just like USB thumb drives) which would then disconnect it from the host (thus become unavailable to the host).

              • 4. Re: Workstation 12 smart card reader not detected
                herveus Lurker

                Howdy!

                 

                Thanks for trying. I tried it with usb.ccid.disable set to TRUE, and it did take over the reader, but it was still not visible to the OS running on the VM.

                 

                It's almost as if there is a driver missing or something, but that doesn't make any sense either.

                 

                The same instance of the VM runs fine on other systems. The difference between where it works and where it doesn't is the security posture, or whatever.

                 

                Unfortunately, the help desk refused to address the question of what policies might be interfering here, on the grounds that VMWare was not a corporately supported app.

                 

                I don't know enough about Windows 7 policies to formulate a useful question. And, of course, it may all be moot shortly, as I am due to be upgraded to a new box with Windows 10 this month.

                 

                yours,

                Michael

                • 5. Re: Workstation 12 smart card reader not detected
                  mjaric Lurker

                  I'm not sure if this can help you, but in my case (MacOs with VMWare Fusion) I had to reconfigure USB to version 1.1 for my virtual machine, and it worked properly

                   

                  Cheers,

                  Milan Jaric

                  • 6. Re: Workstation 12 smart card reader not detected
                    booradlly Lurker

                    This should be selected as the answer, as this is default behavior.

                     

                    More details for mjaric awesome answer:

                    Symptoms:

                    usb device is not listed under removable devices

                    You notice no usb device is listed under removable devices

                     

                    Steps to resolve.

                    Suspend VM, if you don't it will be done automatically.

                    Add usb controller, select 1.1 not 3.0

                    Click Ok.

                    Vm will now be suspended if you haven't already suspended it.

                    You should now be looking at a popup with a bunch of devices available for you to connect to your VM