8 Replies Latest reply on Apr 16, 2019 9:28 AM by mchadwick19

    Cursor blink rate always stays on FAST

    VMWareWSS2015 Novice

      I am running into this weird issue with blinking cursor rate.  This is Windows 7 VMs.

      I set the following on the gold image.


      We set blinking cursor rate (Control Panel > Keyboard) down to third line from the left.  Save the setting.

      Also updated following registry key.


      HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control Panel\Desktop]




      The setting works in gold image but once recomposed VMs does not.  Blinking cursor rate is always set to FAST even if you update it on the VM.


      Anybody out there ran into this issue...

        • 1. Re: Cursor blink rate always stays on FAST
          JCrimson Lurker

          This exact issue is happening in my organization. Did you find a solution? Please help!

          • 2. Re: Cursor blink rate always stays on FAST
            mchadwick19 Enthusiast

            If you are changing this in HKCU for the user you are creating the pool with, this isn't going to work. HKCU when you are logged in only applies to the user account you are using (doesn't move between user profiles).


            What you need to do is unhide hidden items in explorer. Open regedit select the HKEY_Users (this is by preference, you can use other locations as well) hive. File > Load Hive. Browse to C:\Users\Default\ntuser.dat and give it a name. You will see the name show up under HKU. In here, make the change you need to do. When you are done, select the name and File > Unload hive. If you do not unload the hive, the changes are not saved.


            Seal your image and push the changes.

            • 3. Re: Cursor blink rate always stays on FAST
              JCrimson Lurker

              I understand how HKCU works and I'm not trying to change it on the master image. The settings on the master image are fine, its just the windows default.


              On my master image, in control panel > Keyboard properties > Cursor Blink rate I can change this and everything works as normal. Again, not asking this to be default, just want to point out that everything works normal.



              The issue is once I create a vdi from this image, the user that logs in has ZERO control over that slider. The user can move the slider and change the slider or even the registry key for this setting, and it will INSTANTLY revert to MAX FAST upon pressing "OK" in this keyboard properties box. I have tried everything I can think of to fix this. There no policy enforced to control this setting, there's no profile entry to enforce this setting. There's nothing on the parent image to enforce this setting. I have given users full admin rights as a test and their setting still gets set to MAX FAST as soon as they press OK.

              • 4. Re: Cursor blink rate always stays on FAST
                mchadwick19 Enthusiast

                I get what you're saying now. Do you have any visual assistance apps that may be injecting itself there? Anything that's text to speech or visual impairment aids may be overriding the kb setting.


                Also I have seen in the past some thin clients having their own cursor blink rates that is being pushed into the session as part of the KB/Mouse redirection.

                • 5. Re: Cursor blink rate always stays on FAST
                  JCrimson Lurker

                  No visual assistance apps

                  no text to speech

                  no visual impairment aids


                  I have tried this from zero clients, thin clients, and my laptop with the horizon app install. All get the same results.


                  If I connect via pcoic i get the super fast cursor rate and cant change the setting.

                  If i connect via RDP the cursor flashing is completely invisible but the keyboard setting is still set to max and cannot be changed just like via pcoip.


                  Let me also add that this problem started last week when I moved users from dedicated pools with persona to floating pools with UEM. Maybe moving to floating pools with uem revealed this issue we've always had?


                  Here are my trials and results....


                  Tested Floating vs Dedicated Pool. Problem found in both.



                  Tested Windows 7 vs win 10. Problem only in Win7.



                  Disabled UEM for this setting. Problem still there.



                  Testing previous vdi verisons

                  new image, 62b: has issue

                  march image, 62: has issue

                  feb image, 61b: has issue

                  jan image, 61: has issue



                  Tried via RDP and the mouse is either invisible or solid with no flashing..



                  Tried https://kb.vmware.com/s/article/53152

                  Mouse seems the same



                  Tried https://kb.vmware.com/s/article/2060701

                  no change.



                  New Findings:

                  I made a dedicated vdi - When I log in as my normal user account (non admin), getting persona and uem - Issue is there

                  I then assigned my admin account to the same dedicated vdi, logged in. (admin accounts dont get uem but will get persona) - Issue is gone....

                  Something in user profiles?



                  A related issue is in acrobat when you choose to print copies and select the number with the up and down arrows the number jump like you are pressing the mouse multiple time. This doesn't happy anywhere else on the VDI, just selecting print copies. When I used the above trial that fixed the flashing cursor, this was also fixed. these issues are directly related.



                  Tried making my non admin account a local admin on the dedicated vdi. issue still there.



                  Tried disabling inheritance from other gpos, issue still there with admin or non admin in a floating pool.



                  Pool trials:

                  dedicated pool (persona gpo + uem gpo)



                  Admin - works

                  non admin - issue




                  dedicated pool (UEM gpo only)



                  Admin - issue

                  non Admin - issue




                  dedicated pool (Persona gpo only)



                  Admin - works

                  non Admin - issue




                  dedicated pool (NO persona gpo + NO uem gpo)



                  Admin - issue

                  non Admin - issue

                  non Admin (added to UEM Admin group) - issue


                  floating pool (Persona gpo only)



                  Admin - works

                  non Admin - issue


                  conclusion: Pool type doesn't matter.



                  Cloned Win7 Parent image. Updated: VMware Tools, Agent, UEM. = Same issue



                  Disabled 3d Graphics on parent vm - same issue



                  Used latest optimizer on win7 image - same issue

                  • 6. Re: Cursor blink rate always stays on FAST
                    JCrimson Lurker

                    issue resolved with the below


                    Blinking cursor.


                    On parent image open regedit and load default ntuser.dat.

                    • - Highlight HKLM hive and go to file, Load hive.
                    • - Load .DAT from c:\users\default user\ntuser.dat
                    • - Name it something easy to remember and spot like “Default Profile”

                    New hive will be loaded under HKLM and named in our case “Default Profile” In that hive navigate to

                    • - HKLM\Default Profile\software\policies\Microsoft\Windows\Control Panel\Desktop
                    • - Delete the three outlined keys bellow.


                    After keys have been delete make sure to unload the hive by highlighting “Default Profile” and going to file, unload hive. If this step is missed new users will not be able to log in.

                    • 7. Re: Cursor blink rate always stays on FAST
                      mchadwick19 Enthusiast

                      Lots of info here and seems to be quite the gamut of tests.


                      First off I, personally, would recommend against using both persona and UEM at the same time. They both perform similar functions, but UEM seems to be the way forward for the future. Using the two together you may find that they conflict with each other and override each other. Not saying that's what you are seeing here, but keep in may that your results may be inconsistent using both. There are many comments on this forum and others that outline the reasoning for UEM over persona.


                      As to your RDP comment - RDP reads it's visual settings from a different set of keys under the Terminal services keys.


                      I believe the root of your issue lies in the image itself since with both disabled, the issue exists meaning that your default user profile has these settings configured. I see that you are using the OSOT which does modify the default user registry, but it disables cursor blink all together.


                      I got your other note as I was typing this. This is most likely due to the OSOT setting this. If you look at the template for the default Windows template(s) (under my templates) under the "Apply settings for HKCU" category. The very first thing it does is load the default user ntuser.dat file and disables the cursor blink and blink rate.


                      Are being more restrictive on your desktops and disallowing registry access to users? This may be the reason why they can adjust the slider in the UI but when they click "ok" they are unable to update the registry key that controls this setting. You would be able to see this with procmon.

                      • 8. Re: Cursor blink rate always stays on FAST
                        JCrimson Lurker

                        We were running Persona and UEM side by side per vmware's persona to UEM migration kb. VMware Knowledge Base


                        We didn't notice this issue until I removed persona from our VDI and just let UEM manage personalization. The only reason I tried to add Persona back to them was to see what all changed and why we didn't have this issue before with just Persona.


                        Yeah the issue was with the default ntuser.dat