6 Replies Latest reply on Jan 4, 2019 2:18 PM by TheBobkin

    Can't claim SSDs as Capacity Storage

    onlyReavr Lurker

      Hi,

       

      I have a strange problem. I can't claim my Flash Drives as a Capacity Drive.

      Already deleted the partitions on all of the SSDs and tagged everyone as a Capacity Drive, but the tag won't stay after a reboot of the whole vSphere Host.

      There must be another issue beside the capacity tag. I have the option to claim every Flash Drive as Cache.

      I already had them as Capacity Drive before I reenabled the vSAN Feature, but at this time I added them after I enabled vSAN, but it should possible to configure vSAN as All Flash from the start?

       

      Now I have thrown some of the Hosts onto a new and fresh vCenter and resetted the Hosts itself to be sure, but the Problem is still there.

       

      Anyone have a clue what is going on there?

        • 1. Re: Can't claim SSDs as Capacity Storage
          TheBobkin Master
          vExpertVMware Employees

          Hello,

           

           

          Welcome to vSAN Communities, I hope you find some good info on this forum.

           

          Are you by any chance using 6.0/6.2 vSAN Standard or ROBO licensed hosts?

          All-Flash was/is not a licensed-feature of these (in vSAN 6.5 Standard edition it is).

           

          Do they show as marked after marking them when you run vdq -q?

          Are you able to use them as capacity before you reboot (and this is removed)?

          Where are you marking them as Capacity from?

          Try from CLI:

          kb.vmware.com/kb/2120252

          and RVC:

          docs.vmware.com/en/VMware-vSphere/6.5/com.vmware.vsphere.virtualsan.doc/GUID-8A265A85-0F30-4EDF-97E6-4235A36A2458.html

           

           

          Bob

          • 2. Re: Can't claim SSDs as Capacity Storage
            onlyReavr Lurker

            Hi,

             

            all Hosts are on Version 6.5 with Standard License.

             

            They do show marked in vdq -q, as I show you here:

             

            Kopfzeile 1

                  "Name"     : "naa.5002538d40d3f9a5",

                  "VSANUUID" : "",

                  "State"    : "Eligible for use by VSAN",

                  "Reason"   : "None",

                  "IsSSD"    : "1",

            "IsCapacityFlash": "1",

                  "IsPDL"    : "0",

               },

             

            I marked them with the CLI, now I tried it with RVC too but it doesn't work, there is no selection for the Disks as Capacity.

             

            Mhh ..

            • 3. Re: Can't claim SSDs as Capacity Storage
              TheBobkin Master
              VMware EmployeesvExpert

              Hello,

               

               

              Is the vCenter/vCSA managing this cluster also on version 6.5?

              Is Auto-claim of disks disabled? (Yes I know you likely wouldn't see cache nor anything nor be able to open 'create disk' if this is enabled but still)

               

               

              After marking them as Capacity-Flash are you able to create a disk-group from the CLI using:

              # esxcli vsan storage diskgroup mount -s <naa of cache-tier SSD> -d <naa of 1st capacity-tier SSD> -d <naa of 2nd capacity-tier SSD>

               

              If this fails, does it give an error message and if not (specific) then please post the vmkernel.log and clomd.log from when this occurred (both located in /var/log/ ).

               

              What model of controller and SSDs are you using here and what is the mode on the controller? (e.g. pass-through or RAID0)

               

               

              Bob

              • 4. Re: Can't claim SSDs as Capacity Storage
                onlyReavr Lurker

                Hi,

                 

                auto claim is disabled, yes. The command that you said doesn't worked for me, but it is not that far away from the right answer.

                I found the solution for this because of this command!

                 

                I managed to create a SSD Cache and SSD Capacity with following command:

                 

                esxcli vsan storage add -s naa.xxx-d naa.xxx

                 

                Thanks!

                • 5. Re: Can't claim SSDs as Capacity Storage
                  BuddyLee Lurker

                  While this appears to have been solved by the original poster via the CLI, I am seeing this same thing on a 6.7U1 environment.  I can use the exact same hardware on 6.5 and when going through to setup VSAN you can select both capacity and cache disks just fine.  If I install 6.7 on the same hardware, the ability to select capacity is absent and also missing is the ability to select Dedupe and Compression at the beginning of the wizard.  This looks like it might be a bug?

                  • 6. Re: Can't claim SSDs as Capacity Storage
                    TheBobkin Master
                    VMware EmployeesvExpert

                    Hello BuddyLee,

                     

                     

                    Welcome to Communities.

                     

                    Are you perchance using a 6.7 pre-U1 vCenter and 6.7 U1 hosts?

                    I saw this recently with a customer that various things didn't function when configuring the cluster due to this unsupported setup (and it worked fine after updating the vCenter to 6.7 U1).

                     

                     

                    Bob