2 Replies Latest reply on Jul 24, 2017 2:01 AM by rachel

    VMWare Tools not recognised for Linux guest in Tech Preview

    rachel Enthusiast

      The Tech Preview doesn't seem to think I have VMWare Tools installed. Since switching to the tech preview, I'm getting an overlay on the laptop's internal screen:

       

      "The virtual machine must have up-to-date VMWare Tools installed and running."

       

      This doesn't go away. At first, on the current release version, it seemed to be only happening during boot, and on the initial login screen, which seemed to only be using VGA graphics, but once logged in and full VMWare graphics took over, the overlay would disappear. Now it is not going away at all. (Persistently over reboots of the guest.)

       

      In addition at least some other vmware-tools provided functionality is not working, specifically shared folders. Again, more specifically, it's VMWare itself telling me I need to install VMWare Tools for that to work. (I didn't notice it immediately because I don't normally use that anyway. So I don't know if that was working before the tech preview.)

       

      I tried switching to the vmware tools provided by the host, but that was unsuccessful. Specifically, it thought open-vm-tools was still installed (it definitely was not) and so refused to install some of its own components, or compile modules. It looks like at least some of the vmware modules are included in the linux-image-generic package that's installed as standard on Ubuntu, and I'm guessing it was those that it was objecting to. In this state, tools functionality did not work, and I had only bog-standard VGA graphics. I had to remove those tools and reinstall open-vm-tools to regain former functionality. But I still have the overlay message as described.

       

      Macbook Pro 13" Retina with High Sierra Public Beta 2

      VMWare Fusion Tech Preview 2017

      Guest OS: Ubuntu Linux 17.04

      VMWare tools installed: open-vm-tools-desktop (& dependencies) from Ubuntu software repos.

       

      Hardware note: in desktop configuration, have external monitor, which is the primary, both in macOS and in the guest Linux environment (which is, yes, using both monitors, apparently just fine). Both screens are "retina", with the external one being 4K, at its macOS default resolution (2x scaling). The Linux desktop is also doing its own 2x scaling which is working just fine, or at least as fine as it does under Linux, which is to say, not entirely consistently!

       

      But I've got full-resolution graphics on both screens working as I'd expect. I could stand for it to be a bit *quicker*, which is partly why I'm trying the tech preview (in the hope that its use of Metal graphics on the host might improve graphics performance with these Retina screens, which would be the single best thing to improve *perceived* performance on the desktop) but generally everything seems to be working as if vmware tools are installed. (Linux desktop is GNOME standard, ie: using X11, not Wayland, on which a number of apps I run don't work.)

        • 1. Re: VMWare Tools not recognised for Linux guest in Tech Preview
          wila Guru
          vExpertCommunity WarriorsUser Moderators

          Hi,

           

          The open-vm-tools package exists of two packages, open-vm-tools and open-vm-tools-desktop.

           

          Did you try:

            sudo apt-get purge open-vm-tools-desktop

           

          and then install vmware tools from the host?

           

          --

          Wil

          | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
          | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
          | More info at https://www.vimalin.com
          | Twitter @wilva
          | VMware Wiki at http://www.vi-toolkit.com
          • 2. Re: VMWare Tools not recognised for Linux guest in Tech Preview
            rachel Enthusiast

            That appears to have worked, so marking you correct. :-)

             

            I'm not entirely sure if it's *better* though. :-} The overlay has gone away and I am being allowed to set up shared folders, so the Host is recognising that vmware tools has been installed. Otherwise things seem pretty much the same. I'm not certain but X11 may be a little slower at dragging windows around. Don't quote me on that though as the last time I used it on the open-vm-tools was yesterday and I've been using native macOS since then, so my eyes may be comparing it with the wrong thing.

             

            A little detail:

             

            What I actually did was:

             

            sudo aptitude purge open-vm-tools open-vm-tools-dkms open-vm-tools-desktop

             

            Then I ran the vmware tools installer. This time it didn't indicate that it thought another VMWare Tools was installed, so yes, presumably it's some configuration normally left behind if you don't purge the above packages that was the problem there. Naturally it still recommended that I install open-vm-tools instead, but I persisted. ;-)

             

            vmware-config.pl did note that the following modules have "already been installed on this system by another installer or package and will not be modified by this installer.": vmci, sock, vmxnet3, pvscsi, vmmemctl. So those modules will still be the ones from linux-image-generic and not potentially-newer versions from the host vmware tools. It did let me enable vmbock and vgauth and caf (and would have thinprint as well but I said no to that)

             

            Then with respect to X:

             

            Distribution provided drivers for Xorg X server are used.

             

            Skipping X configuration because X drivers are not included.

             

            So I imagine it is using the VMWare X driver installed with the system.

             

            So in general it looks like I'm running a bit of a mix between the drivers that come with the system and some from the host vmware tools that didn't replace those on the system. It's enough for the host to recognise that tools have been installed, but I'd guess I'm not getting the benefit of any (presumed) advances in those drivers that were not replaced.