9 Replies Latest reply on Jul 25, 2017 4:34 AM by vijayrana968

    vmware deploy from template with guest customization error

    LucaMeglioli Novice

      customizon of a new vm from template goes in error

       

      in the events of the vm i see :

      "An error occureed while setting up network properties of the guest Os. See log file C:\windows\temp\vmware-inc\guestcust.log in the guestos for detail"

       

      in this log file there's just an error reporting "[2017-07-21T14:52:08:                              :  ERROR] error number 80010106, No error message found for error code -2147417850 (0x80010106)"

       

      i've tested the sysprep manually inside the VM and it ends good

       

      it happen after installing some application (about CAD environment)

       

      if i get back to the snapshott taked before the application's setup , the deploy ends good

       

       

      i also noted that, after installing hte application, when i deploy the VM from the template the network device comes up as disconnected (both "conncted" and "connected at power on" are not solected")

       

      thank you for support

        • 1. Re: vmware deploy from template with guest customization error
          vijayrana968 Master
          vExpert

          You need to lookup details in setupact.log and setuperr.log under C:\Windows\System32\sysprep\Panther inside guest os.

          • 2. Re: vmware deploy from template with guest customization error
            LucaMeglioli Novice

            thanks for the reply

             

            setupact.log is the first file that i've checked, there's no error

             

             

            2017-07-21 14:52:07, Info              SYSPRP ========================================================
            2017-07-21 14:52:07, Info              SYSPRP ===      Beginning of a new sysprep run      ===
            2017-07-21 14:52:07, Info              SYSPRP ========================================================
            2017-07-21 14:52:07, Info   [0x0f004d] SYSPRP The time is now 2017-07-21 14:52:07
            2017-07-21 14:52:07, Info   [0x0f004e] SYSPRP Initialized SysPrep log at C:\Windows\system32\Sysprep\Panther
            2017-07-21 14:52:07, Info   [0x0f0054] SYSPRP ValidatePrivileges:User has required privileges to sysprep machine
            2017-07-21 14:52:07, Info   [0x0f007c] SYSPRP FCreateTagFile:Successfully deleted tag file C:\Windows\system32\Sysprep\Sysprep_succeeded.tag
            2017-07-21 14:52:07, Info   [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'RESPECIALIZE'
            2017-07-21 14:52:07, Info   [0x0f005f] SYSPRP ParseCommands:Found supported command line option 'QUIET'
            2017-07-21 14:52:07, Info              SYSPRP WinMain:Processing 're-specialize' internal provider request.
            2017-07-21 14:52:07, Info              SYSPRP RunExternalDlls:Running platform actions specified in action file for phase 6
            2017-07-21 14:52:07, Info   [0x0f00ba] SYSPRP SysprepSession::CreateSession: Successfully created instance with mount path C:, action file C:\Windows\System32\Sysprep\ActionFiles\ReSpecialize.xml, and mode <null>
            2017-07-21 14:52:07, Info              SYSPRP SysprepSession::Execute: Beginning action execution from C:\Windows\System32\Sysprep\ActionFiles\ReSpecialize.xml
            2017-07-21 14:52:07, Info              SYSPRP ActionPlatform::GetStringValue: Getting REG_SZ value SysprepMode under key HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup\Sysprep
            2017-07-21 14:52:07, Info              SYSPRP ActionPlatform::GetValue: Getting value SysprepMode under key HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup\Sysprep
            2017-07-21 14:52:07, Warning           SYSPRP ActionPlatform::GetValue: Error from RegQueryValueEx on value SysprepMode under key HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup\Sysprep; dwRet = 0x2
            2017-07-21 14:52:07, Info              SYSPRP SysprepSession::CreateXPathForSelection: Sysprep mode in registry is <null>
            2017-07-21 14:52:07, Info              SYSPRP ActionPlatform::GetStringValue: Getting REG_SZ value PROCESSOR_ARCHITECTURE under key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
            2017-07-21 14:52:07, Info              SYSPRP ActionPlatform::GetValue: Getting value PROCESSOR_ARCHITECTURE under key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
            2017-07-21 14:52:07, Info              SYSPRP SysprepSession::CreateXPathForSelection: Processor architecture in registry is AMD64
            2017-07-21 14:52:07, Info              SYSPRP SysprepSession::ExecuteInternal: After sorting, providers will be excuted in this order:
            2017-07-21 14:52:07, Info              SYSPRP SysprepSession::ExecuteInternal: name:Microsoft-Windows-PnpSysprep, order: 100d
            2017-07-21 14:52:07, Info   [0x0f00bd] SYSPRP CreateSysprepActionList: Building action list for component Microsoft-Windows-PnpSysprep
            2017-07-21 14:52:07, Info   [0x0f0080] SYSPRP ActionPlatform::LaunchModule: Found 'Sysprep_Respecialize_Pnp' in C:\Windows\System32\sppnp.dll; executing it
            2017-07-21 14:52:07, Info              SYSPRP SPPNP: Sysprep_Respecialize_Pnp: Enter
            2017-07-21 14:52:08, Info              SYSPRP SPPNP: Created progress thread.
            2017-07-21 14:52:08, Info              SYSPRP SPPNP: Creating device install status thread.
            2017-07-21 14:52:08, Info              SYSPRP SPPNP: Waiting for device install status thread to exit.
            2017-07-21 14:52:08, Info              SYSPRP SPPNP: Status: Starting...
            2017-07-21 14:52:08, Info              SYSPRP SPPNP: Status: Total = 0, Complete = 0, Progress = 0% (0%)
            2017-07-21 14:52:08, Info              SYSPRP SPPNP: Status worker: Waiting for device installation to start...
            2017-07-21 14:52:08, Info              SYSPRP SPPNP: Waiting for progress thread to exit.
            2017-07-21 14:52:09, Info              SYSPRP SPPNP: Status: Idle
            2017-07-21 14:52:09, Info              SYSPRP SPPNP: Finished waiting for device install status.
            2017-07-21 14:52:09, Info              SYSPRP SPPNP: Progress thread exited.
            2017-07-21 14:52:09, Info              SYSPRP SPPNP: Sysprep_Respecialize_Pnp: Exit
            2017-07-21 14:52:09, Info   [0x0f0081] SYSPRP ActionPlatform::LaunchModule: Successfully executed 'Sysprep_Respecialize_Pnp' from C:\Windows\System32\sppnp.dll without error
            2017-07-21 14:52:09, Info   [0x0f00b8] SYSPRP SysprepSession::Execute: Sysprep mode was not specified, deleting it from registry
            2017-07-21 14:52:09, Info   [0x0f00c6] SYSPRP ActionPlatform::DeleteValue: Deleting registry value SysprepMode under key HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup\Sysprep
            2017-07-21 14:52:09, Warning           SYSPRP ActionPlatform::DeleteValue: Registry value SysprepMode to be deleted does not exist under key HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup\Sysprep
            2017-07-21 14:52:09, Info   [0x0f0052] SYSPRP Shutting down SysPrep log
            2017-07-21 14:52:09, Info   [0x0f004d] SYSPRP The time is now 2017-07-21 14:52:09
            • 3. Re: vmware deploy from template with guest customization error
              LucaMeglioli Novice

              in the vmkernel log , related to ethernet, i just found this :

               

              2017-07-21T13:50:38.830Z cpu12:189970)Vmxnet3: 15251: Using default queue delivery for vmxnet3 for port 0x200003c

              2017-07-21T13:50:38.830Z cpu12:189970)NetPort: 1573: enabled port 0x200003c with mac 00:50:56:b8:13:fc

              2017-07-21T13:50:38.832Z cpu12:189970)NetPort: 1780: disabled port 0x200003c

              2017-07-21T13:50:38.837Z cpu6:189969)Vmxnet3: 15251: Using default queue delivery for vmxnet3 for port 0x200003c

              2017-07-21T13:50:38.837Z cpu6:189969)NetPort: 1573: enabled port 0x200003c with mac 00:50:56:b8:13:fc

              • 4. Re: vmware deploy from template with guest customization error
                vijayrana968 Master
                vExpert

                Check if application is MAC aware as you are facing issue with application installed.

                • 5. Re: vmware deploy from template with guest customization error
                  LucaMeglioli Novice

                  we installed many part of solidworks , it seems there's no link to the mac address for this application

                   

                  we''re stuck in the same situation of the last week , clone with customization goes in error after 2/3 sec

                  • 6. Re: vmware deploy from template with guest customization error
                    LucaMeglioli Novice

                    this is the guestcust logs file

                     

                     

                    "

                    [2017-07-24T17:48:58:                          :   INFO] GuestCustUtil invoked.
                    [2017-07-24T17:48:58:                          :   INFO] Params: customize -sealparam "/quiet /generalize /oobe /reboot" -nics 4000 -schedulenativeunobfusc
                    [2017-07-24T17:48:58:                          :  DEBUG] Registry value 'CustomRescheduleFlags' is not set. Returning default value: 0
                    [2017-07-24T17:48:58:                          :   INFO] Checking for Windows Sysprep Respecialize operation.
                    [2017-07-24T17:48:58:                          :  DEBUG] Sysprep process is not running.
                    [2017-07-24T17:48:58:                          :   INFO] Windows Sysprep Respecialize operation was not detected.
                    [2017-07-24T17:48:58:             GuestCustUtil:  DEBUG] Deleting status marker file C:/Windows/.post-gc-status
                    [2017-07-24T17:48:58:             GuestCustUtil:  DEBUG] Status marker file C:/Windows/.post-gc-status doesn't exist
                    [2017-07-24T17:48:58:                          :   INFO] Extended customization is not enabled!
                    [2017-07-24T17:48:58:                          :  DEBUG] Customization in progress set to 1 at 2017-Jul-24 17:48:58
                    [2017-07-24T17:48:58:                          :  DEBUG] Rpci: Sending request='deployPkg.update.state 4 0 C:/Windows/TEMP/vmware-imc/guestcust.log'

                     

                    [2017-07-24T17:48:58:                          :  DEBUG] Rpci: Sent request='deployPkg.update.state 4 0 C:/Windows/TEMP/vmware-imc/guestcust.log', reply='', len=0, status=1

                     

                    [2017-07-24T17:48:58:                          :  DEBUG] Successfully opened key SYSTEM\CurrentControlSet\Control\Session Manager\
                    [2017-07-24T17:48:58:                          :  DEBUG] Size of reg_multi_sz 21.
                    [2017-07-24T17:48:58:                          :  DEBUG] Read multi_sz value from registry autocheck autochk *, size 21.
                    [2017-07-24T17:48:58:                          :  DEBUG] string value from registry autocheck autochk *.
                    [2017-07-24T17:48:58:                          :  DEBUG] Returning 1 elements
                    [2017-07-24T17:48:58:                          :  DEBUG] Got BootExecute from session mgr.
                    [2017-07-24T17:48:58:                          :  DEBUG] Native App sysprepDecrypter.exe, arguments ''
                    [2017-07-24T17:48:58:                          :  DEBUG] Copied file sysprepDecrypter.exe to C:\Windows\system32\sysprepDecrypter.exe
                    [2017-07-24T17:48:58:                          :  DEBUG] Updated boot execute value.
                    [2017-07-24T17:48:58:                          :  DEBUG] Successfully created/opened key SOFTWARE\VMware, Inc.\Guest Customization\
                    [2017-07-24T17:48:58:                          :  DEBUG] New boot execute:
                    [2017-07-24T17:48:58:                          :  DEBUG] autocheck autochk *
                    [2017-07-24T17:48:58:                          :  DEBUG] sysprepDecrypter.exe
                    [2017-07-24T17:48:58:                          :  DEBUG] Temporary sysprep dir path: C:\sysprep
                    [2017-07-24T17:48:58:                          :  DEBUG] Moving directory 'sysprep' to 'C:'

                     

                    [2017-07-24T17:49:00:                          :  DEBUG] Rpci: Sending request='deployPkg.update.state 4 101 C:/Windows/TEMP/vmware-imc/guestcust.log@No error message found for error code -2147417850 (0x80010106)'

                     

                    [2017-07-24T17:49:00:                          :  DEBUG] Rpci: Sent request='deployPkg.update.state 4 101 C:/Windows/TEMP/vmware-imc/guestcust.log@No error message found for error code -2147417850 (0x80010106)', reply='', len=0, status=1

                     

                    [2017-07-24T17:49:00:             GuestCustUtil:  DEBUG] Status marker file C:/Windows/.post-gc-status doesn't exist
                    [2017-07-24T17:49:00:                          :  ERROR] error number 80010106, No error message found for error code -2147417850 (0x80010106)
                    [2017-07-24T17:49:00:                          :   INFO] GuestCustUtil exiting."
                    • 7. Re: vmware deploy from template with guest customization error
                      vijayrana968 Master
                      vExpert

                      You mentioned that VM id deploying fine without installing application. To reproduce the issue, deploy one VM with application installed and one without install, check the MAC address changes.

                      • 8. Re: vmware deploy from template with guest customization error
                        LucaMeglioli Novice

                        i think i dind't understand ,

                         

                        if i deploy 2 VM they MUST have 2 different mac address, doing that what can i check?

                         

                         

                        if i deploy a vm from the template on a snapshot WITHOUT application -> deploy ends good

                         

                        if i deploy a vm from the same template on a differente snapshot (where softwae have benn installed) -> deploy ends with this error

                        • 9. Re: vmware deploy from template with guest customization error
                          vijayrana968 Master
                          vExpert

                          By deploying two VMs I meant to compare their logs. I know VMs will have separate and unique MAC but some applications are sensitive to MAC address where you need to make some changes in VMX. What is the application name you are using.

                           

                          For previous versions I can see Customization of templates or clones in VirtualCenter may fail if third party software is installed (1006025) | VMware K…