2 Replies Latest reply on Jun 21, 2017 8:42 AM by continuum

    ESXi 4.1 2TB Limit and Missing VMFS Partition - Both Main Volume and Snapshot got killed

    JamesRCurrie Lurker

      Hello!

       

      Looking for some assistance here. Brief environment rundown:

       

      2 ESXi 4.1 Hosts

      1 ESX 4.1 Host

      1 EqualLogic iSCSI SAN

      Mutiple Datastores, one of which (Datastore02) is now broken (which contains 2 VMDKs for a production Exchange Server)

      No backup (<sigh>, I know)

       

      Without realizing what I was doing, I extended the SAN volume for Datastore02 from 2 TB to 2.2 TB. It all started going wrong after that. Rescan caused the available space to expand, but I was unable to grow Datastore02 to use the extra space due to an error. Realized that there is a 2 TB limit. Tried to shrink, SAN GUI won't allow shrink. Tried to move around VMDKs from space-constrained Datastore02, couldn't move files. Tried vMotioning guests back and forth, as well as restarting Hosts. Datastore02 is now inactive and VM is inaccessible. SAN prompted for snapshot before I expanded to 2.2 TB, which I did, but the snapshot is displaying the same symptoms now: After presenting the LUN and trying to Add Storage in vSphere, ESXi sees the 2 TB as free space, rather than having a VMFS partition (well, there's a 15 MB VMFS partition, but that's not enough), and it wants to format the free space.

       

      From a few tools I've used, it seems that the VMDK files are still in there, but neither ESXi 4.1 nor ESXi 5.1 (that I just installed) can see anything but free space in the LUN.

       

      Any questions or suggestions are appreciated. Actually, I didn't start this post by using the word "urgent", but as you may have guessed it's pretty urgent. Anything at all (tips, tools, etc) is greatly appreciated!

       

      Thank you,

      James