3 Replies Latest reply on May 31, 2017 7:53 AM by samoed

    View Planner 3.6 and vCenter 6.5 support

    samoed Lurker

      Hello All,

       

      We are having an issue getting the 3.6 View planner appliance to connect to our vCenter which is running 6.5d (appliance).   Both the appliance and vcenter are sitting on the same subnet so I know its not a firewall issue.       Below is the output of the viewplanner.log after running two test connection attempts (1st using proper creds, 2nd using incorrect creds to verify i get a different message).  I dont recall seeing a vcenter compatibility list for view planner.  Any ideas?

       

      TEST AGAINST VC WITH PROPER CREDS

      2017-05-30 20:09:18,010 DEBUG    Saving vCenter configuration with parameters: {                                                                                                 u'VCserver': u'10.XX.XX.31', u'datacenter': u'D2', u'VCuser': u'administrator',                                                                                                  u'VCpasswd': '*******'}

      2017-05-30 20:10:05,388 DEBUG    Saving vCenter configuration with parameters: {u'VCserver': u'10.XX.XX.31', u'datacenter': u'D2', u'VCuser': u'administrator', u'VCpasswd': '*******'}

      2017-05-30 20:10:07,900 DEBUG    Testing the vCenter connection.

      2017-05-30 20:10:07,900 DEBUG    key: VCserver, value: 10.XX.XX.31

      2017-05-30 20:10:07,901 DEBUG    key: datacenter, value: D2

      2017-05-30 20:10:07,901 DEBUG    key: VCuser, value: administrator

      2017-05-30 20:10:07,901 DEBUG    key: VCpasswd, value: XXXXXXXXXX

      2017-05-30 20:10:07,901 DEBUG    Testing an instance of vCenter Interface.

      2017-05-30 20:10:07,901 DEBUG    vCenter info administrator   ********    10.XX.XX.31

      2017-05-30 20:10:07,990 DEBUG    vCenter Version: 6.5.0

      2017-05-30 20:10:08,004 ERROR    Error in testing the vCenter connection: Traceback (most recent call last):

        File "/build/mts/release/bora-3657232/performance/viewplanner/Harness/root/vc_interface.py", line 127, in testVCConnection

        File "/build/mts/release/bora-3657232/performance/viewplanner/Harness/root/pyVmomi/vim/__init__.py", line 400, in GetDatacenter

      vim.fault.NotFound: (vim.fault.NotFound) {

         dynamicType = <unset>,

         dynamicProperty = (vmodl.DynamicProperty) [],

         msg = <unset>,

         faultCause = <unset>,

         faultMessage = (vmodl.LocalizableMessage) []

      }

       

       

      TEST AGAINST VC WITH INCORRECT CREDS

      2017-05-30 20:10:27,403 DEBUG    Saving vCenter configuration with parameters: {u'VCserver': u'10.XX.XX.31', u'datacenter': u'D2', u'VCuser': u'administrator', u'VCpasswd': '*******'}

      2017-05-30 20:10:29,599 DEBUG    Testing the vCenter connection.

      2017-05-30 20:10:29,600 DEBUG    key: VCserver, value: 10.XX.XX.31

      2017-05-30 20:10:29,600 DEBUG    key: datacenter, value: D2

      2017-05-30 20:10:29,601 DEBUG    key: VCuser, value: administrator

      2017-05-30 20:10:29,601 DEBUG    key: VCpasswd, value: XXXXXXXXXX

      2017-05-30 20:10:29,601 DEBUG    Testing an instance of vCenter Interface.

      2017-05-30 20:10:29,602 DEBUG    vCenter info administrator   ********    10.XX.XX.31

      2017-05-30 20:10:32,670 ERROR    Error in testing the vCenter connection: Traceback (most recent call last):

        File "/build/mts/release/bora-3657232/performance/viewplanner/Harness/root/vc_interface.py", line 123, in testVCConnection

        File "/build/mts/release/bora-3657232/performance/viewplanner/Harness/root/pyVmomi/vim/__init__.py", line 47, in Connect

        File "/build/mts/release/bora-3657232/performance/viewplanner/Harness/root/pyVmomi/vim/__init__.py", line 67, in Login

        File "/build/mts/release/bora-3657232/performance/viewplanner/Harness/root/pyVmomi/VmomiSupport.py", line 515, in <lambda>

        File "/build/mts/release/bora-3657232/performance/viewplanner/Harness/root/pyVmomi/VmomiSupport.py", line 324, in _InvokeMethod

        File "/build/mts/release/bora-3657232/performance/viewplanner/Harness/root/pyVmomi/SoapAdapter.py", line 1159, in InvokeMethod

      vim.fault.InvalidLogin: (vim.fault.InvalidLogin) {

         dynamicType = <unset>,

         dynamicProperty = (vmodl.DynamicProperty) [],

         msg = 'Cannot complete login due to an incorrect user name or password.',

         faultCause = <unset>,

         faultMessage = (vmodl.LocalizableMessage) []

      }