8 Replies Latest reply on Oct 28, 2017 3:39 PM by longlanh

    Unable to backup Windows AD Server with VMware Tools installed

    Ybbom Lurker

      Hi Folks

       

      We have some Windows Server 2012 R2 VMs running in DMZ environment. An easy way to backup them is using the integrated Windows Server backup functionality. We recently updated our VMware Tools version from 10.0.9 to 10.1.5 and after this update we weren’t able to use successfully run a system state backup with the integrated Windows Server backup function because we got the following error message every time we tried to backup them:

       

      Error in backup of C:\windows\\systemroot\ during enumerate: Error [0x8007007b] The filename, directory name, or volume label syntax is incorrect.

       

      After short investigation we found a registry key under “HKLM\SYSTEM\CurrentControlSet\Services\vsock” named “ImagePath” with the value “\SystemRoot\system32\drivers\vsock.sys” from type “REG_EXPAND_SZ”. This paths originally references to a device driver SYS file under “C:\windows\system32\drivers\vsock.sys” which is used for the vSocket Service API (prior known as VMCI as far as I know).

       

      After we changed this value from “\SystemRoot\system32\DRIVERS\vsock.sys” to “system32\DRIVERS\vsock.sys” we were able to successfully backup our Servers without any error messages. We also tried to reinstall/repair the VMware Tools and also installed the latest stable 10.1.7 but the VMware Tools provides every time an incorrect path. 

      Is someone else facing this issue or aware of it?

       

      @VMware: Is there any change planned in a future VMware Tools releases?

       

      Kind regards,

      Ybbom