1 Reply Latest reply on Sep 12, 2017 7:01 PM by hukay

    Could not connect to one or more vCenter Server systems

    EricGustafson Lurker

      I can't quite make heads or tails of the issue, but it appears I have a duplicate vcsa or certificate issue.  This error just started occuring once da, albeit a few host issues and so the vcenter and psc both ended up on a different host after a hard down of the host they were on.  The original host became mostly unresponsive yet the vm's were still functioning - I had to pull the power which dumped all the vm's on it.  All services appear to be running.

       

      In any case I'm getting the connection err now.

           Could not connect to one or more vCenter Server systems:

           https://labsvccor01.xxx.xxxxx.xxx:443/sdk

       

      I even tried installing a new vcsa(6.5) with the same fqdn, joined it to the psc and am getting the same error - with no hosts or anything added yet.  I can however logon through vcenter web client and see my 2 nodes under system configuration (vcenter and psc).

      under the psc, manage, cert authority, I see a duplicate host (esx06) and now an entry to my freshly installed vcenter (based on cert date). I also see 3 other instances of the vcenter, each with the same cert date. 

      Since the issue exists with my 'newer' vcas install, I wish to shut down the new one and restart my original vcsa that I've removed from inventory..

       

       

       

      Should there be more than 1 cert for the same vcsa?

       

      Looking at the services, it shows a dupe as well.

       

      Service Type: vcenterserver

              Service ID: ef87ff67-971c-414a-8e78-719954cf892c

              Site ID: vsphere-local-cor

              Node ID: 63d64820-3cec-11e7-a7bd-000c297c35a5

              Owner ID: vpxd-f19f21ae-a536-4871-9718-7b7cb1008901@vsphere.local

       

        Service Type: vcenterserver

             Service ID: c0c4c832-0966-44e6-a3d3-dc6ea6fd7de5

             Site ID: vsphere-local-cor

             Node ID: 7979e9b8-a785-11e6-ab71-000c29140f31

             Owner ID: vpxd-f19f21ae-a536-4871-9718-7b7cb1008901@vsphere.local

       

      How do I know which entries to remove or can I remove all and re-add my original vcenter?  What about re-issuing certs, would that be of any help?  Grasping at straws here with limitied know-how..

      Any help would be appreciated.

      Eric

       

      Interestingly enough, I'm seeing this same issue at another site....completely separate vcsa/psc setups (same global company though)

       

      ref: “Failed to verify the SSL certificate for one or more vCenter Server Systems” error in the vSphere Web Client (2050273) …