1 2 3 Previous Next 40 Replies Latest reply on Aug 6, 2018 11:57 PM by rushdirizvygmail

    vCSA 6.5 installation stuck at RPM installation

    rushdirizvygmail Novice
    vExpert

      I tried both ways of installing vCSA as manual OVA deployment and through GUI. Both had same impact and seems I can't get through with the installation.

       

      vcenter 6.5.JPG

      vCenter RPM.JPG

       

      Please note I have downloaded the latest build to do the installation.

       

      Appreciate your urgent help on this.

       

      Rushdi

        • 1. Re: vCSA 6.5 installation stuck at RPM installation
          JunMai Lurker

          I am having the exact issue... Stuck at 80% for overnight.

           

          I have tried different builds ... 6 attempts all came to the same end.

           

          I am using DHCP for the IP... Wonder if that could be causing the issue??

          Don't have a fixed address to give it at the moment.

           

          Thank you any assistance you might be able to give.

           

          Jun

          =================

          I did the same setup with a fixed address and it failed the same way.


          Also tried from a windows 7 Desktop, failed the same way...

           

          Installer log shows:

          2017-04-19T21:38:48.008Z - debug: Failed to get url of file in guest vm:ServerFaultCode: The guest operations agent could not be contacted.

          2017-04-19T21:38:48.008Z - debug: [610]pollRpmInstallProgress:getGuestFileErr:ServerFaultCode: The guest operations agent could not be contacted.

          2017-04-19T21:38:55.793Z - debug: initiateFileTransferFromGuest error: ServerFaultCode: The guest operations agent could not be contacted.

          2017-04-19T21:38:55.794Z - debug: Failed to get fileTransferInfo:ServerFaultCode: The guest operations agent could not be contacted.

           

          ession with lstActTm Wed Apr 19 2017 05:07:09 GMT-0700 (PDT)

          2017-04-19T19:07:27.573Z - debug: initiateFileTransferFromGuest error: ServerFaultCode: The guest operations agent could not be contacted.

           

           

          This looks like a failure within the Installer!!

           

          Really Need some help please...

          • 2. Re: vCSA 6.5 installation stuck at RPM installation
            rushdirizvygmail Novice
            vExpert

            JunMai,

             

            Have you tried with the build which was just release 1-2 weeks back?

             

            I haven't been able to give it a try..

             

            Cheers!

            • 3. Re: vCSA 6.5 installation stuck at RPM installation
              lwiedmer Lurker

              I had the same issue -- turns out I forgot to disable DRS on the cluster. So mid-update the appliance was migrated to a new host, causing it to hang. I re-ran the update after setting DRS to partially-automated and all was well.

              • 4. Re: vCSA 6.5 installation stuck at RPM installation
                JunMai Lurker

                None of those were my issues or situations.

                 

                After we got an AD and a DNS server installed, then we could get the vCenter server installed.

                 

                This has been one of the most annoying situations I have experienced.

                Also the installer is so convoluted. Why can't they just make it an iso or a OVF file????

                • 5. Re: vCSA 6.5 installation stuck at RPM installation
                  mark_l_zhang Novice

                  Today, I tried the latest VCSA 6.5 in my lab. I met the same issues.

                  But eventually, it succeeded.

                   

                  I installed from a windows platform, and got the RPM sucks 80%.

                  I opened the log files:

                  Failed to get fileTransferInfo:ServerFaultCode: Current license or ESXi version prohibits execution of the requested operation.

                   

                  So I changed to another ESXi with enterprise license. Delete the VMs from disks, restart the deployment.

                  It succeeded.

                  I think vcsa need some special features on the VMs. So you need check your licenses as well.

                  I used licenses before is a node licenses, only ESXi box without any features on it, like vMotion, DRS etc.

                  It was not written in the documents. Hope it helps.

                  • 6. Re: vCSA 6.5 installation stuck at RPM installation
                    AskChiz Novice

                    You may have your hosts locked down as per below as I did.

                    https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1016039

                     

                    the message about installing an RPM is bogus and misleading, it is actually trying to logon to your host to check the successful deployment of the appliance.

                     

                    Try reversing the lockdowns in the article above with these two commands.

                     

                    To re-enable an ESXi/ESX host's Managed Object Browser (MOB):
                    vim-cmd proxysvc/add_np_service "/mob" httpsWithRedirect /var/run/vmware/proxy-mob

                     

                    To re-enable the Host Welcome login web page:
                    vim-cmd proxysvc/add_tcp_service "/" httpsWithRedirect localhost 8309

                    • 7. Re: vCSA 6.5 installation stuck at RPM installation
                      anksos Novice
                      vExpert

                      Still the same issue for me,

                       

                      I checked as well the thing with the proxy and is normal set on my ESXi 6.5 Update 1.

                       

                      In my case I am trying to deploy a PSC 6.5 Update 1 (not vCenter Server) because it will be external the PSC.

                       

                      Any idea?

                       

                      My log of the installer is showing this:

                      ...

                      2017-08-18T08:32:32.876Z - debug: [489]pollRpmInstallProgress:getGuestFileErr:ServerFaultCode: The guest operations agent could not be contacted.

                      2017-08-18T08:32:35.433Z - debug: Updated current session with lstActTm Fri Aug 18 2017 10:32:08 GMT+0200 (Central Europe Daylight Time)

                      2017-08-18T08:32:42.879Z - debug: initiateFileTransferFromGuest error: ServerFaultCode: The guest operations agent could not be contacted.

                      2017-08-18T08:32:42.880Z - debug: Failed to get fileTransferInfo:ServerFaultCode: The guest operations agent could not be contacted.

                      2017-08-18T08:32:42.880Z - debug: Failed to get url of file in guest vm:ServerFaultCode: The guest operations agent could not be contacted.

                      2017-08-18T08:32:42.880Z - debug: [490]pollRpmInstallProgress:getGuestFileErr:ServerFaultCode: The guest operations agent could not be contacted.

                      2017-08-18T08:32:52.879Z - debug: initiateFileTransferFromGuest error: ServerFaultCode: The guest operations agent could not be contacted.

                      2017-08-18T08:32:52.880Z - debug: Failed to get fileTransferInfo:ServerFaultCode: The guest operations agent could not be contacted.

                      2017-08-18T08:32:52.880Z - debug: Failed to get url of file in guest vm:ServerFaultCode: The guest operations agent could not be contacted.

                      2017-08-18T08:32:52.880Z - debug: [491]pollRpmInstallProgress:getGuestFileErr:ServerFaultCode: The guest operations agent could not be contacted.

                      2017-08-18T08:33:02.876Z - debug: initiateFileTransferFromGuest error: ServerFaultCode: The guest operations agent could not be contacted.

                      2017-08-18T08:33:02.878Z - debug: Failed to get fileTransferInfo:ServerFaultCode: The guest operations agent could not be contacted.

                      2017-08-18T08:33:02.878Z - debug: Failed to get url of file in guest vm:ServerFaultCode: The guest operations agent could not be contacted.

                      2017-08-18T08:33:02.878Z - debug: [492]pollRpmInstallProgress:getGuestFileErr:ServerFaultCode: The guest operations agent could not be contacted.

                      2017-08-18T08:33:12.876Z - debug: initiateFileTransferFromGuest error: ServerFaultCode: The guest operations agent could not be contacted.

                      2017-08-18T08:33:12.878Z - debug: Failed to get fileTransferInfo:ServerFaultCode: The guest operations agent could not be contacted.

                      2017-08-18T08:33:12.878Z - debug: Failed to get url of file in guest vm:ServerFaultCode: The guest operations agent could not be contacted.

                      2017-08-18T08:33:12.878Z - debug: [493]pollRpmInstallProgress:getGuestFileErr:ServerFaultCode: The guest operations agent could not be contacted.

                       

                      And is keep stucking on 80% during the Installing RPM/.

                       

                      Thank you in advance.

                      • 8. Re: vCSA 6.5 installation stuck at RPM installation
                        anksos Novice
                        vExpert

                        Hi @,

                         

                        After trying to troubleshoot this issue I realized when it goes to 80% and power on the Photon (VCSA or PSC) open the console and click enter. It will go through all the process and you will see in the end that the stage 2 configuration will start and will finish the installation successfully but the Installer will be still stuck on 80%. Most probably is some bug or your ESXi is not reporting correctly to the installer so that's the reason is stucking there but the installation will be successful.

                         

                        For me that was the solution of my issue. You can close even the installer it will not affect your installation of the VCSA/PSC.

                         

                        Thanks

                        2 people found this helpful
                        • 9. Re: vCSA 6.5 installation stuck at RPM installation
                          vijayrana968 Master
                          vExpert

                          How did you checked the logs, I am installing fresh VCSA with embedded PSC and facing same issue. How to check logs as console is only showing PHOTON OS logo. 

                          • 10. Re: vCSA 6.5 installation stuck at RPM installation
                            vijayrana968 Master
                            vExpert

                            This is the repeated error in installation logs located at C:\Users\Administrator\AppData\Local\VMware\CIP\vcsaInstaller folder on machine I am deploying appliance from.

                             

                            • 11. Re: vCSA 6.5 installation stuck at RPM installation
                              Ripley8 Hot Shot

                              Oddly enough I haven't had this issue until today, and all my class systems have suffered the same issue. Tried it on my demo kit and got exactly the same, RPM failed to install.

                              • 12. Re: vCSA 6.5 installation stuck at RPM installation
                                david.sjostrand Enthusiast

                                I'm guessing you've run in to the same problem as I did. The ovf image on the iso has an expiring root account password. After the root password has expired it can't be changed during the deployment. In the image I've been using (VMware-VMvisor-Installer-6.5.0-4564106.x86_64.iso) the expiration date is oct 22. In effect, the images are time-bombed and will only work one year after being released by vmware.

                                Capture.JPG

                                1 person found this helpful
                                • 13. Re: vCSA 6.5 installation stuck at RPM installation
                                  tonygibbs16 Lurker

                                  I have this same issue, but I am stuck at 95%.

                                   

                                  I am using the following install media within Workstation Pro 14 with an evaluation licence.

                                   

                                  As I am trying out and learning VMWare myself for the first time, then I don't know which log files to check.

                                   

                                  I did the installation yesterday using the OVF file in the vcsa directory of the VCSA ISO.

                                   

                                  If I reset the VCSA VM then I get the stage 2 screen to continue configuring, but then it will not let me finish because it says check that the RPM has finished.

                                   

                                  I have checked the password age of my root account, and that is ok.

                                   

                                  I am running on Windows 10 Pro that is on a domain and has BitLocker enabled.

                                   

                                  Any ideas?

                                   

                                  Cheers,

                                       Tony

                                  • 14. Re: vCSA 6.5 installation stuck at RPM installation
                                    prashiprince Lurker

                                    Thanks David, I had same issue and had to download latest ISO from VMware.

                                    1 2 3 Previous Next