11 Replies Latest reply on Apr 19, 2017 7:09 PM by BrianCHW

    ESXi 6.5 VMs wont start

    DingoTaz Novice

      Hello. Workstation 12.5.4. I have esxi6.5 and vCenter 6.5 all nested. When I go to run a VM within ESXi (even vCenter), it wont power on, hanging at some random point with an error in the events "Running VMware ESX in a virtual machine will result in degraded performance. Do you want to continue?". Obviously no way of answering this (I believe in 6.0 and earlier you could use the C# client but that's not there anymore in 6.5).

       

      It was working for me real nice (I think until the update, or it may have been esxi 6.5). Any ideas?

       

      Thanks

        • 1. Re: ESXi 6.5 VMs wont start
          RJB3ST Enthusiast

          Hello,

           

          Just quickly to understand your current setup, so you have 1 host and 1 vCenter running in VMware workstation? or do you have the host running on VMware workstation and vCenter on the host?

           

          So with the latest ESXi 6.5 version you will get a host web client, if you go to https://IP Address/ui  it should take you to the host web client. Is that where you are getting the error?

           

          You can try adding the following line to your .vmx file for the VM, this should automatically answer any questions when the VM boots:

           

          msg.autoAnswer = "TRUE"

           

          If this is set as True, try it as False, seen a few articles about this but they say different things and I'm currently rebuilding my lab and have 0 hosts to try it out!

           

           

          1 person found this helpful
          • 2. Re: ESXi 6.5 VMs wont start
            DingoTaz Novice

            Hello. You may be on to something. If I click on the VM and go to manage/events it shows it is asking a dumb question.... that the VM (vCenter) is running in a virtualised environment and may run slowly. Do you want to continue. And of course no way to answer the question.

             

            I'll play around with your setting let you know. I'm also thinking of poewrcli there is a get-question cmdlet or something like that that may be useful.

             

            thanks

            • 3. Re: ESXi 6.5 VMs wont start
              DingoTaz Novice

              Hello. I've had some time to experiment now. I found this KB which describes the problem.

               

              KB 21087839 When powering on a nested virtual machine, vSphere Client reports the warning: Running VMware ESX in a virtual machine w…

               

              I added a config value of msg.autoanswer to the nested VM (which lives on the ESX host datastore). One value seemed to stop the message appearing in the VM's event tab in ESX but it still hung and wouldn't complete powering on. The other value had no effect. (can't remember true or false what did what).

               

              I built a fresh esxi 6.5 inside workstation and same problem. So either ESXi6.5 they have mucked this up (like so many other things in it) or Workstation has some issues. Not sure which but it certainly used to work. I might add a ESX 6.0 host see what happens.

               

              Oh and using powercli get-answer says there are no questions for the VM. And starting the VM from powercli doesn't work either. Same problem.

              • 4. Re: ESXi 6.5 VMs wont start
                TomHowarth Guru
                vExpertUser Moderators

                have a good read of William Lam's site he is the uncrowned king of nested virtualization

                 

                http://www.virtuallyghetto.com/nested-virtualization

                • 5. Re: ESXi 6.5 VMs wont start
                  DingoTaz Novice

                  William Lam in his excellent site unfortunately doesn't cover running it in Workstation.

                   

                  I have more info. I have read the vmware.log file in the esxi datastore of the VM trying to start. It doesn't indicate any errors, but setting msg.autoAnswer = "TRUE" does answer the question (this is noted in the log file). However all VMs, and even a new one I created, won't power on.

                  I have gone all the way back to workstation 12.0 and still no good. I have tried esxi 6.0 fresh install with local datastore and still no good.

                   

                  It used to work. I really don't know what's going on. I can only think it's a Windows 10 issue, a conflict with another program or a BIOS issue as the computer's bios has been upgrade (and yes all the virtual technologies are enabled).

                  • 6. Re: ESXi 6.5 VMs wont start
                    DingoTaz Novice

                    Good news. Now working. Uninstall avast anti-virus and all good. A recent update must have broken it.

                    • 7. Re: ESXi 6.5 VMs wont start
                      BrianCHW Novice
                      vExpert

                      Was the issue with Avast on your host machine?  Running into the same issue here with no fix at the moment...

                      • 8. Re: ESXi 6.5 VMs wont start
                        BrianCHW Novice
                        vExpert

                        So after trying all of the per VM switches and completely building the vCenter and Hosts from scratch I still can't get nested VM's to power on.  Is no one else having this issue?  I am debating on going back a few versions and seeing what / where things broke.

                        • 9. Re: ESXi 6.5 VMs wont start
                          RJB3ST Enthusiast

                          Hello,

                           

                          I would assume Avast was on his host machine. Have you got it running on your computer? If so have you tried to uninstall it?

                           

                          Kind Regards,

                          RJ

                          • 10. Re: ESXi 6.5 VMs wont start
                            BrianCHW Novice
                            vExpert

                            My next step, I will let you know!  I had disabled it before with no luck.  I took the VM's to another machine and they worked which is odd.  The rig is a Acer Predator with a i7 6700k CPU.

                            • 11. Re: ESXi 6.5 VMs wont start
                              BrianCHW Novice
                              vExpert

                              Uninstalling Avast worked like a charm...enabling or disabling the features in the software did nothing.  Life is good now, thanks for the help!