4 Replies Latest reply on Jul 24, 2019 6:15 PM by lynxinator

    ESXi 6.5 - maxView Storage Manager

    gah005 Lurker

      Has anyone had any luck getting the maxView Storage Manager to work with ESXi 6.5.0 (Build 4887370)?

       

      I've tried installing the latest version maxView Storage Manager v2.03.22476 vibs which either caused a PSOD or rendered the system into a totally unusable state.

       

      I was able to get the 1.08-21375 version of the maxView vibs to install correctly however upon logging in to the maxView console, it states "No controllers were found in this system."

        • 1. Re: ESXi 6.5 - maxView Storage Manager
          jkaldon Lurker

          I too need some help with getting maxView to run on esxi 6.5!

          • 3. Re: ESXi 6.5 - maxView Storage Manager
            Vme332c Novice

            I think you guys are in for a rude awakening (maxview ALWAYS shows Optimal, even when you pull drives w alarm sounded, and esxi web int->manage shows degraded, even after a rescan in maxview, ALWAYS optimal).  also i have never been able to get arcconf to work under any guestOS (win or linux). it always shows error, CIM (something).  Ive confirmed via curl and web browser, that cim port 5989 is accessable.

             

            While i spent days fighting with these adaptec Raid cards to get monitoring working ( series 6 and series 8 adaptec cards, 6805 and an 8805 ),  i found this great thread which finally is the only known solution (all other cim providers get you PSOD after 20-30m post boot).  Ofcourse all you need is the adaptec VIB to mount a adaptec datastore (easy) what good is a raid card without the ability to MONITOR ITs status??
            It was nice of adaptec support to answer the phone,  but they were useless,  lady said, we have never heard of any issue with VMware, on any of our cards.  Only option is to file a case with them, which lady warned would take several months, and most likely will offer no solution (nice).
            So adaptec is a dead end on vmware.
            edit: update,  i WAS able to get arcconf working , you wont believe this,  but the solution is to use the LATEST guestOS arcconf version (from the 8805 card,  version v2_06_23164)https://storage.microsemi.com/en-us/speed/raid/storage_manager/msm_vmware_v2_06_23164_zip.php
            at this link (again, just arcconf, for win64, its in a folder named cmdline , in the archive linked below.    maxview from his version wont show any card found):
            Adaptec - Adaptec Driver: maxView Storage Manager v2.06.23164 for VMware Download Detail
            So to recap (and this is abhorrent, adaptec):
            on 6.0 or 6.5 esxi,  you need to run the old drivers and CIM .vibs (and old arcconf.vib)  listed in posts/replies above (the 1.08....)
            and then use the lastest arcconf.exe (for guest os win64, link is a few lines up), and that will give you accurate data from your raid card (both 6805 and 8805).
            -no matter what you do, with MSM,  best case - you will not get any valid data from MaxView Storage manager (MSM).   worst case, PSOD 10-30m after boot (and alt-F12 filled w SCSI timeouts once esxi boots,  the newer CIM VIBs must be crashing the card's OS is all i can think of)
            (maxView is still no go in terms of useful data/working).  I have also tried every adaptec driver/arcConf.vib/arc-cim.vib combination (very old versions, as well as latest apr 2018 versions for the 8805 card)
            • 4. Re: ESXi 6.5 - maxView Storage Manager
              lynxinator Lurker

              VMe332c,

               

              I am unable to connect get the maxview windows storage manager / msm app or the arcconf.exe to connect to a Adaptec 72405 RAID card that is in a server running ESXi 6.7 update 2.

               

              First I installed the adaptec 7 driver for esxi v6.0.6.2.1.52033-5095623.

               

              Next, I tried both the vmware-esx-provider-arc-cim-provider.vib and the vmware-esx-provider-arcconf.vib drivers as well as the arcconf app that is included in the two versions of the msm that are listed below.

               

              msm_vmware_v2_05_22932

               

              msm_vmware_v3_01_23531

               

              After I issue the arcconf connect command on either port 5989 or port port 5988 it appears to accept the command because it does not display an error.  Next I issue the "arcconf getconfig 1" command and I received the error message below.

               

              "CIM Exception: Error initializing provider arcCLIProvider from arcCLIProvider for class ARC_CLIExecutor.."

               

              I tried downloading the versions that you posted, but the links no longer worked.  I then tried googling the file names and was unable to find the files.

               

              The second problem is the card or array status info does not appear under host / monitor / hardware / storage in the web vphere client v1.33.3.  Do you know how to get that to work?

               

              If there is not a solution, is there a work around?  One thing that popped up on one of my google searches was nagios monitoring, but I was not able to find any information about it monitoring a adaptec card with ESXi 6.7 update 2.