1 2 Previous Next 22 Replies Latest reply on Apr 24, 2019 11:28 PM by AlexLuther

    XP VM suddenly slow, Win 7 fine

    Glonky Lurker

      I have a number of Windows XP and Windows 7 virtual machines installed on my Win10 host that have worked fine for months.

      Today I had two Win 7 machines started and started a Win XP one, the performance on the XP VM was extremely slow or stalled for minutes at a time. The Win 7 machines were still running OK.

      I tried closing all other VM's and XP was still slow, tried a XP and host reboot and XP still slow (10 mins to restart XP).

      I have also tried another two WinXP VM's and they are also slow.

      I moved one of the XP VM's to another host and it goes fine.

       

      XP task manager shows 100% cpu usage with ~95% kernel times. Host machine is around 20% usage and still responds OK.

      Any suggestions?

      VMware is also saying the vmware tools are out of date and no 3D graphics will be avail.

      Not sure if related but this morning I also couldn't log in to my host Win10 profile until I tried a windows update (no updates) and then restarted (as suggested on forums).

      I might try a different user profile when this XP finishes updating vmware tools (40 mins into it so far, zzzz)

       

      Update: Feb 13

      Tried on a different profile and same, reinstalled VMware and still the same (XP VM slow, Win7 VM fine).

      Looks like the main slow point is disk access, with nothing running I can bring up the start menu pretty quick. Updating the tools took around 1.5 hours.

      Tried running an xp vm that a colleague had made with workstation and it was set to use 8 cores and it near froze the host.

        • 1. Re: XP VM suddenly slow, Win 7 fine
          Kinimod Novice

          Hi Glonky,

           

          we have found your post after long time loking all over the internet. We are facing similar problem with all our Win XP machines. It started act like you described after we had installed Mitsubishi GX Work software, which was propably the reason, but we are not sure.

          Please, did you resolved this issue? My colegue already recovered his laptop and now everithing is working fine, but I still dont want to give it up...

           

          My Win7 machines are OK, just all those WinXP. My host is Win7 64x Pro, HP 650 G1 and I also have no problem with those VM for couple of years till last monday.

           

          You are propably my only hope before I chose to recover my laptop.

           

           

          thanks for any advice

           

           

          dominik

           

          dominik.juhasz@ats-global.com

          • 2. Re: XP VM suddenly slow, Win 7 fine
            CharlesGilley Novice

            Glonky - every time my Xp VM went into slow mode, a services thread was compute bound.  I just kill off the tread.  Not much feedback from Microsoft considering Xp no longer has support.

             

            cg

            • 3. Re: XP VM suddenly slow, Win 7 fine
              Glonky Lurker

              Hi Dominik ,

               

              Still no solution for my xp yet,  although I did find one that is still working OK. I am just moving the rest to win7.

              I don't use GX works but I do use a lot of Rockwell Software on my base machine.

               

              Wayne

              • 4. Re: XP VM suddenly slow, Win 7 fine
                Glonky Lurker

                Hi Charles,

                 

                Do you identify the compute bound thread by CPU usage? The only service thread I have (services.exe) is not too bad on CPU (< 10%) but I also cannot terminate it as it is a critical system process. Task manager is using around 1/3 of my CPU (when other applications are starting) and vmtools is using around another 1/3 CPU.

                 

                If I wait for everything to complete loading the CPU usage drops, but increases as soon as I start and disk activity. Startup takes around 30 secs till the black Windows loading screen is visible, then another couple minutes till the windows starting, then around 3 minutes till I get a login screen. Logging in takes another 5 minutes or 15 minutes till the CPU drops. As a thought I did try killing the windows update as I guess this is not required anymore but it didn't help.

                 

                Wayne

                • 5. Re: XP VM suddenly slow, Win 7 fine
                  Kinimod Novice

                  Hi Glonky.

                   

                  we are using, rockwell, siemens, omron and few other softs, that still need XPs, so this was/is a huge issue for us. My colegue has found solution or reason for our case. It was because of AVAST. New update works somehowe bad. Its Hardware-assiseted virtualization option don't work as it should. When we uncheck the option and reboot our host PC, every XP vm works fine, BUT only till new reboot of host. So lets say we got something like half succes...

                   

                  I am thinking about upgrading to Win10 as solution, or I have to wait for new update from AVAST.

                   

                  I will inform you. Till then, thaks a lot for andwer...

                  • 6. Re: XP VM suddenly slow, Win 7 fine
                    Glonky Lurker

                    Thanks,

                     

                    Stopping the hardware-assisted virtualization option in avast works for me too when I finally found it (under Settings / Troubleshooting for any others looking). Will see what it's like after a reboot.

                     

                    As a side note I am running on Windows 10 with Avast Pro on my work computer which has this XP slow issue (running on VMWare licensed player), but my home computer on Windows 10 with Avast Free does not have this option, but then it doesn't have this slow XP problem either (running on VMWare free player).

                     

                    Still good after a second reboot of my host. Thanks again.

                     

                    Wayne

                    • 7. Re: XP VM suddenly slow, Win 7 fine
                      CharlesGilley Novice

                      Yes, I just open up task manager and kill it off.  There are many services.exe thread, and if one is stuck at 100%, it's obviously misbehaving - so goes my thought process.  One thing you can do to get task manager from being such a hog - slow down the updates.  Then you get a more reasonable reading as to what is taking up the time.

                       

                      fwiw, the runaway services.exe is a well known issue in Xp.  If the cpu percentage is hopping around, then this is not the same thing I typically see.

                      • 8. Re: XP VM suddenly slow, Win 7 fine
                        Kinimod Novice

                        ...so I have just finieshed with upgrading to Win10. Actually it was a completly clear install, so I had gigantic hope that it will help. Nope... it did not. I got same situation, after new instalation. I thought that it might be in my virtual XP, so I have craated new one... result was same.

                         

                        I think we have to solve this with AVAST support...

                         

                        till then, we have to use our "reboot magic"...

                         

                         

                        strange think is that this behavior is same for all of our compatny laptops with same Avast... somebody has W7, somebody W10 with same problem...

                         

                        golden PLCs...

                         

                        Dominik

                        • 9. Re: XP VM suddenly slow, Win 7 fine
                          ClaudePalm Lurker

                          Hi.

                          I had the same problem, Very slow after last VMWare update to 12.5.4. (XP guest, Win 7 pro 64 host)

                          I use AVG antivirus. Disabled it but no difference

                          I finally solved it.

                          When I checked the Task Manager I found one of the xvchost.exe was using 98-99% which explained why slow. I went to Services and shut down various services until I got to Automatic Updates. That brought CPU usage to 0% for that service. Back to fast operation. I re-enabled it and then stopped Automatic Updates from the Control Panel. Still all OK.

                          But I have another XP Guest that also went the same way but stopping Auto Updates did not help it. Back to Services and when I set Windows Installer to Manual instead of Automatic It came good.

                           

                          Claude Palm

                          • 10. Re: XP VM suddenly slow, Win 7 fine
                            Glonky Lurker

                            Hi Dominik,

                             

                            Got a response from Avast about the issue, they suggested I uninstall and reinstall the Behavior Shield component.

                            I have tried this and re-enabled the hardware assisted virtualization and XP machine is behaving itself now. Hopefully won't happen again.

                             

                            Wayne

                            • 11. Re: XP VM suddenly slow, Win 7 fine
                              Kinimod Novice

                              Hi Wayne.

                               

                              Avast also responded to our request, but in our case they just told us that they know about the issue and they are working on it... funny. So we have tried your advice, we unistalled Behavior Shield comp. at our Avast Business portal from my laptop, then we installed it back and it did not work.

                               

                              so hopefully new update from Avast will solve this

                               

                               

                              thanks for help

                               

                              Dominik

                              • 12. Re: XP VM suddenly slow, Win 7 fine
                                Krikoman Novice

                                I have this same problem started about a week ago. I use AVG on both VM and Host computers Looking at Automatic Updated ours was set to Auto but not running.

                                 

                                Windows installer was already set to manual and not running.

                                 

                                Still having trouble here!

                                 

                                Noticed a bit of weirdness, in that when the cursor is in the Description Box for the XP vms it switched from a hand to a pointer very rapidly, it doesn't do this on the Win7 or Win 10 Vms.

                                 

                                Very strange.

                                • 13. Re: XP VM suddenly slow, Win 7 fine
                                  Krikoman Novice

                                  Sorry to be dim, but are we talking about the Anti-Virus on the Host, the Vms or Both?

                                  • 14. Re: XP VM suddenly slow, Win 7 fine
                                    Krikoman Novice

                                    OK All Sorted FFS!!

                                     

                                    It was AVG, like Avast they've put "Enable Hardware-Assisted Virtualization" Check box in their trouble shooting section and it's automatically ticked!!

                                     

                                    A whole week to sort this out, copying files , disabling drivers and installing other, updating this and that, all to no avail!!

                                     

                                    Any how if you're using AVG Free Zen. Click on the Tray icon, Click on Antivirus Free section, then click he arrowed menu button shown below.

                                     

                                     

                                    Select Settings, then Troubleshooting, Uncheck "Enable Hardware-Assisted Virtualization" Reboot and hay-presto no more issues.

                                     

                                     

                                     

                                    Thanks for everyone that helped, I'd never seen this setting before in AVG so it might be something new, new and deadly for people sanity.

                                    1 person found this helpful
                                    1 2 Previous Next