4 Replies Latest reply on Jan 19, 2017 6:28 AM by jpschnee

    ds2db not generating a wrf file

    badgerx Novice

      Hi

       

      I'm busy working on getting the rest of the workloads in my tile working while I wait for feedback on the missing loadgen package. OlioWeb and OlioDB seem to be working fine as does the ds2webX loads. I am am struggling to get ds2db to generate a wrf file and hope someone can provide some pointers as to where to look for more debugging. Initially I had not prepared the database correctly with csv files after deploying from the ova, but I've rectified that, with no change.

       

      Attached is two result files: one with OlioWeb OlioDB DS2WebA DS2WebB DS2WebC DS2DB and another just with DS2DB in the hopes that I would get a more specific error.

       

      At the moment I am getting:

      Calculating Turbo Timing & Scoring : Run_Is_NOT_Compliant

      Run_start   : Thu Jan  1 02:00:00 1970

      Start_time 0 : Thu Jan  1 02:00:00 1970

      End_time  : Thu Jan  1 02:00:00 1970

      Run_end  : Thu Jan  1 02:00:00 1970

      Duration_in_minutes : 0.00

      Steady_start_start 300 : Thu Jan  1 02:05:00 1970

      Steady_state_end 1200 : Thu Jan  1 02:20:00 1970

      Phase_0_begin 300 : Thu Jan  1 02:05:00 1970

      Phase_1_begin 600 : Thu Jan  1 02:10:00 1970

      Phase_2_begin 900 : Thu Jan  1 02:15:00 1970

      Error: could not resolve start-time. Results data missing from one or more *.wrf files or time on clients not synchronized

      Which I am assuming is just a side effect of the missing ds2db wrf file. If I run a manual report and exclude the DVDStore I get the output based on the olio and web tests.

       

      Edit: Attachments removed.

        • 1. Re: ds2db not generating a wrf file
          badgerx Novice

          I think I have solved my problem. I worked on generating manual reports with tilescore.pl. And when including DVD store I got the following error.

           

          Month '2016' out for range 0..11 at /cygdrive/c/VMmakr2/tilescore.pl line 657.

           

          I also then realized that a full run didn't generate a wrf for oliodb either, so it wasn't actually a problem that I didn't have one for ds2db

           

          So I had one of our devs help me through the code and the problem is the parsing of the date from the ds2web wrf files. My timezone is SAST with date format YYYY/MM/DD. The code for DS2 seems to expect it in YYYY/DD/MM. So we hacked the code to work with SAST. Interestingly enough I don't see this problem with Olio, so maybe the script can be improved?

           

          These are the parts of the wrf files it parses for Olio:

          [BENCHMARK] Benchmark start: 2017-01-17 23:11:01, maxUsers=400

           

          And here is DS2

          Controller (2017/01/17 11:11:21 PM): all threads connected - issuing Start

          tilescore.pl can parse Olio but not DS2.

          • 2. Re: ds2db not generating a wrf file
            jpschnee Expert
            VMware Employees

            Hello,

             

            The issue is you didn't setup the templates and/or VMs with the correct time formatting "USA standard (Month/Day/Year)".  I'm not sure what you intend to do with the results of your testing but the benchmark source files (including the tilescore.pl script) should never be modified in any way.  All subsequent runs would be considered non-complaint.  I recommend updating your environment for compliance.

             

            Correct, DS2DB and OlioDB VMs do not generate a WRF file, they are backend databases only.

            • 3. Re: ds2db not generating a wrf file
              badgerx Novice

              As far as I can tell from the documentation it only states:

              NOTE The vCenter Server, the ESXi hosts, the workload virtual machines, and the clients (both physical and virtual) must also be configured to the same time zone.

              The entire VMmark test environment must be configured to the same time zone.

              but it doesn't actually dictate which time zone & time format.

               

              Would have been useful had that been stated much earlier in the documentation rather than the footnote under miscellaneous troubleshooting for STAX errors (which I'm not experiencing):

              If you observe “Out of bounds error by harness during time sync” in the STAX messages window, make sure the date and time format used by all Windows-based systems (that is, all clients and the vCenter server) is the USA standard (that is, month/day/year) as opposed to the UK standard (that is, day/month/year).

              As for hacking the script, I'm sure these things can always be improved. Olio report section handles the date format, why not ds2? At this stage the output is for internal use, so I can manage without the explicit blessing of VMware

              • 4. Re: ds2db not generating a wrf file
                jpschnee Expert
                VMware Employees

                I agree and have already filed a bug for the documentation to be improved.  Sounds like you're good to go for now.  Good luck.