10 Replies Latest reply on Nov 28, 2019 11:36 AM by Levin1

    No small or tiny option when upgrading to VCSA 6.5

    abreed05 Lurker

      So I have a current VCenter server running 5.5 I just recently upgraded it from 5.1 as I am wanting to take the appliance to 6.5

      However when I go through the upgrade wizard and get to the deployment size I only have options for Medium Large and XL.
      My Current appliance only has 8GB of RAM and 2 Processors. The ESXI host that the appliance is running on has 16GB of RAM.

      So I cannot select the medium option for deployment as it requires 24GB of ram minimum.

      How can I get the upgrade wizard to show a tiny and small option?

        • 1. Re: No small or tiny option when upgrading to VCSA 6.5
          MusicCityTiger Lurker

          Same problem here!  Trying to upgrade my VCSA 6.0 to 6.5, but only "medium, large, x large" available.  I don't have enough cpu in my individual hosts (quad cores, no hyperthreading) to support any of these. VMWare needs to fix this if they expect customers to move to 6.5.

          • 2. Re: No small or tiny option when upgrading to VCSA 6.5
            rayrondini Lurker

            Yep... same deal. Any updates?

            • 3. Re: No small or tiny option when upgrading to VCSA 6.5
              jlay3 Lurker

              I too am having issues when upgrading from VCSA 6.0.0, 3634797. I have tried going to both 6.5 and 6.5.0 A without luck. Selecting the default storage size I get medium, large, X-large. I can change storage size to large and I suddenly have the small option (but with more HD usage required) but can not get the tiny option to appear. I am using windows update manager so I'm wondering if the migration assistant running on there may be affecting the size options when it does its precheck?

              • 4. Re: No small or tiny option when upgrading to VCSA 6.5
                Tinto1970 Master

                same here. trying upgrade from vcsa 5.5 with windows vum.

                 

                I can select only x-Large! Naturally i don't want to have a 24 vCPU 48GB RAM vCenter for a <10 hosts infrastructure.

                • 5. Re: No small or tiny option when upgrading to VCSA 6.5
                  jnickell Novice

                  Any luck on a resolution for this?  I'm in the same boat with a 5.5 VCSA (2 vCPUs, 8 GB of RAM). GUI upgrade utility is trying to force me into a Medium. 

                  I've opened a support ticket and will post what I find out, but wanted to see if anyone else had found a fix or a reason for this.

                  • 6. Re: No small or tiny option when upgrading to VCSA 6.5
                    jnickell Novice

                    Support sent me a link to this article.  I have not investigated it yet..

                    Deployment Size options are not available when upgrading or migrating to vCenter Server Appliance 6.5 (2148587) | VMware…

                     

                    After performing some of the steps outlined in the article.  I re-ran the the config and was able to select a "Tiny", "Large" setup

                     

                    From the basics of the list

                     

                    Inventory Service database  - I could not do this.  I got an error about the files (vpx and cms) not being found

                    Large vCenter Server Database tables - ran the database clean up script

                    Core Dumps - deleted many of the 'archived' files  I didn't see so much in the .dmp format, but saw lots of .gz files.  I deleted them figuring they were older log data. 


                    Hope that helps someone else.  I'm closing on completing my migration to the 6.5 VCSA

                    • 7. Re: No small or tiny option when upgrading to VCSA 6.5
                      rayrondini Lurker

                      Basically if any of your vCenter hardware configs are larger than the threshold for the tiny or small deployment, it will force you to a larger. Or, even if your drive is too full (my log drive was 70% utilized), it will force you to the larger deployment.  After deleting a bunch of log files to reduce my log drive, I was able to choose the smaller options. FYI: The actual upgrade failed and I had to revert back to my original VCSA. I'll attempt again tomorrow probably.


                      For reference, here's what VMware support sent:

                       

                      Please check if the VCPU , memory and storage meets the requirement , if they are over committed then you use the options missing

                      Minimum requirements for the VMware vCenter Server 6.x Appliance: https://kb.vmware.com/kb/2106572

                      Hardware Requirements for the vCenter Server Appliance and Platform Services Controller Appliance

                       

                      http://pubs.vmware.com/vsphere-65/index.jsp?topic=%2Fcom.vmware.vsphere.upgrade.doc%2FGUID-88571D8A-46E1-464D-A349-4DC43DCAF320.html

                       

                      Here's what actually fixed it for me (again, because my logs drive was 70% utilized) - also from Support:

                      1) For this vCSA, /storage/log was over 70% full. Run the following command to change directory into /storage/log:

                       

                      cd /storage/log

                       

                      2) Run the following command to show the largest files:

                       

                      find . -type f -size +50000k -exec ls -lh {} \; | awk '{ print $9 ": " $5 }'

                       

                      Please take a snapshot of the vCSA before removing these files.

                       

                      3) The "rm" command removes files, I have provided an example of the command you will need to run below to remove a file. You will need to run this for each file listed from the find command above:

                       

                      rm vmware/log/vmware-vpxd.8.log

                       

                      Once this command completes it wont return any output.

                       

                      4) Once I finished removing all the large files, I ran the command df -h again and the /storage/log directory was now only 35% full.

                       

                      5) We started the upgrade again and you were given the option to select a tiny and small deployment size.

                      • 8. Re: No small or tiny option when upgrading to VCSA 6.5
                        diegoazevedo Novice

                        I am also facing this issue when trying to migrate to VCSA 6.5. Currently running vCenter/VUM 5.5 U3 on a Windows 2012 R2 server. The SQL databases for both vCenter and VUM are remote to this vCenter server.

                         

                        This vcenter manages 2 ESXi servers and about 30 VMs. No point in going higher than Tiny. I am only able to select "Tiny" with storage size "large" - which translates to 775GB . If I select "Default" for storage (290GB), than Tiny disappears from the deployment size drop-down, leaving me just Small and up.

                         

                        After cleaning up all logs I could find, both servers (vCenter and SQL) have at least 46% available on the system drive. Both servers also have a data volume (D:) where SQL data and VUM updates are stored.They are at least 69% free.

                         

                        I reduced the resources on both servers so that they would fit under the Tiny deployment size. Right now the SQL server has 1vCPU/2GB RAM (down from 2/4) and the vCenter server has 1vCPU /7GB RAM (down from 2/12).

                         

                        Running out of ideas...

                         

                        The only thing I thought was to deploy using "small/default" and reduce the resources later, but not sure what this will cause when other updates come out. They might fail due to the deployment size not meeting required resources, or something along those lines. Furthermore we can potentially have monitoring tools like vROPs flagging the misconfiguration. Besides those points, I don't like the idea of having someone else looking and complaining: Someone didn't follow recommendations/best practices...

                        • 9. Re: No small or tiny option when upgrading to VCSA 6.5
                          GTSREngineer Lurker

                          Deleting the some of the very large logs and then backing out of the install to the very start and then next back through again fixed it right up.

                          • 10. Re: No small or tiny option when upgrading to VCSA 6.5
                            Levin1 Novice

                            Hi

                             

                            Same on 6.5 U1 --> 6.7 U3

                             

                            In my case on option "Storage size" was only "X-Large" available. It was because of an active snapshot of vCenter VM.

                            As I removed the snap, i was able to choose "large"