1 2 3 4 Previous Next 47 Replies Latest reply on May 1, 2019 4:58 AM by parvezaliusmani Go to original post
      • 15. Re: 503 Service Unavailable (Failed to connect to endpoint:
        pbraren Hot Shot
        vExpertVMware Employees

        Many reboots since, all is still working fine, this issue appears to now be completely resolved for me.

        • 16. Re: 503 Service Unavailable (Failed to connect to endpoint:
          FSRWalt Lurker

          LWCSteve, Adding those accounts to my GPO did the trick for me!

          After applying the GPO I restarted the service with service-control --stop vsphere-client then a start - waited a few minutes, killed a chicken as a sacrifice to VMWare and was able to get into the Web Client.

          (I think the sacrifice is optional, not sure if it was needed.)

           

          Thanks so much!  I've been at this for over a week!

           

          --Walt

          • 17. Re: 503 Service Unavailable (Failed to connect to endpoint:
            vmjoe Enthusiast

            LWCSteve

            Thanks for the solution! Works for me on 2012 R2 server with vCenter 6.5 (build 4602587).

             

            I didn't use group policy - we have a group on the server where I had to add all the local users created by vCenter installation.

             

            It's a shame that VMware is creating such rubbish... and from the error message in the browser it's impossible to even get a clue what's the problem. :-(

            • 18. Re: 503 Service Unavailable (Failed to connect to endpoint:
              lockdwn Lurker

              Thank you!  I have been having issues with this for a while. 

              • 19. Re: 503 Service Unavailable (Failed to connect to endpoint:
                tdesai Lurker
                VMware Employees

                Would you mind filing a PR for this so that I can have the appropriate team follow up on this ?

                Kindly let me know the PR details once you have it

                 

                Thanks

                Tushar Desai

                • 20. Re: 503 Service Unavailable (Failed to connect to endpoint:
                  tdesai Lurker
                  VMware Employees

                  can you share details on this ticket ??

                  • 21. Re: 503 Service Unavailable (Failed to connect to endpoint:
                    RajeevVCP4 Hot Shot
                    vExpert

                    Hello

                    I fixed same issue , but my customer infrastructure was like this. 

                    Basically this issue occurred because of your DB full or DNS have wrong entry.

                     

                    2 PSC

                    1 VC ( with vPostgreSQL db).

                     

                    Giving here step by step solution.

                    run hostname -f on vc and psc virtual machine  if you got this error ,

                    Unknown host

                    1. Log in to the console of vCenter Appliance as the root user.
                    2. To change directory to /etc , run this command:

                      cd /etc

                    3. Open the hosts file using a text editor.
                    4. Add the hostname in vCenter_IP vCenter Server Appliance FQDN vcenter short name format.

                      For example, 10.10.10.10 vcenter.vmware.com vcenter
                    5. Save and close the file.
                    6. Restart the vmware-vpxd service by running this command:

                    service vmware-vpxd restart

                     

                    1. Issue was in DNS setting on PSC , login by root on GUI change DNS according to infrastructure , you can check by it nslookup from you virtual center server.

                    2. IP address of your PSC should be resolved on both ways ( forward lookup and reverse lookup)

                    3. Then try to restart vpxd service

                    4. service vmware-vpxd restart

                    May be it would failed as service initialized failed if yes

                    Shut down your PSC and restart

                    Shut down your VC and restart

                    Check vpxd status service vmware-vpxd status ( If not running)

                    Go to PSC/VM vm by putty and restart these service.

                     

                    /etc/init.d/vmware-stsd restart

                    /etc/init.d/vmware-sts-idmd restart

                    service vmware-cm restart


                    then go to vc vm by putty


                    and restart


                    service vmware-vpxd restart


                    Now you should be connect by client.


                    If you have still issue send me log file.

                    /var/log/vmware/vpx/vpxd.log







                    3 people found this helpful
                    • 22. Re: 503 Service Unavailable (Failed to connect to endpoint:
                      TechNut Novice

                      Hi,

                       

                      After looking at all the issues in this thread, I still had the 503 problem.

                       

                      I'm running the Photon-based VCSA Appliance 6.5.  I did the Photon update, and upgraded to the latest version, 6.5.0.5300.

                       

                      After a reboot, that did not solve my issue.  I again logged into the management appliance, and looked at the settings.  Following the helpful video on the DNS/DHCP reservation, which did not apply to me, I began to wonder if network settings where the issue. 

                       

                      In my settings, I found that IPv4 was enabled, but IPv6 was turned off.  On a hunch, I enabled IPv6, and a few minutes later the /ui and vSphere 6.5 web client started working again. Great! 

                       

                      On a reboot, I found Photon did not keep any of the IPv6 settings, and again, the 503 error was thrown, no matter how long I waited.  I logged into the appliance via the console, and tried to set IPv6 settings manually.  This did not work.  There's some modification to the configuration to prevent setting IPv6 up on the command line. 

                       

                      Upon deeper digging, I found the following settings in /etc/sysctl.conf on the machine,

                       

                                #Disabling SLAAC/Link Local addresses

                                net.ipv6.conf.eth0.disable_ipv6=1

                       

                      Note to VMware staff: This does not disable link local, it turns off IPv6 completely on the eth0 interface!

                       

                      This appeared two times.  I then went and changed the settings to,

                       

                                net.ipv6.conf.eth0.disable_ipv6=0

                       

                      And ran,

                       

                                sysctl -a

                                sysctl -p

                       

                      And the settings where changed.  After a few minutes, the web based GUI started to work again.

                       

                      Next, I rebooted the machine, and it worked just fine.  Multiple reboots, it works just fine.

                       

                      I found that after I changed this setting, I could change IPv6 settings in the Photon Management application.

                       

                      You will notice that you will get 404 errors or cannot connect errors when you try the web GUI very early in the startup when things are working as they should.  That's a good sign, since, the 503 error will come up almost the same second the Photon Login console shows up.  After a few minutes, you will see your VM's get settings taken from the vSphere appliance, as it should, which you will then see the classic Web Initializing message in your browser.  Again, a good sign! If you login to the Photon Management application, you need to see "Good", not "Unknown".  Once "Good" displays for all the statuses, you should start seeing the 404 error, and then eventually the web gui will work. If you continue to see 503 errors and good, after waiting 10 or 15 minutes, then something else is wrong...

                       

                      It does seem indeed that this problem is related to network settings.  Either bad hostname in /etc/hosts or some kind of issue with how IP's are being stored.  I hope someone from VMware sees this and decides to dig in, as it is very frustrating to fix.  You need good Linux development (not just admin skills) to debug this kind of issue.  That's not something most VMware admins will have.

                       

                      HTH

                      2 people found this helpful
                      • 23. Re: 503 Service Unavailable (Failed to connect to endpoint:
                        macralf Lurker

                        I had the same issue (503), nothing was wrong with DNS or DB related.  The Problem popped up right after I updated my first host to 6.5.  Changing these IPv6 settings corrected the issue immediately.

                        • 24. Re: 503 Service Unavailable (Failed to connect to endpoint:
                          Richie_NL_ Lurker

                          Had the same problem, changing the net.ipv6.conf.eth0.disable_ipv6 from 1 to 0 also fixed the problem for me!

                           

                          Thanks, this problem was driving me nuts.

                          • 25. Re: 503 Service Unavailable (Failed to connect to endpoint:
                            AaronRose Novice

                            I had this same issue on a 6.0 u2 windows machine last week after a restart.  If you so choose the installer creates many virtual accounts NT Service\VMware-thingx..etc.  That it uses to log on different services.   On the windows machine I like to use the service-control --start --all command in the \bin of the vcenter folder.  It starts all services or with --stop stops all services in the correct order.  I had mine fail on any vmware service that wasn't using system as checked in services.msc.

                             

                            I attempted to use "local service" as I have two vcenters and this was working on anohter, but had the same result.  When I looked at the user rights "logon as a service" no longer had local service in the use rights.  TIP: when you make a GPO to give domain accounts specific user rights, be sure to add the defaults back in.  The gpo does not add the accounts to those user rights it replace whatever values are already there with the ones you set. 

                             

                            After setting each of those services to the domain account....all is working properly.  Leave the services using SYSTEM account to logon alone.

                            • 26. Re: 503 Service Unavailable (Failed to connect to endpoint:
                              MihailsA Lurker

                              What kind of sorcery is that? Good Lord! You deserve every cookie in the world for this! Not even VMware support could figure it out for me. If only I found this a couple of weeks earlier - would have saved me days of struggle with upgrade to 6.5! You rock!

                              • 27. Re: 503 Service Unavailable (Failed to connect to endpoint:
                                patomanna Lurker

                                Hi guys! I have the same problem since a few month and I can't find the solution.

                                 

                                My vcenter server is in:

                                OS. Windows Server 2012 R2 Standard

                                DB: Microsoft SQL Server Enterprise 11.0.2100.60

                                VCenter Version: Versión 6.5.0 Compilación 5318154 (18 APRIL 2017)

                                 

                                Also I had the same problem in oldest versions (4602587 and 4944578).

                                As a temporaly solution I delete de profile folders from C:\ProgramData\VMware\vCenterServer\data\vSphere Web Client\SerenityDB\serenity, after delete the profile folders works.

                                 

                                But I need to fix it definitly because crash frecuently.

                                I checked the GPO and not all user are add, and I cound't add it. hi users I couldn't add because doesn´t exist in my server.

                                 

                                  content-library

                                  perfcharts

                                  vmware-vpostgres

                                  vsan-health

                                 

                                 

                                The IPv6 is disabled in my Vcenter Server,

                                The DNS is correct in my DC ( register A and PTR)

                                The host file it's empty.

                                 

                                Someone can help me?

                                 

                                Regards.

                                Patricio.

                                • 28. Re: 503 Service Unavailable (Failed to connect to endpoint:
                                  aladin98 Lurker

                                  It really help bro, thank you

                                  • 29. Re: 503 Service Unavailable (Failed to connect to endpoint:
                                    GreenerRabbit Lurker

                                    Hello,

                                     

                                    My setup is:

                                    vCenter Server: Server 2016 x64 with Desktop Experience

                                    vCenter DB Server: Server 2016 x64 with Desktop Experience and SQL Server Standard x64 w/SP1

                                     

                                    I get the 503 Service Unavailable when I select vSphere Client (HTML5) - Partial functionality

                                     

                                    I was able to get the HTML5 version working with a workaround:

                                     

                                    1. Edit the following file: "C:\ProgramData\VMware\vCenterServer\cfg\vmware-vmon\svcCfgfiles\vsphere-ui.json"
                                    2. Go just below “StartCommandArgs”: [
                                    3. Insert a new line and add the following line: "-Dos.name=Windows Server 2012",
                                      1. Include the ,
                                      2. Be mindful of case sensitive
                                    4. Stop vsphere-ui: C:\Program Files\VMware\vCenter Server\vmon\vmon-cli.exe --stop vsphere-ui
                                    5. Start vsphere-ui: C:\Program Files\VMware\vCenter Server\vmon\vmon-cli.exe --start vsphere-ui

                                     

                                    I'm not sure why Server 2016 isn't supported in the vsphere-ui but its supported in the Supported host operating systems for VMware vCenter Server installation

                                    https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2091273

                                     

                                    -Ted