11 Replies Latest reply on May 10, 2017 5:09 AM by Pooran98

    vCSA 6.0U2 -> 6.5 Upgrade Fails with Vcintegrity error

    rhgouveia Lurker

      Hi,

       

      I have a problem with the upgrade vCSA 6.0U2 to 6.5.

       

      In the import step to the new vCSA the upgrade fails with this error:

       

      Vcintegrity Export file does not exist or is corrupted, abort import

       

      Can anyone help me with this?

       

      Thanks,

       

      Ricardo Gouveia

        • 1. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with Vcintegrity error
          sanjeebkumar Enthusiast
          VMware Employees

          Do you have VUM installed and configured in 6.0U2 ?

          Can you post the vc-support or the log folder /var/log/vmware/upgrade?

          • 2. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with Vcintegrity error
            tomikuku Lurker

            Hi,

            Any update on this case? Have the same error in update from 5.5 to 6.5

             

            Tomasz

            • 3. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with Vcintegrity error
              vplstingels Novice

              I am having the same issue as well. I have opened up a case with VMware. We will see how it goes. Anybody know where to find those logs?

               

               

               

              Error Message below:

               

              Error

              Error attempting Vcintegrity Export file does not exist or is corrupted, abort import

               

               

              Resolution

              Please check vcIntegrity migration logs for details.

               

              • 4. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with Vcintegrity error
                Mastsrl Novice

                i'm having the exact same issue, atfer this the migration is left in an inconsistent state, the old VCSA is powered off, the new one is up but has the temporary IP and logging in to the 5480 port does not bring the migration menu but the regular appliance maintenance ui.

                 

                if i login to any of the esxi servers manually with vs client they complain about being managed by vcsa on the old IP.

                 

                 

                what gives?, do i need to rollback and restart everything?.

                 

                indeed i do have a separate VUM instance in which i ran the migration assistant beforehand.

                 

                i exported the log as it asked me in tgz but i don't know what i'm looking for in them.

                 

                any ideas?.

                 

                edit: i found a solution of sorts..

                after doing the rollback(turning on old VCSA, deleting new VCSA appliance VM), i uninstalled VUM from the windows server and then disabled the plugin in VCSA.

                After this the upgrade ran succesfully

                • 5. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with Vcintegrity error
                  kegwell Enthusiast

                  Same issue.  Any updates or resolution?

                  • 6. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with Vcintegrity error
                    javier_dp Novice

                    Hi

                     

                    I am installing using the win32 GUI from the same Windows VM the Update Manager runs into.

                    I have tried:

                    1. Using our real VUM installation (sql server express) with data. Failure
                    2. Removing VUM from that Windows VM. The upgrade won't start because it cannot find Migration Assistant. Migration assistant cannot be run because there's no VUM installed. Failure.
                    3. Reinstalling VUM with embedded sql server express 2012 with an empty database. Again VcIntegrity error at the end of the migration.

                     

                    This is the info from the log:

                     

                    2017-01-05T08:06:08.547Z INFO __main__ Set root upgrade folder to: /usr/lib/vmware/cis_upgrade_runner/payload/component-scripts

                    2017-01-05T08:06:08.620Z INFO extensions Found upgrade phase <module 'vcIntegrity' from '/usr/lib/vmware/cis_upgrade_runner/payload/component-scripts/vcIntegrity/__init__.py'>:Import'

                    2017-01-05T08:06:08.620Z INFO extensions Executing upgrade phase '<module 'vcIntegrity' from '/usr/lib/vmware/cis_upgrade_runner/payload/component-scripts/vcIntegrity/__init__.py'>:Import' with context {u'resourceDir': u'/usr/lib/vmware/cis_upgrade_runner/upgrade_working_directory', u'infrastructureUsername': u'Administrator@vsphere.local', u'sourceSsoPassword': 'CENSORED', u'exportDir': u'/storage/seat/cis-export-folder/vcIntegrity', u'locale': u'en', u'destinationPlatform': u'Linux', u'destinationVcVersion': u'6.1', u'sourceVcVersion': u'6.0', u'sourceSsoUsername': None, u'sourcePlatform': u'Linux', 'logDir': u'/var/log/vmware/upgrade', u'infrastructureHost': u'EDITED', u'sourceSsoVersion': u'6.0', u'vcdb.migrateSet': u'all', u'infrastructureHttpsPort': u'443', u'infrastructurePassword': 'CENSORED', u'systemExportDir': u'/storage/seat/cis-export-folder/system-data', u'destinationSsoVersion': u'6.1'}.

                    2017-01-05T08:06:09.325Z INFO service_manager Executing command '['/bin/service-control', '--list']'

                    2017-01-05T08:06:09.407Z INFO service_manager Command '['/bin/service-control', '--list']' has exit-code='0' and stdout: vmware-vpostgres (VMware Postgres)

                    vmware-imagebuilder (VMware Image Builder Manager)

                    vmware-cm (VMware Component Manager)

                    vmware-vpxd (VMware vCenter Server)

                    vmware-sps (VMware vSphere Profile-Driven Storage Service)

                    applmgmt (VMware Appliance Management Service)

                    vmware-statsmonitor (VMware Appliance Monitoring Service)

                    vmware-rhttpproxy (VMware HTTP Reverse Proxy)

                    vmware-vapi-endpoint (VMware vAPI Endpoint)

                    vmware-stsd (VMware Security Token Service)

                    lwsmd (Likewise Service Manager)

                    vmafdd (VMware Authentication Framework)

                    vmware-psc-client (VMware Platform Services Controller Client)

                    vmware-vsm (VMware vService Manager)

                    vmonapi (VMware Service Lifecycle Manager API)

                    vmware-perfcharts (VMware Performance Charts)

                    vmware-updatemgr (VMware Update Manager)

                    vmware-vmon (VMware Service Lifecycle Manager)

                    vmware-vsan-health (VMware VSAN Health Service)

                    vsphere-client (VMware vSphere Web Client)

                    vmware-sts-idmd (VMware Identity Management Service)

                    vmcad (VMware Certificate Service)

                    vmware-eam (VMware ESX Agent Manager)

                    vmware-cis-license (VMware License Service)

                    vmcam (VMware vSphere Authentication Proxy)

                    pschealth (VMware Platform Services Controller Health Monitor)

                    vmdird (VMware Directory Service)

                    vmware-mbcs (VMware Message Bus Configuration Service)

                    vmware-vcha (VMware vCenter High Availability)

                    vsphere-ui (VMware vSphere Client)

                    vmware-content-library (VMware Content Library Service)

                    vmdnsd (VMware Domain Name Service)

                    vmware-sca (VMware Service Control Agent)

                    vmware-netdumper (VMware vSphere ESXi Dump Collector)

                    vmware-vpxd-svcs (VMware vCenter-Services)

                    vmware-rbd-watchdog (VMware vSphere Auto Deploy Waiter)

                     

                     

                    2017-01-05T08:06:09.419Z ERROR __main__ Upgrade Phase 'vcIntegrity:Import' failed. Exception: Error attempting Vcintegrity Export file does not exist or is corrupted, abort import

                    Traceback (most recent call last):

                      File "/usr/lib/vmware/cis_upgrade_runner/payload/componentPhaseLauncher.py", line 438, in main

                        executionResult = systemExtension(exeContext)

                      File "/usr/lib/vmware/cis_upgrade_runner/libs/sdk/extensions.py", line 94, in __call__

                        result = self.extension(*args)

                      File "/usr/lib/vmware/cis_upgrade_runner/libs/sdk/extensions.py", line 110, in _func

                        return func(*args)

                      File "/usr/lib/vmware/cis_upgrade_runner/payload/component-scripts/vcIntegrity/__init__.py", line 60, in doImport

                        return vcIntegrity_upgrade.importData(context)

                      File "/usr/lib/vmware/cis_upgrade_runner/payload/component-scripts/vcIntegrity/vcIntegrity_upgrade.py", line 231, in importData

                        raiseUpgradeFailed('Vcintegrity Export file does not exist or is corrupted, abort import')

                      File "/usr/lib/vmware/cis_upgrade_runner/payload/component-scripts/vcIntegrity/vcIntegrity_upgrade.py", line 58, in raiseUpgradeFailed

                        raise PermanentError(cause=errStr, resolution=resStr)

                    PermanentError: Error attempting Vcintegrity Export file does not exist or is corrupted, abort import

                    • 7. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with Vcintegrity error
                      javier_dp Novice

                      More info: I'm upgrading a single PSC vCenter VCSA 6.0 build 3634794 with VUM running on Windows 2012 server

                      • 8. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with Vcintegrity error
                        javier_dp Novice

                        sanjeebkumar is the previously provided info what you needed?

                        • 9. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with Vcintegrity error
                          bobichon Lurker

                          Hi,

                           

                          After remove the VUM, you must remove the webclient update manager in the vcenter on the webinterface.For me, just deactivate doesn't work.

                           

                          I used this method in this KB Cannot remove or disable unwanted plug-ins from vCenter Server and vCenter Server Appliance (1025360) | VMware KB

                           

                          To remove unwanted plug-ins from the available plug-in list:

                          1. In a web browser, navigate to http://vCenter_Server_name_or_IP/mob.

                            Where vCenter_Server_name_or_IP/mob is the name of your vCenter Server or its IP address.


                          2. Click Content.
                          3. Click ExtensionManager.
                          4. Select and copy the name of the plug-in you want to remove from the list of values under Properties. For a list of default plug-ins, see the Additional Information section of this article.
                          5. Click UnregisterExtension. A new window appears.
                          6. Paste the key of the plug-in and click Invoke Method. This removes the plug-in and results in void.
                          7. Close the window.
                          8. Refresh the Managed Object Type:ManagedObjectReference:ExtensionManager window to verify that the plug-in is removed successfully.

                           

                          after you run installer without migration-assistant

                           

                          Sorry for my english .

                           

                          Sébastien

                          • 10. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with Vcintegrity error
                            EzequielD Lurker

                            The problem is the import of "Vmware Update Manager" data. In my case i did this to bypass it:

                             

                             

                            1- I reverted all the changes that the upgrade process did: From the ESXi hosting the new and old Appliance, I removed the new appliance and powered up the old one again. Thats important for the next steps to work properly.

                             

                            2- Wait till the old vCenter Appliance is fully functional again and ensure that the Update Manager plugin is working correctly (start the "update manager" service in the update manager machine if the "Migration Assistant" stopped it, which was my case). Also in my case, after login on the old appliance with vsphere client, the upgrade process left an orphaned new appliance, you can delete it safely.

                             

                            3- Once the update manager is working again, Uninstall the "vmware vsphere update manager" from "ADD/Remove programs" at the Update manager machine. If it's the update manager 6 update2 it will also unregister the plugin in the old vsphere appliance. Can't say about different versions because 6update2 was my scenario.

                             

                            4- If the plugin uninstalled correctly you should not see the plugin at vsphere client anymore. Check it after restarting vsphre client on your computer and if it's gone then you can proceed with the upgrade/migration again, now without "migration assistant" for update manager because we removed it completely.

                             

                            That did the trick for me, if uninstalling the update manager software don't uninstall the plugin for you, then you should remove it manually from the old vsphere appliance (there are guides on how to unregister plugins in vcenter 6), and start the upgrade to 6.5 process without it on your environment.

                             

                            In my case I wanted to migrate Update Manager just to not configure it again, no critical data lost because everything can be downloaded again, but If you have complex configurations/baselines that must be exported/imported then I suppose you'll need to wait until vmWare releases a fix to that problem.

                             

                            regards and profit.

                            Ezequiel

                            • 11. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with Vcintegrity error
                              Pooran98 Enthusiast
                              vExpert

                              @EzequielD I wanted to say thanks for your comments it helped us get through our VCSA 6.5 migration.