1 2 Previous Next 15 Replies Latest reply on Jun 16, 2017 11:10 PM by Marcusw03

    vCSA 6.0U2 -> 6.5 Upgrade Fails with VIX error

    kmzimm Enthusiast

      I'm attempting to upgrade my lab vCSA from 6.0U2 to 6.5, using the GUI on a Windows 10 machine, however it fails with the error "A problem occurred while getting data from the source vCenter Server."


      I'm getting the following errors in the logs:

       

      2016-11-16T04:33:20.362Z - info: VM with hostName vcenter.<redacted>: { _type: 'VirtualMachine',
        _moid: 'vm-281',
        config: { template: false },
        guest:
         { hostName: 'vcenter',
           ipAddress: '172.16.1.210',
           net: [ [Object] ] },
        name: 'vCenter 6',
        summary:
         { storage:
            { committed: 88573757853,
              uncommitted: 42716880896,
              unshared: 88572180157,
              timestamp: 2016-11-16T02:57:13.284Z } } }
      2016-11-16T04:33:20.362Z - info: VM Identifier for Source VC: vm-281
      2016-11-16T04:33:20.435Z - debug: initiateFileTransferFromGuest error: ServerFaultCode: A general system error occurred: vix error codes = (1, 4294967292).

       

      2016-11-16T04:33:20.436Z - debug: Failed to get fileTransferInfo:ServerFaultCode: A general system error occurred: vix error codes = (1, 4294967292).

       

      2016-11-16T04:33:20.436Z - debug: Failed to get url of file in guest vm:ServerFaultCode: A general system error occurred: vix error codes = (1, 4294967292).

       

      2016-11-16T04:33:20.436Z - error: Error in getting fileData for nodeType. Error: ServerFaultCode: A general system error occurred: vix error codes = (1, 4294967292).

       

      2016-11-16T04:33:20.436Z - error: Failed to read the nodetype, Error: A general system error occurred: vix error codes = (1, 4294967292).

       

      2016-11-16T04:33:20.436Z - error: sourcePrecheck: error in getting source Info: ServerFaultCode: A general system error occurred: vix error codes = (1, 4294967292).

       

      ----

      The vmware.log file for the vCSA VM only shows this:

       

      2016-11-16T04:33:58.183Z| vmx| I125: VigorTransportProcessClientPayload: opID=388cfbff-46-fede seq=6928: Receiving GuestOps.InitiateFileTransferFromGuest request.
      2016-11-16T04:33:58.269Z| vcpu-1| I125: VigorTransport_ServerSendResponse opID=388cfbff-46-fede seq=6928: Completed GuestOps request.

       

      ---

      I tried turning up the logging on the vmware tools in the guest, but no additional logs were generated, so I'm at a dead end.

       

      Any ideas would be appreciated.

        • 1. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with VIX error
          cchilderhose528 Novice

          I am having the same issue with upgrading my DEV VCSA.  Hopefully someone chimes in here.

          • 2. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with VIX error
            5mall5nail5 Novice

            I too am having this issue on one of my vCenters.  I was able to upgrade another 6.0 U2 VCSA to 6.5 without issue.  The one with this same issue has Update Manager linked, so maybe that's related?

            • 3. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with VIX error
              RonaldMetisIT Lurker

              Same problem here.....

              • 4. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with VIX error
                mike-p Enthusiast

                Same error - no linked components like UM etc.

                All components running in a nested ESXi6 host. I tested FQDN's and IP's.

                • 5. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with VIX error
                  marlinx Novice

                  I had same error. Change vCSA root pasword helps me. After that wizard continues ...

                  1 person found this helpful
                  • 6. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with VIX error
                    5mall5nail5 Novice

                    Wow really?  The source VCSA?  Yep!  Fixed it for me!

                    • 7. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with VIX error
                      DavidFDIC Novice

                      I am having problem as well.

                      vcenter/sso authentication was successful

                      esxi authentication was successful.

                      it seems that it is trying to get some data via some file transfer from sso but it failed.

                       

                      2016-11-17T03:05:46.105Z - debug: Logging in to vcenter:443 as administrator@vsphere.local

                      2016-11-17T03:05:46.188Z - info: Logged in to vcenter:443 as administrator@vsphere.local, session: 52e76ebc-4667-fc85-a19a-61cb9b87c1ae

                      2016-11-17T03:05:46.190Z - info: Login successful to source VC, IP: vc01.cloud.local

                      .......

                      2016-11-17T03:05:46.356Z - debug: Logging in to esxi:443 as root

                      2016-11-17T03:05:46.404Z - info: Logged in to esxi:443 as root, session: 198040d9-866b-4127-876c-5aee34fcde26

                      .......

                      2016-11-17T03:05:46.497Z - debug: initiateFileTransferFromGuest error: ServerFaultCode: A general system error occurred: Unknown error

                      2016-11-17T03:05:46.498Z - debug: Failed to get fileTransferInfo:ServerFaultCode: A general system error occurred: Unknown error

                      2016-11-17T03:05:46.498Z - debug: Failed to get url of file in guest vm:ServerFaultCode: A general system error occurred: Unknown error

                      2016-11-17T03:05:46.499Z - error: Error in getting fileData for nodeType. Error: ServerFaultCode: A general system error occurred: Unknown error

                      2016-11-17T03:05:46.499Z - error: Failed to read the nodetype, Error: A general system error occurred: Unknown error

                      2016-11-17T03:05:46.500Z - error: sourcePrecheck: error in getting source Info: ServerFaultCode: A general system error occurred: Unknown error

                       

                       

                       

                      David

                      • 8. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with VIX error
                        kmzimm Enthusiast

                        Thanks for the pointer in the right direction. I dug into it further, and it looks like the problem is the root password being expired:

                         

                        Command> com.vmware.appliance.version1.localaccounts.user.list

                        Config:

                          Configuration:

                              Username: root

                              Status: enabled

                              Role: superAdmin

                              Passwordstatus: expired

                              Fullname: root

                              Email:

                         

                        ----

                         

                        So, resetting or unexpiring the password solves the issue.

                         

                        Thanks again!

                        2 people found this helpful
                        • 9. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with VIX error
                          DavidFDIC Novice

                          Yup - it was the root password issue on the VCSA.  It is working now.

                           

                          David

                          • 10. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with VIX error
                            sanjeebkumar Enthusiast
                            VMware Employees

                            Please refer release note VMware vSphere 6.5 Release Notes

                            Attempts to upgrade a vCenter Server Appliance or Platform Services Controller appliance with an expired root password fail with a generic message that cites an internal error
                            During the appliance upgrade, the installer connects to the source appliance to detect its deployment type. If the root password of the source appliance has expired, the installer fails to connect to the source appliance, and the upgrade fails with the error message: Internal error occurs during pre-upgrade checks.

                            Workaround:

                            1. Log in to the Direct Console User Interface of the appliance.
                            2. Set a new root password.
                            3. Retry the upgrade.
                            • 11. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with VIX error
                              cchilderhose528 Novice

                              Confirmed that the password trick works as I noticed on my VCSA 6.0u2 that the expiry was set to 1970 for some reason.  So I changed it and set expiry to never.  This allowed me to upgrade. 

                              • 12. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with VIX error
                                TomKalabis Enthusiast

                                same problem here.

                                VCSA6.0 U2 > VCSA 6.5 in my homelab.

                                 

                                2016-11-22T21:04:24.654Z - info: Xml output from ovftool: <data><ManifestValidate valid="true"/></data>

                                2016-11-22T21:04:24.654Z - info: Cancelling timeout due to completion

                                2016-11-22T21:04:24.654Z - info: Progress Controller: Deployment completed

                                2016-11-22T21:04:24.654Z - info: Progress Controller: Final Result: {"items":["RESULT","+ SUCCESS"],"complete":true,"vmRef":"10"}

                                2016-11-22T21:04:24.654Z - info: Progress Controller: IP : undefined

                                2016-11-22T21:04:24.654Z - info: Progress Controller: VM Ref: 10

                                2016-11-22T21:04:24.654Z - info: <PERFORMANCE>:APPLIANCE_DEPLOYMENT:158:seconds

                                2016-11-22T21:04:24.654Z - info: rpmInstallProgress: hostIp=esx3.demolab.local, guestVmId=10, guestUser=root

                                2016-11-22T21:04:24.654Z - debug: rpmInitialDelay: 120000

                                2016-11-22T21:04:24.654Z - debug: pollRpmInstallProgress loop: delay=10000, maxLoop=720

                                2016-11-22T21:04:24.733Z - info: ovfProcess child process exited with code 0

                                2016-11-22T21:04:27.827Z - debug: initiateFileTransferFromGuest error: ServerFaultCode: The object has already been deleted or has not been completely created

                                2016-11-22T21:04:27.827Z - debug: initiateFileTransferFromGuest error: ServerFaultCode: The object has already been deleted or has not been completely created

                                2016-11-22T21:04:28.811Z - debug: Failed to get fileTransferInfo:ServerFaultCode: The object has already been deleted or has not been completely created

                                2016-11-22T21:04:28.811Z - debug: Failed to get fileTransferInfo:ServerFaultCode: The object has already been deleted or has not been completely created

                                2016-11-22T21:04:28.811Z - debug: Failed to get url of file in guest vm:ServerFaultCode: The object has already been deleted or has not been completely created

                                2016-11-22T21:04:28.811Z - debug: Failed to get url of file in guest vm:ServerFaultCode: The object has already been deleted or has not been completely created

                                2016-11-22T21:04:28.811Z - debug: [202]pollRpmInstallProgress:getGuestFileErr:ServerFaultCode: The object has already been deleted or has not been completely created

                                2016-11-22T21:04:28.811Z - debug: [704]pollRpmInstallProgress:getGuestFileErr:ServerFaultCode: The object has already been deleted or has not been completely created

                                 

                                 

                                i changed root password and reboot vcsa60 - still same problem, so i disable DRS on my cluster. but still same...

                                any ideas ?

                                • 13. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with VIX error
                                  TomKalabis Enthusiast

                                  its funny, that now is upgrade finished... but in .log is error messages.

                                  2016-11-22T21:10:47.819Z - info: installProgress[25]: 82

                                  2016-11-22T21:10:51.831Z - debug: initiateFileTransferFromGuest error: ServerFaultCode: The object has already been deleted or has not been completely created

                                  2016-11-22T21:10:52.822Z - debug: Failed to get fileTransferInfo:ServerFaultCode: The object has already been deleted or has not been completely created

                                  2016-11-22T21:10:52.822Z - debug: Failed to get url of file in guest vm:ServerFaultCode: The object has already been deleted or has not been completely created

                                  2016-11-22T21:10:52.822Z - debug: [71]pollRpmInstallProgress:getGuestFileErr:ServerFaultCode: The object has already been deleted or has not been completely created

                                  2016-11-22T21:10:56.827Z - debug: initiateFileTransferFromGuest error: ServerFaultCode: The object has already been deleted or has not been completely created

                                  2016-11-22T21:10:57.819Z - debug: Failed to get fileTransferInfo:ServerFaultCode: The object has already been deleted or has not been completely created

                                  2016-11-22T21:10:57.819Z - debug: Failed to get url of file in guest vm:ServerFaultCode: The object has already been deleted or has not been completely created

                                  2016-11-22T21:10:57.819Z - debug: [238]pollRpmInstallProgress:getGuestFileErr:ServerFaultCode: The object has already been deleted or has not been completely created

                                  2016-11-22T21:10:58.825Z - info: installProgress[26]: 86

                                  2016-11-22T21:11:02.819Z - debug: initiateFileTransferFromGuest error: ServerFaultCode: The object has already been deleted or has not been completely created

                                  2016-11-22T21:11:03.819Z - debug: Failed to get fileTransferInfo:ServerFaultCode: The object has already been deleted or has not been completely created

                                  2016-11-22T21:11:03.819Z - debug: Failed to get url of file in guest vm:ServerFaultCode: The object has already been deleted or has not been completely created

                                  2016-11-22T21:11:03.819Z - debug: [72]pollRpmInstallProgress:getGuestFileErr:ServerFaultCode: The object has already been deleted or has not been completely created

                                  2016-11-22T21:11:07.832Z - debug: initiateFileTransferFromGuest error: ServerFaultCode: The object has already been deleted or has not been completely created

                                  2016-11-22T21:11:08.819Z - debug: Failed to get fileTransferInfo:ServerFaultCode: The object has already been deleted or has not been completely created

                                  2016-11-22T21:11:08.819Z - debug: Failed to get url of file in guest vm:ServerFaultCode: The object has already been deleted or has not been completely created

                                  2016-11-22T21:11:08.819Z - debug: [239]pollRpmInstallProgress:getGuestFileErr:ServerFaultCode: The object has already been deleted or has not been completely created

                                  2016-11-22T21:11:09.822Z - info: installProgress[27]: 90

                                  • 14. Re: vCSA 6.0U2 -> 6.5 Upgrade Fails with VIX error
                                    TimmyBrian Lurker

                                    Changing root password of vSphere vCenter worked for me

                                     

                                    Change the vSphere vCenter root password via:

                                    https://vCenterIP:5480/

                                    1 2 Previous Next