6 Replies Latest reply on Nov 6, 2016 4:46 PM by malletta

    Enhanced Link Mode Migration?

    malletta Novice

      Hi,

       

      I have 2 sites, each with an external PSC and vsphere server and both are on the vsphere.local domain. site names are different though. These were upgraded from 5.5 embedded and then repointed to their respective external PSC.

       

      Enhanced Link mode doesnt seem to work and im under the impression I need to do the following..

       

      In one of my sites (Site B), create a new PSC (PSC2) which is a replica of site A, then repoint the vsphere server in SITE B to the new PSC2.

       

      In terms of DVS and other items like that, they should all just populate the new PSC2 and things should keep running without any further config or outage?

       

       

      Am I in fairy land or am i going in the right direction?

       

      thanks in advanced.

        • 1. Re: Enhanced Link Mode Migration?
          erikverbruggen Hot Shot
          vExpert

          Did you join the second PSC to the SSO Domain of the first PSC? For Enhanced Linked Mode to work both the PSC's need to be in the same SSO Domain.

          • 2. Re: Enhanced Link Mode Migration?
            malletta Novice

            Yes they are all on the same SSO Domain. (vsphere.local)

            • 3. Re: Enhanced Link Mode Migration?
              Mattallford Hot Shot
              vExpert

              Hmm. As long as they are in the same SSO domain, ELM should work OK. SSO sites aren't relevant to the ELM discussion (or at least shouldn't be to my knowledge).

               

              What build of 6 are you running?

              Are you receiving any errors when you log into the web client about not being able to connect to other vCenter Servers? I assume you are using the web client and not the c# client?

              Can you see any other vCenter Server objects in the inventory, or nothing at all?

              Anything of interest in the vpxa logs on vCenter when you log in?

              Have the vCenter serves been restarted post repoint to PSC?

               

              Cheers, Matt.

              • 4. Re: Enhanced Link Mode Migration?
                malletta Novice

                What build of 6 are you running?

                3634793

                Are you receiving any errors when you log into the web client about not being able to connect to other vCenter Servers?

                No.

                I assume you are using the web client and not the c# client?

                Your assumption is correct.

                Can you see any other vCenter Server objects in the inventory, or nothing at all?

                Nothing at all.

                Anything of interest in the vpxa logs on vCenter when you log in?

                I couldn't see anything obvious. I did find an ldap lookup error which was resolved.

                Have the vCenter serves been restarted post repoint to PSC?

                Yes. I restarted again after fixing the ldap error(wrong UPN format) for the SSO domain just to be sure.

                • 5. Re: Enhanced Link Mode Migration?
                  thecloudxpert Enthusiast
                  vExpert

                  How have you determined Enhanced Link Mode is not working?

                   

                  If you have 2 external PSC's in the same SSO domain (vsphere.local) but in different sites (Site A and Site B), your vCenter (VCSA or Windows) in Site A is pointing to the PSC in Site A, and the vCenter (VCSA or Windows)  in Site B is pointing to the vCenter in Site B.  Then that is a supported linked mode configuration and it should be working OOTB.

                   

                  There is no need to have additional PSCs to each site. 

                   

                  If you decide to add additional PSC's you will need to add an additional replication link, see https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2127057

                  • 6. Re: Enhanced Link Mode Migration?
                    malletta Novice

                    I spoke to vmware support about this after I resolved another issue and they have suggested the following to resolve the issue...

                     

                    Backup DB from vSphere in site B,

                    Decom vSphere server,

                    Decom PSC,

                    Create new PSC in site B as replica of site A,

                    Create vSphere server,

                    Restore DB from site B.