2 Replies Latest reply on Jul 31, 2020 10:23 AM by danish91

    VMware tools installed on CentOS 7, but not starting

    picsnapr Lurker

      Hi friends,

      I installed CentOS 7 on the VMware Fusion 8.5. The Linux is running fine, but even after I installed the VMware Tools, I still can't see it starting up. On the Folder sharing window, I see the message: "Shared folders will not be available in the virtual machine until VMware Tools is installed and running."


      Any idea what could be missing with the vmware tools installation?


      PS. I've tried both ways on vmtools installation: yum method as well as 'extracting the tar.gz and running .pl file' method. And both ways it seems that the vmtools are installed fine.

        • 1. Re: VMware tools installed on CentOS 7, but not starting
          Darcyz Enthusiast
          VMware Employees

          Hi picsnapr,

          Welcome to Fusion Community.

          Open-VM-Tools is default installed in CentOS 7.

           

          How to uninstall open-vm-tools?

          1.Terminal and run'rpm -qa | grep vm'

          From the package listed by this command, you can find 3 packages:

          open-vm-tools-gui-9.2.3-3.2.1.x86_64

          open-vm-tools-9.2.3-3.2.1.x86_64

          libvmtools0-9.2.3-3.2.1.x86_64


          2. Remove the 3 packages by running command 'sudo rpm -e open-vm-tools-gui open-vm-tools libvmtools0'


          3. Rerun 'rpm -qa | grep vm' and you will find the returned package list no longer contain the 3 packages


          You can install the vmware tools again, it will work fine.

          If it still doesn't work. please let me know.


          Regards

          1 person found this helpful
          • 2. Re: VMware tools installed on CentOS 7, but not starting
            danish91 Lurker

            Searched all over forums and Stackoverflow, this was the only solution that worked. Thank you!