1 Reply Latest reply on Oct 21, 2016 10:28 AM by BuzzBourque

    Caps-lock and num-lock turning off when clicking into horizon client

    Telby30 Lurker

      Hello All!

       

      My users are complaining that when they open a desktop, their caps-lock and num-lock are not set.

       

      Example - If I have both num-lock and caps-lock on for my physical pc, when I click inside the virtual desktop they are off and I have to turn them on again.

       

      Is there any way to have the client keep the keyboard settings of the physical device they are connecting from?

       

      Note - I have tried this KB with no luck -> The Num Lock setting for USB numeric keypads might be misread by Horizon View Client for Windows (2045533) | VMware KB

        • 1. Re: Caps-lock and num-lock turning off when clicking into horizon client
          BuzzBourque Novice

          I ended up scripting a solution for my issue which was similar but just numlock.

          I created a .vbs file that determines the current numlock state and sends a keystroke to turn on if necessary. I placed the file in "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup"

           

          on error resume next

           

          Set objWord = CreateObject("Word.Application")

           

          if not objWord.NumLock ="True" then

           

          set WshShell = CreateObject("WScript.Shell")

          WshShell.SendKeys "{NUMLOCK}"

           

          end if

           

          objWord.Quit