0 Replies Latest reply on Aug 1, 2016 2:57 AM by YllowDnk

    health check script 6.0

    YllowDnk Novice

      Hello,

       

       

      i have a datacenter with 3 clusters and 7 hosts. Since a month the health check script running from vma is not

       

      working anymore. I ran the script against every single cluster and its working on 2 clusters but on 1 cluster it

       

      fails. This cluster has 3 hosts. When i ran the script against all 3 single hosts it is working on 2 hosts but 1

       

      host fails. The output shows:

       

      Use of uninitialized value in concatenation (.) or string at /home/vi-admin/vmwarevSphereHealthCheck.pl line 391.

       

      SOAP Fault:

      -----------

      Fault string: A general system error occurred:

      Fault detail: SystemErrorFaultGenerating VMware vSphere Health Report v5.5.0 "/home/vi-admin/Report/Health_Check_Report.html" ...

       

      This can take a few minutes depending on the size of your environment.

      Get a cup of coffee/tea/beer and check out http://www.virtuallyghetto.com

       

      line 391 is in the "system build info" section in the script.

       

      line 391: $summary_start .= "<tr><td>".$sc->about->fullName."</td><td>$system_name</td><td>".$sc->about->instanceUuid."</td></tr>\n";

       

      I already restartet the host one time but that did not help.

       

      Can anyone help what could cause this issue ?