2 Replies Latest reply on Feb 20, 2019 4:55 PM by elameno

    USB Headset Audio Stuttering (only when mic enabled as input device)

    elameno Lurker

      For Workstation 12, Windows 10 host, Ubuntu 14.04 guest:  I have a Kingston HyperX Cloud II USB headset/mic combo that I like to use for voice communications via google hangouts.  If I attach the device to a linux guest (tried both ubuntu and centOS), set the headphones to the output device AND the headset mic as the input device, I receive audio stuttering in the VM.  Now the interesting thing is that if I disable the headset mic as the input device the audio stuttering goes away and all is well (except that I can't use the mic of course).

       

      When using the headset in the Windows 10 host OS, I have no such problems and the headset works fine with the mic enabled.

       

      Has anyone else run across this issue, or perhaps had any success with USB headsets in a Linux guest?  Any thoughts on what to try that might resolve the issue?

       

      Thanks in advance!

      Dave

        • 1. Re: USB Headset Audio Stuttering (only when mic enabled as input device)
          hansrotec Novice

          hey man, i wracking my brain on the same issue. here is how i fixed it. removed the sound card completely out of settings, for the VM. then loaded into the VM and added the USB device back... audio works crystal clear now... great for sip....  I know it might be too late for you, but for anyone else this worked on workstation pro 12.x  host was windows 10 pro and vm was windows 10 pro, used multiple USB audio devices in test all worked.

          • 2. Re: USB Headset Audio Stuttering (only when mic enabled as input device)
            elameno Lurker

            This works for me if I have USB 3.0 support enabled. 

             

            I've found that if you can get the default sound device to work properly, selecting the HyperX Cloud II headset on the host machine worked the best.  Lately my VM audio has been all goobered up and I can't get it working, so I had to come back to this and try to connect via USB.  So, for any other folks that have this problem:

             

            1. Power down the VM.

            2. Make sure the audio device is not set to connect at startup

            3. Set the USB support to 3.0

            4. Sign in.

            5. If the HyperX Cloud II headset is already connected, disconnect it.

            6. Reconnect the HyperX Cloud II headset.

             

            All should be well.