4 Replies Latest reply on Aug 11, 2019 8:36 AM by Ronaldsh69

    Unable to SSH to ESXi after 6.0U2 with PuTTY [SOLVED]

    warnesjSHR Lurker

      Hi everyone.  I wanted to share my latest experience with you in case anyone else runs into this.

       

      After applying the 6.0U2 update to a standalone ESXi host I was unable to SSH to the host anymore from PuTTY on my Windows workstation.  I know that the 6.0U2 update had some pretty big changes to the SSH daemon so I was pretty sure it was related to that.  I searched Google and the VMware knowledge base without much luck.  I ran across these articles:

       

       

      But those articles don't apply to 6.x.    But they pointed me in a direction to check in the /var/log/auth.log file for any errors.  I did indeed find the following errors:

       

      016-06-20T21:52:38Z sshd[40905]: error: Hm, kex protocol error: type 30 seq 1

       

      I did a quick Google search and ran across this article: https://blog.nytsoi.net/2015/07/13/putty-kex-error.  The problem (as I understand it) is that the key exchange method "Diffie-Hellman group exchange" is not supported with the version of OpenSSH that is used on the ESXi host.  The work-around was fairly easy.  The blog article referenced above says:

       

      In PuTTY, go to “Connection → SSH → Kex”. There, select “Diffie-Hellman group exchange” and move it to the bottom of the list, so it is not used.

       

      As soon as I did that, I was able to use PuTTY to connect to the standalone ESXi host.

       

      Hope anyone else finds this information useful.  It definitely had me scratching my head for a while.