1 2 Previous Next 18 Replies Latest reply on Jun 23, 2016 1:13 AM by AntonioFel

    Esxi 6.0 slow network performance

    AntonioFel Novice

      Hi, i have two esxi 6.0 whit gb connection, but when i tranfer a file between the two server, the speed is vary bad ( average 8Mbyte/s).

       

      I have the same issue in both direction. I have also perform a nic teaming, but the result is the same.

       

      Enviroment:

       

      ProLiant DL360e Gen8Vmware ESXi 6.0.0, 3380124
      ProLiant DL120 Gen9Vmware ESXi 6.0.0, 3380124

       

      Both the server are unloaded in Cpu and memory, and are connected at the same GB switch (with cat6 cables )

       

      Tell me if you need others info.

       

      Thank you for the support!!

        • 1. Re: Esxi 6.0 slow network performance
          J1mbo Virtuoso

          What's the storage subsystem?

          • 2. Re: Esxi 6.0 slow network performance
            AntonioFel Novice

            Local datastore, configured in raid 5 (both)

            • 3. Re: Esxi 6.0 slow network performance
              J1mbo Virtuoso

              Do your controllers have battery or flash-backed write cache?

              • 4. Re: Esxi 6.0 slow network performance
                AntonioFel Novice

                I don't know. How can i chack it?

                 

                P.S In a previosus installation with the same enviroment but with esxi 5.5, the speed was regular.

                • 5. Re: Esxi 6.0 slow network performance
                  J1mbo Virtuoso

                  Look up the controller, B140 or H240 controller have no cache options so aren't suitable for ESXi. But these services might have P440 controller with FBWC.

                  • 6. Re: Esxi 6.0 slow network performance
                    thecloudxpert Enthusiast
                    vExpert

                    is anything set to auto-negotiate network speeds? that has in the past, caused me problems. (i.e. switch port set to auto, server set to auto and then it decides to run at 10Mb/s)

                    • 7. Re: Esxi 6.0 slow network performance
                      AntonioFel Novice

                      I have these controller:

                       

                      [root@SRV-ESXI-2:/opt/hp/hpssacli/bin] ./hpssacli ctrl all show detail

                      Dynamic Smart Array B140i in Slot 0b

                         Bus Interface: PCI

                         Slot: 0b

                         Controller Status: OK

                         Hardware Revision: C

                         RAID Stack Version: 3.02

                         Option ROM Version:3.49-10

                         Rebuild Priority: High

                         Surface Scan Delay: 3 secs

                         Surface Scan Mode: Idle

                         Parallel Surface Scan Supported: Yes

                         Current Parallel Surface Scan Count: 1

                         Max Parallel Surface Scan Count: 16

                         Wait for Cache Room: Disabled

                         Surface Analysis Inconsistency Notification: Disabled

                         Post Prompt Timeout: 15 secs

                         Cache Board Present: False

                         Cache Ratio: 100% Read / 0% Write

                         Read Cache Size: 64 MB

                         Write Cache Size: 0 MB

                         Drive Write Cache: Disabled

                         Total Cache Size: 0 MB

                         SATA NCQ Supported: True

                         Spare Activation Mode: Activate on physical drive failure (default)

                         Number of Ports: 4 Internal only

                         Driver Name: HP HPDS

                         Driver Version: 0.0.5

                         PCI Address (Domain:Bus:Device.Function): 0000:01:00.7

                         Controller Mode: RAID

                         Controller Mode Reboot: Not Required

                         Latency Scheduler Setting: Disabled

                         Host Serial Number: CZ2611052K

                         Sanitize Erase Supported: False

                         Primary Boot Volume: None

                         Secondary Boot Volume: None

                       

                      [root@SRV-ESXi-1:/opt/hp/hpssacli/bin] ./hpssacli ctrl all show detail

                       

                       

                      Dynamic Smart Array B320i RAID in Slot 0 (Embedded)

                         Bus Interface: PCI

                         Slot: 0

                         Cache Serial Number: PBKUB0CRH6H2O7

                         Controller Status: OK

                         Hardware Revision: C

                         RAID Stack Version: 5.00

                         HBA Firmware Version: 15.10.05.00

                         HBA Mode Option ROM Version: 07.25.05.00

                         Option ROM Version:3.54-0

                         Rebuild Priority: Medium

                         Surface Scan Delay: 3 secs

                         Surface Scan Mode: Idle

                         Parallel Surface Scan Supported: No

                         Wait for Cache Room: Disabled

                         Surface Analysis Inconsistency Notification: Disabled

                         Post Prompt Timeout: 15 secs

                         Cache Board Present: True

                         Cache Status: OK

                         Read Cache Size: 64 MB

                         Write Cache Size: 512 MB

                         Drive Write Cache: Disabled

                         Total Cache Size: 512 MB

                         No-Battery Write Cache: Disabled

                         Cache Backup Power Source: Capacitors

                         Battery/Capacitor Count: 1

                         Battery/Capacitor Status: OK

                         SATA NCQ Supported: True

                         Spare Activation Mode: Activate on physical drive failure (default)

                         Number of Ports: 2 Internal only

                         Driver Name: HP HPVS

                         Driver Version: 0.0.1

                         PCI Address (Domain:Bus:Device.Function): 0000:07:00.0

                         Host Serial Number: CZ342064VB

                         Sanitize Erase Supported: False

                         Primary Boot Volume: None

                         Secondary Boot Volume: None

                      • 8. Re: Esxi 6.0 slow network performance
                        AntonioFel Novice

                        All the interface on the switch are in auto.

                        I have force it to 1000-full but the issue is the same.

                        • 9. Re: Esxi 6.0 slow network performance
                          J1mbo Virtuoso

                          you need to enable the write cache of the b320 and upgrade the b140.

                          • 10. Re: Esxi 6.0 slow network performance
                            AntonioFel Novice

                            Ok, but as writed before, in the old enviroment with:


                            ProLiant DL360e Gen8


                            ProLiant DL180e Gen6


                            equiped with esxi 5.5, the speed between the two host was normal (wire speed). Nothing has changed, the controller b320 is the same.


                            Can you explain it?


                            Have the previuous version of esxi, a different behavior?


                            Thank you!!

                             

                             

                             

                            • 11. Re: Esxi 6.0 slow network performance
                              J1mbo Virtuoso

                              If you want to gain some assurance over the network side of things try running iperf both ways, eg:

                               

                              within a guest on one machine (I'll call it 1.1.1.1): iperf -s -w 256K

                              within a guest on the other machine: iperf -c 1.1.1.1 -w 256k and iperf -c 1.1.1.1 -w 256k -d

                               

                              This will show raw IP throughput across the physical network between the two guests. You should see 110MB/s (about 940Mbps) or more.

                               

                              Re caching - I've just edited this post as I miss-read the output from the b320 controller. It looks that the write cache is enabled on that. Do you see slow copy both from and to that host? Also, check all firmware is up-to-date and are you using the HP customised build?

                              • 12. Re: Esxi 6.0 slow network performance
                                AntonioFel Novice

                                Yes, the slow copy it's from and to the host, and the image it's an HP custom on both hosts.

                                 

                                But, sorry for the repeat, but i't importanto for me undestand, why in the old enviroment all works fine?

                                • 13. Re: Esxi 6.0 slow network performance
                                  J1mbo Virtuoso

                                  Check the driver versions on both environments - SSH to the hosts then run

                                   

                                  esxcli storage adapter core list

                                   

                                  to find the driver name, then

                                   

                                  esxcli software vib list

                                   

                                  To see the version. Others have reported driver v88 on 5.5 being OK but v100 being slow and a solution being to revert to the older driver (this thread).

                                   

                                  Hope that helps.

                                  • 14. Re: Esxi 6.0 slow network performance
                                    AntonioFel Novice

                                    Ok i have tried but the commands are refused:

                                     

                                    [root@SRV-ESXI-2:~] esxcli storage adapter core list

                                    Error: Unknown command or namespace storage adapter core list

                                     

                                    what is the right syntax ?

                                    1 2 Previous Next