5 Replies Latest reply on Jun 6, 2016 6:02 AM by dmorse

    The STAX service is not registered on the specified machine

    AbouElNadar Lurker

      I have seen this post https://communities.vmware.com/thread/275895?tstart=0 and I have the exact same problem. [it is not answered though]

      Everytime I try to run VMMARK-stax.bat file I get this error

      11.JPG

      12.JPG

      No log files and I reinstalled STAF a couple of times one but still there is no 'lang' directory under STAF

           C:\STAF\data\STAF    

      Also no 'log' under:

       

      When i run staf local stax version I get "Error submitting request, RC: 2"

      When i run staf local misc version I get  "3.4.24.1"


      I have STAF version 3.4.24.1 and a Stax version  3.5.16


      I cannot tell where is the problem but STAF is running on my machine.

      when I ping WIN-VK25EUQOMBT.maildomain.eri.cloud.com

      123.JPG

      I get a reply from the IPv6 on the client machine although I disabled IPv6


      Does anyone know what the problem could be ?

        • 1. Re: The STAX service is not registered on the specified machine
          RebeccaG Expert
          VMware Employees

          Hi there,

           

          You either skipped the step where you modified the staf.cfg file (In the VMmark 2.5.2 Benchmarking Guide, section "Create a Customized STAF.cfg File") or you saved it to the wrong location. Please check that the modified file is at C:\STAF\bin\STAF.cfg

           

          See STAX Error when executing VMMark2-STAX.bat - STAX Service Not Registered

           

          Also, I am not sure where you are thinking you should see a 'lang' directory?

           

          Thank you,
          Rebecca

          • 2. Re: The STAX service is not registered on the specified machine
            AbouElNadar Lurker

            Hello,

             

            I did modify the file and it is located in the C:\STAF\bin directory. 

            I attached the STAF.cfg file, maybe I am missing something.

             

            RebeccaG

             

             

            Thank you.

            • 3. Re: The STAX service is not registered on the specified machine
              dmorse Enthusiast
              VMware Employees

              Your STAF.cfg looks good.  I have a feeling maybe the STAX and EVENT services aren't in the right place.  Could you run this command from C:\STAF and attach services.txt?

               

              C:\STAF>dir /s c:\staf\services > services.txt

               

              I've attached my output so you can compare; it should be similar.  Specifically, you'll need STAFEvent.jar in the c:\staf\services\event directory, and STAX.jar in c:\staf\services\stax.

               

              Also, the output of "java -version"?

               

              Thanks,

              David

               

              • 4. Re: The STAX service is not registered on the specified machine
                AbouElNadar Lurker

                Hi,

                 

                I didn't have the STAFEvent.jar in the c:\staf\services\event directory so I added it and ran the command and all the files seem to match up now to the file you gave me. I attached my output.


                "java -version" output

                Capture.JPG

                I restarted my machine and I tried to run VMmark-stax.bat file again this is what I get

                11111.JPG


                If I press OK and try to submit a new job I get the following error

                123456.JPG


                Thanks,

                Nour.

                • 5. Re: The STAX service is not registered on the specified machine
                  dmorse Enthusiast
                  VMware Employees

                  I didn't have the STAFEvent.jar in the c:\staf\services\event directory so I added it and ran the command and all the files seem to match up now to the file you gave me. I attached my output.

                   

                  Actually, there's still one key difference between your output and mine: under c:\staf\services, you should end up with two directories: event and stax.  You only have stax (with event as a subdirectory under that).

                   

                  Per the guide:

                  Install the STAF EVENT Service

                  Follow these steps to install and configure the STAF EVENT service in the client system:

                  1 Download version 3.1.4 or later of the EVENT package from:

                  http://staf.sourceforge.net/getservices.php

                  2 Uncompress the zip file, placing the event directory it contains into the C:\STAF\services directory.

                  You should end up with:

                  C:\STAF\services\event\event.pdf

                  C:\STAF\services\event\History

                  C:\STAF\services\event\License.htm

                  C:\STAF\services\event\STAFEvent.jar

                   

                  Regarding the error when you click OK, you need to edit your C:\STAF\bin\staf.cfg and uncomment the default local trust line, so the local machine is trusted as well as 192.168.*.*:

                   

                  Incorrect:

                  # Set default local trust

                  # trust machine local://local level 5

                  trust level 5 machine 192.168.*.*

                  Correct:

                  # Set default local trust

                  trust machine local://local level 5

                  trust level 5 machine 192.168.*.*