1 2 Previous Next 16 Replies Latest reply on Sep 12, 2017 4:44 PM by kevinstiegler

    Can't enable VSAN

    equelin Novice
    vExpert

      Hello everyone,

       

      I feel that it may be a noob question but I can't figure how to enabled a VSAN cluster in my vCenter Worklab... As you can see on the screenshot there's no options available in the Cluster VSAN settings...

       

      The vcenter is in version 6.0.0 Update 2 build 3634794.

       

      Do you have any advices ?

       

      Thanks

       

      Error_VSAN.jpg

       

      Message was edited by: Erwan Quelin

        • 1. Re: Can't enabled VSAN
          zdickinson Expert

          Good afternoon, the first thing I go to is the vSAN networking.  Can all host ping the addresses on the vSwitches that you have enabled vSAN?  Thank you, Zach.

          • 2. Re: Can't enabled VSAN
            Richardson Porto Champion
            Community WarriorsUser ModeratorsvExpert

            Can you confirm if HA is disabled on cluster ? See: Using Virtual SAN and vSphere HA

             

            You must disable vSphere HA before you enable Virtual SAN on the cluster. Then you can reenable vSphere HA.

            ---

            Richardson Porto
            Senior Infrastructure Specialist
            LinkedIn: http://linkedin.com/in/richardsonporto
            • 3. Re: Can't enable VSAN
              equelin Novice
              vExpert

              Hello,

               

              Thank you for your responses.

               

              I'm sorry but my question was perhaps not enough precise. Here is what I'm expecting to find in my vCenter (Screenshot from another vCenter) when I look at the VSAN's settings:

               

              Error_VSAN_2.jpg

               

              This cluster has no host with VSAN enabled and all the options are greyed out as expected (except the modify button). If you look at the first screenshot you'll see that no informations are displayed and it's the same for the other menus related to VSAN.

               

              So my questions are:

              - I'm I missing something ?

              - Is there something I have to configure on the vCenter to be able to activate a VSAN cluster (services perhaps) ?

               

              Thank you

               

              Erwan

              • 4. Re: Can't enable VSAN
                zdickinson Expert

                Understood, is it possible that is a GUI error?  Perhaps the vCenter just needs to be restarted.  Thank you, Zach.

                • 5. Re: Can't enable VSAN
                  equelin Novice
                  vExpert

                  Hello,

                   

                  It may be a GUI error, but the reboot didn't solved the issue.

                   

                  I'll try to find a way to configure the cluster through CLI.

                   

                  regards,

                  • 6. Re: Can't enable VSAN
                    Muthur85 Lurker

                    Hello,

                     

                    You can work around this cosmetic issue without upgrading, by clearing the message, using one of these methods:

                    • Restart the VPXA management agent on VSAN nodes

                      Restarting the VPXA (vCenter Server) management agent on the VSAN cluster ESXi host nodes refreshes the information in vCenter Server and clears the message.
                    • Force an update to cluster membership

                      Removing and then re-adding a host to the VSAN cluster forces all hosts to update the information about the cluster membership, which clears the message.

                    Restarting the VPXA management agent on VSAN nodes

                     

                    To restart the VPXA (vCenter Server) management agent on the VSAN cluster ESXi host nodes:

                    1. 1. Enable SSH or the ESXi Shell on each host in the VSAN cluster. For information about enabling SSH or the ESXi Shell
                    2. 2. Log in to each host in the VSAN cluster using SSH or the ESXi Shell.
                    3. 3. Restart the VPXA management agent using this command:

                      # /etc/init.d/vpxa restart

                      Note: Wait approximately one minute before proceeding to the next host. This allow information from each host to update in vCenter Server one-at-a-time.

                    Forcing an update to cluster membership

                     

                    This message can be cleared by removing a host from the VSAN cluster and re-adding it. This forces all hosts to update information about cluster membership and the message clears after this action.


                    To remove a host from the VSAN cluster and to re-add it:

                    1. 1. Select one ESXi host in the VSAN cluster that can be put to the maintenance mode temporarily.

                      Note: VMware recommends to select the least busy/utilized host.
                    2. 2. In the vSphere Web Client, right-click the ESXi host and click Enter Maintenance Mode.


                      • Select either the Ensure AccessibilityFull data migration
                      • If applicable, allow powered-off virtual machines to be migrated to the remaining ESXi hosts.
                    3. 3. After the host has successfully entered maintenance mode, remove it from the VSAN cluster by dragging the host out of the cluster and into the datacenter object in the vCenter Server inventory.
                    4. 4. After moving the host into the data center, wait for approximately two minutes.
                    5. 5. Drag the host back into the VSAN cluster.

                      After the host is back in the VSAN cluster, right-click the host and click

                    Exit Maintenance Mode.
                    After the host is back in the production cluster, the message on the remaining hosts should be clear

                    • 7. Re: Can't enable VSAN
                      kermic Expert

                      The option to enable vSAN should still be available even if HA is on, at least I have it in my environment.

                      Just a thought - what is the ESXi version you are running on your hosts?

                      If I'm not mistaken then vSAN was introduced with 5.5 U1, could it be that at least one of your hosts in cluster is running an older version than that? Maybe version inconsistencies in your cluster?

                      Unfortunately don't have a test environment available now to to test this out.

                      • 8. Re: Can't enable VSAN
                        fitz123 Lurker

                        Have the same issue here, with last path VMware ESXi, 6.0.0, 3825889

                         

                        Tried to create a new cluster with vSAN, but after creation if I turn it Off, I have the same white screen as Main cluster has.

                        • 9. Re: Can't enable VSAN
                          alriz12 Lurker
                          We have EXACTLY the same issue. At first, we thought this was a licensing issue, but then VMware reminded us that it doesn't matter, we should still be able to configure VSAN even with trial licensing. Have you managed to fix it?
                          • 10. Re: Can't enable VSAN
                            elerium Hot Shot

                            I've sometimes seen this occur from bad caching in a browser, can you try a different browser or use incognito or in-private browsing?

                            • 11. Re: Can't enable VSAN
                              alriz12 Lurker

                              Hi everyone, could help and save time for others - we managed to fix the issue by simply restarting the vCenter appliance.

                              • 12. Re: Can't enable VSAN
                                gjbrown Novice

                                did you make any progress with this?  I've tried all suggested in this thread including rebooting VC and still have same issue.

                                • 13. Re: Can't enable VSAN
                                  san1983 Lurker
                                  VMware Employees

                                  Have you tried using different browser?

                                  • 14. Re: Can't enable VSAN
                                    chris122686 Novice

                                    Hi Equelin,

                                     

                                    You may try to reboot your vCenter Server or its services and try again to open a browser with cleared cache.

                                     

                                    Cheers.

                                    1 2 Previous Next