3 Replies Latest reply on Apr 11, 2016 4:46 AM by peetz

    Export-EsxImageProfile fails with error "VibSign module missing"

    peetz Master
    User ModeratorsvExpert

      Hi all,

      I get more and more reports from the users of my ESXi-Customizer-PS script that they run into errors with the latest release 6.3 R1 of PowerCLI.

      With one of them I confirmed that the issue is not specific to my script, but also occurs after manually running commands like these:

       

      Add-ESXSoftwareDepot "https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml"

      Add-ESXSoftwareDepot "https://vibsdepot.v-front.de"

      $CloneIP = Get-EsxImageProfile "ESXi-6.0.0-20160302001-standard"

      $MyProfile = New-EsxImageprofile -CloneProfile $CloneIP -Vendor $CloneIP.Vendor -Name ($CloneIP.Name + "-customized") -Description ($CloneIP.Description + " (customized)")

      $vib = Get-EsxSoftwarePackage "net-atl1"

      $MyProfile.AcceptanceLevel = $vib.AcceptanceLevel

      Add-EsxSoftwarePackage -SoftwarePackage $vib -Imageprofile $MyProfile

      $outfile = (Get-ChildItem env:temp).Value + "\" + $MyProfile.Name + ".iso"

      "Exporting to $outfile"

      Export-EsxImageprofile -Imageprofile $MyProfile.Name -ExportToISO -FilePath $outfile

       

      The Export-EsxImageProfile command throws the error

         Cannot instantiate 'certified' policy: VibSign module missing.

       

      Unfortunately I cannot reproduce this error myself, but I got reports of at least three different users experiencing this issue.

      Can anyone of the developers jump in and explain, what this error means, or how to troubleshoot it?

       

      Thanks

      Andreas