1 2 Previous Next 20 Replies Latest reply on May 30, 2016 11:28 PM by tbaublys

    vROPs 6.2 VM Tags gone

    vPAKMan Novice

      vROPs 6.1 had all my VM tags and was working great.  I used the tags to label VM's by customer and generated a report for billing using the tags so billing could verify the VM configuration matched the invoices.  (I know, Chargeback Manager, don't ask).  Then I upgraded to 6.2 and vSphere Tags (Summary|vSphere Tag) is missing as well as # of Hard Disks.

       

      Environment:

      I inherited vROPs and have been doing in-place upgrades using the method in the release notes to download the PAK files etc.

      11/12/2015 06:59:20 PM logbuildversion Build Version: VMware vCenter Operations Manager 6.1.0 Build 3037951

      01/29/2016 05:22:13 PM logbuildversion Build Version: VMware vCenter Operations Manager 6.2.0 Build 3445399

      02/11/2016 12:22:26 PM logbuildversion Build Version: VMware vCenter Operations Manager 6.2.0 Build 3528867

       

      Two vCenters monitored by vROPs.  One version 6.0 build 3339083 and the other 5.5 build 1945274 (don't ask)

      19 hosts (ESXi versions 5.0, 5.1, majority 5.5, a couple 6.0 U1a testing)

      About 215 active VM's depending on the day.

       

      Troubleshooting & Symptoms:

      the VMs with tags are on the vCenter 6 environment running on 10 hosts with 3 different versions of ESXi 5.5-2302651, 5.5-3248547 & 6.0-3380124

      The report does not show the tags so this eliminates any browser issues from the equation.

      I tried waiting longer to see if the data just had to be re-populated.

      I validated that the vSphere Adapters were still registered and working. 

      Changes made that are reflected in the same report such as vCPU assignments and vRAM assignments update in a reasonable amount of time so data is being pulled from the virtual machines successfully.

      I found this thread: Re: Not seeing vSphere tags when creating custom groups in vROps

      I have both rebooted the appliance & double-check the policies are set to collect the vSphere tags

      I validated the tags are still on the VMs in question according to vCenter

      I tried to create a group using tags and like the user in the forum, "load more" does not bring up any tags

      I tried creating a whole new view but using "vSphere World" for the sample data had the same result.

      I'm not seeing anything shocking in any of the collector logs. 

       

      Any other ideas or thoughts besides opening a case with support?

       

      Thanks.

        • 1. Re: vROPs 6.2 VM Tags gone
          mark.j Master
          VMware Employees

          I'm not seeing them either. I'm looking in to it on my lab..

          • 2. Re: vROPs 6.2 VM Tags gone
            sxnxr Expert

            I upgraded my lab yesterday to 6.2.0a from 6.1 and i can still see my tags. Are you on the latest (released yesterday)

            • 3. Re: vROPs 6.2 VM Tags gone
              mark.j Master
              VMware Employees

              I'm running 6.2.0a, which came out yesterday. See screenshots.. checking it with a View (cleaner than Custom Group Wizard), it looks like tags aren't getting picked up after an hour. I'm looking in to it some more..

              • 4. Re: vROPs 6.2 VM Tags gone
                sxnxr Expert

                It could be a time thing. I updated yesterday and only checked this today. I have attached some screenshots also

                • 5. Re: vROPs 6.2 VM Tags gone
                  mark.j Master
                  VMware Employees

                  Mine just popped up. Took a little over an hour after creation in vCenter, but it's good now. See attached.

                  • 6. Re: vROPs 6.2 VM Tags gone
                    vPAKMan Novice

                    Mark, that screenshot shows the tag coming in under "Summary|Custom Tag"; not "Summary|vSphere Tag".  Your vSphere Tag still shows "none".  vSphere Tag is where mine used to show up.  In trying to rebuild the View I do not have a "Custom Tag" property under "Virtual Machine".

                     

                    What am I missing?

                     

                    Thanks.

                    • 7. Re: vROPs 6.2 VM Tags gone
                      mark.j Master
                      VMware Employees

                      Well, I'm running vR Ops v6.2.0a and vCenter 5.5 build 200*, so I'm not far off from what you've got. Mine are annotations using the .NET client. Yours are probable NGC tags. I just added a NGC tag to this VM, so I'll let it bake and see how it shows up in vR Ops.

                      • 8. Re: vROPs 6.2 VM Tags gone
                        mark.j Master
                        VMware Employees

                        Done, much faster collecting the NGC tags than vCenter annotations!  5-min interval collection instead of an hour. See attached.

                         

                        So, short answer is that it works for me. Maybe this will give you some ideas on testing, though?

                        • 9. Re: vROPs 6.2 VM Tags gone
                          vPAKMan Novice

                          What I am doing is the VMware documented practice of logging in to the vCenter WebUI, going to tags, creating the tags, and then going into VMs & Templates and assigning the tags.  I'm not trying to be all fancy.  I am trying to use the ordinary, documented method of assigning tags as documented here: Tagging Objects

                           

                          Those tags are not coming over.  You circumvented that process and used a different process so your latest results are not valid results for my complaint.

                           

                          The tags I created & assigned yesterday afternoon still have not shown up 12 hours later.

                           

                          Thanks.

                          • 10. Re: vROPs 6.2 VM Tags gone
                            mark.j Master
                            VMware Employees

                            I did not circumvent any process as you just stated, I created two types of tags. One using the .NET client to create annotations, and the other using the Web Client to create tags. These are two completely different things. You scenario is the latter, and exactly what I did and posted screenshots on. If you policies are setup and the attributes are enabled per my policy screenshot, the tags should be collecting. I checked my end to see if I could reproduce your issue, and I cannot. I suggest opening a SR so they can look at it with you.

                            • 11. Re: vROPs 6.2 VM Tags gone
                              vPAKMan Novice

                              Sorry, I missed the screenshot where you got the tag to show up finally.

                               

                              My vROPs does not seem to have a default field to pull the annotations or notes.  If it does, I can't find it.  I'm not crazy about the idea of having to create another vROPs customization that will get wiped out in some future upgrade again.

                               

                              One thing I noticed going over everything again is that on my vCenter 5.x environment is getting data that my vCenter 6 environment is not.  For example, "Disk Space|Number of Virtual Disks".  On my vCenter 6 environment VMs the results show up as "-" but in my vSphere 5.x environment VMs come back with the proper number.  So as a test I added tags to my vCenter 5.5 environment this morning.  Sure enough they showed up jsut fine.

                               

                              So the problem I am having appears to be specific to vROPs 6.2 and vCenter 6.0.

                               

                              Thanks.

                              • 12. Re: vROPs 6.2 VM Tags gone
                                mark.j Master
                                VMware Employees

                                That definitely does help us narrow down the root of the issues. What permissions does the vR Ops colection service account have on the vCenter v6? And is the vCenter v6 an appliance or installable? Your vR Ops v6.x installation...  where did it's life begin version-wise? Was it upgraded from v5.x? Thanks

                                • 13. Re: vROPs 6.2 VM Tags gone
                                  vPAKMan Novice

                                  Permissions:  the service account we are using is an active directory user account in a security group for VMware administrators which is assigned to the "Administrator" role at the root level (the group is, not the user, so we are working with AD groups).  The group is NOT defined in any of the Windows local groups on the vCenter server.

                                   

                                  vCenter 6 install-able on Windows Server 2012 R2

                                   

                                  vROPs is the appliance version.

                                   

                                  I inherited vROPs and vCenter both so I cannot say with 100% certainty but I am confident it started as vROPs 6 because the appliance version says 6.0.0.2263110 Build 2205710.  My predecessor allowed himself to get pulled in too many different directions and there was a lot that was not updated when I took over.  I updated vROPs to 6.1 and then 6.2 as described in the initial post. 

                                  • 14. Re: vROPs 6.2 VM Tags gone
                                    arubio Novice

                                    last versions and same problem here

                                    1 2 Previous Next