11 Replies Latest reply on May 16, 2018 12:18 AM by yusufritz

    install ESXi, stop on "Relocating modules and starting up the kernel"

    bobbym4 Lurker

      My computer is Intel NUC5PPYH, the processor is a 14nm Pentium n3700.

      Hardware: Intel® NUC Kit NUC5PPYH Specifications

      According to the official website of the information, VT-x/VT-d are supported.


      but i install ESXi, stop on "Relocating modules and starting up the kernel"


      I tried many methods:

      1, Change different ESXi versions 5.1,5.5,6.0.

      2,Upgrade BIOS, set the BIOS boot mode, set the video card memory size.

      3, Press Shift + O before installation and enter ignoreHeadless = TRUE.

      4, Usb disk ISO, PXE boot ISO.

      The above methods fail



        • 2. Re: install ESXi, stop on "Relocating modules and starting up the kernel"
          PeshoTigara Lurker

          I am also on the same boat. Tried everything possible, created custom iso with the chipset and lan drivers, even installed the esxi on another usb using vmware fusion and then booted the nuc with the installed esxi usb, but still hangs on the "relocating modules..".

          • 3. Re: install ESXi, stop on "Relocating modules and starting up the kernel"
            tomcherlet Lurker

            Hey did you found the solution? i am having the same problem :/

            • 4. Re: install ESXi, stop on "Relocating modules and starting up the kernel"
              esxi_user Lurker

              I came across the same problem on a bay-trail based system.  I had to do the following:

              1) set BIOS "max cpuid value limit" to disable

              2) Redirect the Direct Console to a Serial Port by Setting the Boot Options Manually

                   - At startup press Shift+O and append the following boot options

                   "gdbPort=none logPort=none tty2Port=com1";

              3) connect a null modem cable from the esxi host pc to another pc.  This will allow you to finish the install and see further messages if there are more issues.

              4) after installation completes, boot up the host and repeat steps 3 and 4 (if the screen continues to show the "relocating modules" mesg)

              - the relocating modules message has something with ESXI not liking the video card.  Anyways, this just means you won't be able to use the local display to manage ESXI but you can still use vshpere client to manage the system remotely.

              5) setup your management ip and launch the vsphere client to manage your new esxi host.


              Hope this helps.  Good luck!

              • 5. Re: install ESXi, stop on "Relocating modules and starting up the kernel"
                rhoenie Lurker

                I successfully installed VMware ESXi 6.5 on my NUC5PPYH (Intel Pentium N3700, 8GB RAM, 256GB SSD) using these steps on Windows 10:


                • Configured a static DHCP lease on my router for the MAC address of the NUC
                • Updated BIOS to latest version 0059, loading BIOS defaults
                • Downloaded and installed VMware-PowerCLI-6.5.0-4624819.exe
                • Downloaded ESXi-Customizer-PS-v2.5.ps1
                • Downloaded and installed rufus-2.12.exe
                • Downloaded ESXi drivers for onboard network and SATA : net55-r8168-8.039.01-napi.x86_64.vib, sata-xahci-1.39-1.x86_64.vib
                • Created an empty C:\Temp directory and put the .vib files in there
                • Ran the customizer PS script like so: .\ESXi-Customizer-PS-v2.5.ps1 -pkgDir C:\Temp
                • Wrote the created ESXi-6.5.0-20170104001-standard-customized.iso on a USB stick using Rufus
                • Wrote a kickstart file (see below) and copied it as ks.cfg on the USB stick
                • Ejected the USB stick from Windows, put it in the NUC and booted it
                • Pressed Shift + O when the ESXi installer started booting up
                • Changed the command line to: > runweasel ks=usb:/ks.cfg
                • Waited for about 15 minutes for the installer to finish


                Since the system is lacking support for the Braswell graphic chip you wont see anything on the screen happening besides that last line "Relocating modules and starting up the kernel...".

                Just ignore it.


                Please note that the ks.cfg script will erase all contents of the drive inside the NUC!



                # ks.cfg: scripted installation file for ESXi 6.5 installation


                # Accept the VMware End User License Agreement



                # Set the root password for the DCUI and Tech Support Mode

                rootpw mypassword


                # Install on the first local disk available on machine

                clearpart --firstdisk --overwritevmfs

                install --firstdisk=local --overwritevmfs


                # Set the network to DHCP on the first network adapter

                network --bootproto=dhcp


                # reboots the host after the scripted installation is completed



                # enable SSH and the ESXi shell

                %firstboot --interpreter=busybox

                vim-cmd hostsvc/enable_ssh

                vim-cmd hostsvc/start_ssh

                vim-cmd hostsvc/enable_esx_shell

                vim-cmd hostsvc/start_esx_shell


                • 6. Re: install ESXi, stop on "Relocating modules and starting up the kernel"
                  CarstenJ1000 Lurker

                  This description Worked for me on my Intel NUC5PPYH


                  But I made a minor change in the ks.cfg:



                  # Set the network to DHCP on the first network adapter


                  network --bootproto=dhcp --device=vmnic0

                  • 7. Re: install ESXi, stop on "Relocating modules and starting up the kernel"
                    nikiangel Lurker

                    I will need some help with the instruction (I'm completely new in powerCLI).

                    I'm stuck on creating the iso.

                    I downloaded and installed the VMware-PowerCLI-6.5.0-4624819.exe

                    Created (windows 10) C:\Temp

                    Placed the 2 .vib files there

                    Then I stared the shortcut "VMware PowerCLI" (run as administrator) created after the install of VMware-PowerCLI-6.5.0-4624819.exe. It gave me some permission error which I fixed by execut in the terminal "Set-ExecutionPolicy Unrestricted -Force"

                    After this I'm getting the screen below when I start "VMware PowerCLI"


                    When I try to execute the command, I get


                    Please help.


                    OK, the problem here after all was that I was using the "VMware PowerCLI" and I had to use "VMware PowerCLI (32-Bit)".

                    I created the iso successfully, but now I want to do a little more and facing another problem:

                    I want to add another driver in the image, which seems is missing a signature:

                    An unexpected error occured:

                    The VIB xxxxxxxxxxxx does not contain a signature.

                    I want to add it as this will allow me to have a second network adapter (USB to gigabit) in the NUC, and the best would be to have it in the iso image and not to load it manually(or at least these are my expectations).

                    Any suggestions how to skip the signature check?

                    I tried

                    .\ESXi-Customizer-PS-v2.5.ps1 -pkgDir C:\Temp --nosigcheck

                    but no success,

                    .\ESXi-Customizer-PS-v2.5.ps1 -pkgDir C:\Temp -NoSignatureCheck

                    also no success.


                    After reading a little bit more, especially in the "ESXi-Customizer-PS-v2.5.ps1" script, I found that the right command for me is:

                    .\ESXi-Customizer-PS-v2.5.ps1 -pkgDir C:\Temp -nsc


                    Now I have the ISO with all 3 drivers inside and hopefully I can get a NUC5PPYH with 2 native lan adapters,just waiting the adapter to be delivered to me.



                    • 8. Re: install ESXi, stop on "Relocating modules and starting up the kernel"
                      superQ1 Lurker

                      I have tried your method but it seems I'm not having much luck ...

                      I created the ks.cfg in notepad on windows and saved it to the usb to which I deployed the customized ISO with rufus.

                      So it boots and I press Shift-O and run "runweasel ks=usb:/ks.cfg" added to .. and it runs until "Relocating modules and starting up the kernel..."

                      Then stops there ... after waiting an extraordinary amount of time I reboot the device and it cannot boot - says insert boot media or select a proper boot device.

                      Ie it hasnt installed anything ...

                      I am running a 128 Mb SSD with 8Gb RAM ...

                      This is very frustrating ... any help???

                      • 9. Re: install ESXi, stop on "Relocating modules and starting up the kernel"
                        avalonzst Novice

                        I got the same problem on a pc server of Lenovo X3650 M5.

                        But only adding  a booting parameter ignoreHeadless=TRUE  did not solve the problem.

                        By change the option in BIOS of  boot mode to legancy and processer mode to max performance and add ignoreHeadless=TRUE in the boot option, I can install esxi on the server using custom images downlowed from vmware.

                        • 10. Re: install ESXi, stop on "Relocating modules and starting up the kernel"
                          chtugha Lurker

                          I had to try several times until I got it working:





                          1.)  BIOS: reset to default ! and DISABLE UEFI boot - leave only legacy usb (if you leave uefi the shift+o commands will be ignored)


                          2.)  Remove ANY HDD/SSD/WHATEVER from the NUC - you will add it again later


                          3.)  Make the aforementioned boot stick from rhoenies post.


                          4.)  Make a ks.cfg file on the stick with the following content




                          rootpw whatever

                          network --bootproto=dhcp

                          clearpart --firstdisk --overwritevmfs

                          install --firstdisk --overwritevmfs --novmfsondisk




                          5.) Plug the stick into your NUC and press Shift+O at the ESXI bootloader


                          6.) Type:     >runweasel ks=usb:/ks.cfg ignoreHeadless=TRUE            and press Enter


                          7.) ESXi will now be installed (takes about 15 Minutes) - then the machine will reboot


                          8.) After reboot your NUC will complain: "no disk found" - reboot and enter BIOS


                          9.) Enable UEFI boot and check the box at "Boot usb disk first". Check "suppress alert messages" too.


                          11.) Save bios and shutdown -> Now you can reinstall your HDD/SSD


                          12.) Remove the stick from your NUC, plug it into you computer and make following change inside BOOT.CFG: "kernelopt= installerDiskDumpSlotSize=2560 no-auto-partition ignoreHeadless=TRUE"


                          13.) Now plug your stick back in and enjoy your fully working ESXi host by just acccessing it over https://IP-ADDRESS/ui


                          14.) After trying every bios option possible I gave up: you can't run a NUC5PPYH without a monitor or a vga dummy connected. So if you plan on running your NUC complete headless I recommend ordering a 5$ hdmi dummy.



                          If you encounter Problems it is usually related to your USB-Stick. You can try this:

                          >runweasel ks=usb:/ks.cfg ignoreHeadless=TRUE preferVmklinux=TRUE

                          But if it doesn't help try a different USB-Stick. I recommend not to use a USB 3.0 capable one.

                          • 11. Re: install ESXi, stop on "Relocating modules and starting up the kernel"
                            yusufritz Lurker



                            I am having the same issue.


                            I have installed the VMware Workstation on WIN 2012 R2 server there i am trying  to configure esxi 6.0 but getting the same error.


                            Relocating modules and starting up the kernel


                            Does anyone have ides how could i resolve this issue.