1 Reply Latest reply on Dec 30, 2015 7:08 AM by tom.elder

    Get-PIComputeInstance successfully errors out

    tom.elder Novice

      Get-PIComputeInstance : 12/29/2015 11:30:27 AM    Get-PIComputeInstance

      Getting vCloud Air compute instances is only supported on vCloud Air platform.

      For VCHS platform use Get-PIDatacenter to retrieve the data centers instead.

       

       

      At line:1 char:1

      + Get-PIComputeInstance

      + ~~~~~~~~~~~~~~~~~~~~~

          + CategoryInfo          : InvalidOperation: (:) [Get-PIComputeInstance], P

         IException

          + FullyQualifiedErrorId : InstanceServiceImpl_GetPIComputeInstances_Execut

         edOnSubscription,VMware.VimAutomation.PCloud.Commands.Cmdlets.GetPICompute

        Instance

       

      this actually returns  the information after displaying this error

      I am at power shell 4.0 and power CLI 6 Release 3

      windows 7 sp 1

      kind of a pain because I need the code to smoothly execute and at this point it pauses after the error is displayed and requires me to hit the enter key

      course I am running the code like an interpreter and have  not tried to put it into a script to run

       

      anyone run into this phenomena?

      funny thing when I run the Get-PIComputeInstance on the VCHS platform it does the same thing without succeeding

       

      thanks

      in advance