3 Replies Latest reply on Oct 19, 2015 12:46 AM by PierluigiDefendi

    Unable to Configure replication

    PierluigiDefendi Lurker

      Hello

       

      I have a problem with Vsphere Replication.

       

      I needed to expand the system disk of a Windows Server VM that was also replicated (all was working ok).

      So I did :

      From VR I stopped the replication ( otherwise I couldn't edit VM setting and change the disk parameter).

      Stopped the VM

      Edit the setting and changed the Disk setting ( increased 5 GB)

      Restart the Windows VM

      Used ExPart utility from Dell to expand the system disk C:

      Now my system disk was 5 GB more than before. So all went ok. I did also a restart of the VM just in case.

      .

      Then I tried to RECONFIGURE the VR replication of this VM, but when I tried to Reconfigure Replication I got the error.

       

      The virtual machine XXXX  has failed validation and cannot be configured for replication:

      Host is not powered on

       

      I can't understand why. Does someone know something about this situation?

       

      Many thanks in advance.

      Pierluigi

       

      Ps. esx 5.5 with Vsphere (vmware essential plus)

        • 1. Re: Unable to Configure replication
          Jimmy15 Enthusiast

          It is test soultion, I did on 8 VMs successfully..

           

          Follow step by step

           

           

          To resize virtual machine disk files (vmdks) that are protected by vSphere Replication:

          1. Locate the directory or directories where the virtual machine is currently replicating to. Rename these directories using the datastore browser.

          2. Note and record the vSphere Replication configuration for the virtual machine (RPO settings, destination datastores, and so on).

          3. Stop replication for the virtual machine at the protected site using the vSphere Replication User Interface (UI).

          4. Re-size the virtual machine's disks on the protected virtual machine using the Edit Settings.

          5. Resize the virtual disk on the recovery site:
            1. SSH to an ESXi host that has access to the datastore on the recovery site containing the replicated disks.
            2. Change directory to the renamed directory where the vmdk files are stored.
            3. Increase the size of the disk with the vmkfstools command:

              vmkfstools -X 50G Test-VM.vmdk


          6. Once the vmdks have been resized on both sites, rename the folder from step #1 back to its original name using the datastore browser.

          7. Re-configure replication for the virtual machine, using the replication configuration you noted in step #2. You will need to select the datastore folder manually and you will be prompted to use the replicated disks as seeds.

           

          VMware KB: Resizing virtual machine disk files that are protected by vSphere Replication (VR) using VMware vCenter S…

          • 2. Re: Unable to Configure replication
            Jimmy15 Enthusiast

            If you wish , I can provide you the details with screenshots for better understanding..

             

            Regards

            Pankaj Sharma

            • 3. Re: Unable to Configure replication
              PierluigiDefendi Lurker

              Hi Pankaj Sharma

               

              Many thanks for your help. Next time I have to do another resize I will follow your indication to avoid the problem I had.

              But for now I'm in trouble.

               

              When I stopped the replication of the VM I saw that VR left on the datastore the replicated VM so I Canceled it.

              The VM is just a single disk 20 Gb so I thought ... not so big to re-start a new replication... ( sorry but I didn't know what you just explained to me)

              But now, while the VM is power on and working, if I try to reconfigure a new Replication of this VM I got the above error.

               

              Could you help me?

              Pierluigi