13 Replies Latest reply on Mar 17, 2016 9:56 PM by daneyoung

    Issue with Hyper-V Integration Services on vSphere 6.0

    ricklionheart Lurker

      Greetings, I'm running Hyper-V (2012 not R2) nested on vSphere 6.0

       

      Everything works except the Hyper-V integration services. The virtual machines on Hyper-V for some reason thinks they are a physical system and they don´t let start/install/upgrade the integration services. Some screenshots documenting the issue:

       

       

      I've tried everything I know or been able to find:

       

      • Use different options in the vmx file: hypervisor.cpuid.v0, vhv.enable, winHyperV guest OS, etc.
      • Use different options in the hyper-V host (virtual machine).
      • Running different hardware versions on the Hyper-V vm (9,10,11).
      • Tried with and without vmware tools on the Hyper-V hosts.
      • Tried different OS within Hyper-V (server 2008 R2 and 2012).
      • Several patches and upgrades on the host/guest side.

       

      I've seen this issue documented in this post: http://vblog.is/?p=94 and the solution seems to downgrade the ESXi 6.0 host to 5.5 and that is not an option for me (and I really need the integration services running for testing purposes).

       

      Any help will be appreciated, thanks,