6 Replies Latest reply on Oct 12, 2015 4:15 AM by pt__

    Fusion 8 - using native "Retina" resolution is still buggy

    pt__ Novice

      In System Preferences, Displays, choose "scaled" and then "more space" (you must have a retina screen to do this).

       

      VMWare Fusion now scales guests incorrectly (even when "use full resolution for retina display" is ticked), which results in blurry guests and a resolution that is actually greater than the resolution of the physical screen.

       

      Can this bug be fixed now that a new version has been released?

        • 1. Re: Fusion 8 - using native "Retina" resolution is still buggy
          SK9985 Novice

          Having the same exact issue. Regardless of my scaling preferences in OS X, I expect Fusion to use the native resolution in the VM when "use full resolution for retina display" is ticked. Coming from Parallels (where this worked just fine), it's really annoying and should be fixed ASAP. I opened a support ticket and should get a call from support. Hopefully they can offer a fix or workaround.

          • 2. Re: Fusion 8 - using native "Retina" resolution is still buggy
            Andyo Novice

            I downgraded back to version 7 as this was so annoying.

            • 3. Re: Fusion 8 - using native "Retina" resolution is still buggy
              sjordi Novice

              The only reason I upgraded to Fusion 8 was the supposedly Retina display for Windows machines.

              None of the resolutions or options bring Retina to Windows.

              I feel I have been ripped off to say the truth.

              I made a screenshot of their claim as to me, this is misleading advertisement.

              • 4. Re: Fusion 8 - using native "Retina" resolution is still buggy
                SK9985 Novice

                I got a call from vmware support yesterday. After demonstrating the issue, it was clearly reproducible and not working as expected. The support agent told me to get back to me on Friday but they are gonna fix the issue he said. In Fusion 8 a new display driver was created to support DirectX10 - which obviously is still buggy. I hope they fix it soon...

                • 5. Re: Fusion 8 - using native "Retina" resolution is still buggy
                  SK9985 Novice

                  A quick update for all who are suffering from the same issue. Got another call from support with a workaround - which at least is working for me. Here's the setup:

                   

                  MacBook Pro (13") with external 4k display (Dell P2715Q)

                  On OS X the Display Preferences are set to "Medium" (Looks like 2560x1440) but it should also work with the other settings

                  On Fusion in my VM settings under Display:

                  "Use full resolution for Retina display": checked

                  "Automatically adjust user interface size in the virtual machine": uncheck because I want to explicitly run my Windows VM with 200%

                  Full Screen: "Stretch the virtual machine in the screen"

                   

                  Then, as suggested by vmware support, I downloaded the small freeware tool "Retinizer": Retinizer

                  Once you downloaded it, open it and drag the vmware Fusion icon to the Retinizer window and "retinize" it. You may need to explicitly allow retinizer to run in Preferences | Security & Privacy.

                  Then start the VM and set the resolution (Display Settings) to the native resolution of the display.

                   

                  That should be it. In case you have a laggy mouse, change the Gaming optimization in vmware Fusion preferences to not optimize for games. In my case, changing this setting alone didn't help so I needed to enable the Mouse shadow in the Mouse control panel under Windows, log off, log back in and disable the Mouse shadow again. Not sure what vmware is doing when this preference is changed but it actually changed the mouse behavior and isn't laggy anymore.


                  The vmware support agent also assured that despite that workaround, the issue will be fixed in one of the next releases...


                  cheers

                  • 6. Re: Fusion 8 - using native "Retina" resolution is still buggy
                    pt__ Novice

                    Thanks for the workaround. This does not work well for me; the guest is at the correct resolution and is taking up the full screen, but it is still blurry and, as such (I guess it is being scaled multiple times), is very laggy.

                     

                    My preferred workaround is to install SwitchResX and simply switch to my native resolution (2560x1600) when I want to use a virtual machine. But then OS X applications are too small. You can set SwitchResX to automatically switch resolutions when VMWare gains focus (and switch back when it loses focus), but it is still not ideal.

                     

                    I await the fix.