1 Reply Latest reply on Sep 3, 2015 8:37 PM by solgaeDK

    Fusion 8 with Retina Display - wonky mouse

    Matthewe79 Novice

      When i enable the Retina Display option under graphics and have let VM tools adjust my display configuration, i am finding that the mouse cursor is laggy or not as fast as when Retina display is off, or in Parallels 9 or 10.

       

      Is this a bug? or is there a setting where i can make the mouse as responsive as it is when the Retina option is disabled?

       

      Thanks.

        • 1. Re: Fusion 8 with Retina Display - wonky mouse
          solgaeDK Enthusiast

          I was able to somewhat improve it by going into menu VMware Fusion -> Preferences, and under Gaming, select Never optimize mouse for games. No reboot of the VM or Fusion app required. You might benefit from a different option (e.g. Always optimize) though.

           

          Still, I can't help but feel it's in some ways worse than Fusion 7 or Parallels 10. Graphics, while much faster in terms of FPS numbers on 3D games, are showing pauses every now and then, and the mouse pointer freezes when that happens. This is running on Windows 10. Given the OS's heavy dependency on hardware acceleration in graphics, it is much more noticeable. I'm running mid-2015 MacBook Pro with Intel Iris Pro graphics.

           

          EDIT: I found that unchecking Automatically adjust user interface size in the virtual machine and letting Windows run in 100% scaling (i.e. letting VM run on full retina resolution without UI scaling) will resolve a lot of the pauses and choppy mouse movement issues. The problem is that it's nigh-unusable unless you have very sharp eyes. Once I manually adjust the scaling to be 200% (i.e. making it the same as OS X default retina scaling), the problem comes back.

           

          So the root cause seems to be on Fusion 8's handling of scaling within Windows. Much as the majority of Windows apps suck at HiDPI scaling, it is not very usable without it. And not turning on retina option in VM makes the screen somewhat blurry.