2 Replies Latest reply on Aug 17, 2015 2:22 PM by continuum

    Issues with a vmfs raid5 array

    apitsos Novice

      Hi there!

       

      I am in trouble with a vmfs Raid-5 array for about 2 weeks now. Unfortunately there was a damage on the Raid controller (DELL Perc 5/i) of my office's server (DELL PowerEdge 2950 II) and I lost a Raid-5 array. This server was running ESXi 5.5. As soon as the controller was came back, I tried to import the missing array through its BIOS configuration, but I was getting a message that two of the three missing disks were unable to recovered. So I decided to proceed with other steps in order to get the array back in a working condition and get my data.

       

      The three disks were 1TB Seagate SATA 7.2k. They were compatible PC drives, nothing important or special.

       

      So, I connected the three disks on a computer running Windows 8.1 and after searching and trying several utilities and software I finally managed to make the RAID-5 array recoverable. Between others I tried Raid Reconstructor 4.32 by Runtime Software, ReclaiMe Free RAID Recovery, ReclaiMe PRO and others. The one that could give me restoration process was the R-STUDIO Network 7.6 by R-Tools Technology. That software could give me a disk image, but I had to save it somewhere. After trying to build a big enough disk using an external NAS I managed to get a .dsk file with the image of my missing array.

       

      I was trying to find a way to mount this image on a system and be able to "read" the VMs' files (.vmdk, .vmx, etc), but UI couldn't. I used OSFMount and other solutions, like the open-source vmfs-driver available at Google Code, but I wasn't lucky enough. Then I decided to proceed with another recovery of the array, using .vhdx image this time. It took more than 2 days to create the image and now I have spent more than a day to find a way to "read" it. Unfortunately I couldn't. I tried to add it as iSCSI on a Windows 2012 R2 server and attach it to an ESXi server, but it said that the drive was empty (and probably not formatted). I tried vmfs-driver on Windows again, but nothing. It doesn't recognize the \\.\PhysicalDriveX as a vmfs formatted drive.

       

      I am desperate at this moment and I am looking for a solution. Some of the Virtual machines were stored in this array were really important and I would really like to find a way to get recovered the .vmdk files of them.

       

      Could someone expert from here to help me find a solution please?

       

      Here is what I get when I try to attach the drives to the controller again:

      DELL-Controller-Missing-webfriendly.jpg

       

       

      Kind regards,

      Angelos Pitsos

        • 1. Re: Issues with a vmfs raid5 array
          apitsos Novice

          I think I missed something on the given information. I used with success ReclaiMe PRO and that application gave me the images I have. Also on the very first steps, I managed to get the reconstructed RAID array on an external NAS, which I attached to my ESXi Server via e-SATA port. Only one virtual machine was able to run. All the others didn't run. I checked the vmdk files and they were not boot-able. I tried to use Windows Server CD in order to make a repair installation (by hitting "R" on the third step), but unfortunately the disk was appeared as unallocated. I didn't proceed with anything further than that. I proceeded with the other steps I described on the first message.

           

          Please don't hesitate if you want any more information in order to provide me with a solution.

           

          Any kind of help is welcomed and of course much appreciated.

           

          Thanks a lot in advance all of you for paying attention on reading my post and trying to provide some kind of help.

           

           

          Kind regards,

          Angelos Pitsos

          • 2. Re: Issues with a vmfs raid5 array
            continuum Guru User Moderators vExpert

            > I checked the vmdk files and they were not boot-able

            Thats not unexpected - I rather expect that recovered vmdks are not bootable before a repair via Testdisk.
            Are you still busy with this ? - call me via Skype if you want

             

            Ulli