1 2 Previous Next 29 Replies Latest reply on Dec 26, 2015 4:18 PM by lsh08 Go to original post
      • 15. Re: Windows 10 + Boot Camp VM = activation issue (error 0xc004c003)
        lsh08 Novice

        I had a similar situation to you.   I believe if you reinstall your Win7 & activate, then upgrade but do the clean install option you'll

        at least be activated on bootcamp again.  That's what I did from my oem win 8 pro version.   I had a failed upgrade.   Tried to install clean but couldn't activate.   So started a fresh win8 pro install, activated, the upgraded using the fresh install option (not sure how that was worded). 

         

        But I started with  a retail win8 pro system builder license that I think I did have to call to activate on VM too.   So I don't think the retail legacy is the problem.     Maybe any upgraded win10 has an issue?      It would be interesting to know if anyone that upgraded activated on both AND if everyone with retail WIN 10 activated on both.    Maybe a poll on macrumors would help sort out what works.

         

        I am unable to activate both bootcamp and VM       I'm wondering what will happen to us as the 30 days approaches?

         

        I do rarely boot into windows natively, so also wondering if I can deactivated bootcamp and activate in Vm?

        i do need the option to boot natively in windows overall.

        • 16. Re: Windows 10 + Boot Camp VM = activation issue (error 0xc004c003)
          KenV99 Lurker

          You can deactivate a key following the steps here: http://www.thewindowsclub.com/deactivate-uninstall-windows-product-key

          As a full disclaimer, I haven't tried this with Windows 10, so YMMV.

          • 17. Re: Windows 10 + Boot Camp VM = activation issue (error 0xc004c003)
            brianez21 Novice

            Actually, this could be a VMware problem.

             

            Look at the log file for the driver which VMware Tools installs to handle these activation issues:

            C:\ProgramData\VMware\RawdskCompatibility\vmrawdsk.log

             

            You'll see this:

            Windows OS is earlier than Vista; driver exiting.

             

            Even though you're on Windows 10.

            • 18. Re: Windows 10 + Boot Camp VM = activation issue (error 0xc004c003)
              morts331 Novice

              That could be part of the problem.  From what I have been reading the main problem is the FREE upgrade version of Windows 10 is bound to 1 machine only (hardware ID).  The thing that bothers me is that it doesn't matter if you upgraded from win 7 retail to win 10, you still can't activate more than once or transfer the license to a new computer.  There are a lot of people annoyed of that.  The retail version should be transferable to a new machine.

               

              There is a work around posted in the original post, however I've had no luck with it working.  Maybe it did work at one point.  After reading the output of 'slgmgr /dlv' there is an "Installation ID".  I'm guessing MS is only allowing 1 hardware ID per installation ID which is why bootcamp and fusion can't seem to be activated at the same time; 2 hardware ids and 1 installation id.  This is the part that vmware tools should probably handle.

              • 19. Re: Windows 10 + Boot Camp VM = activation issue (error 0xc004c003)
                Data2Go Lurker

                I am seeing this issue, or something very much like it, with a clean retail (paid, no upgrade) install of Windows 10 Professional. It activated in Boot Camp and now will not activate in VMWare Fusion 8. I have not had an opportunity to call the provided phone number and wait.

                 

                The last time I had an activation issue, many years ago with an earlier version of Windows, MS was able to resolve the issue over the phone, so I am optimistic at the moment.

                • 20. Re: Windows 10 + Boot Camp VM = activation issue (error 0xc004c003)
                  Woodmeister50 Novice

                  The issue is that Windows10 is more tightly bound to the hardware than ever before.

                  The thought is that a given piece of hardware will always be upgradable regardless of owner.

                  In a way, the Windows license is now "owned" by the computer and not the user, thus the issue

                  with Bootcamp and VMs as the virtual hardware varies enough from the real hardware to trigger

                  non-activation.

                  • 21. Re: Windows 10 + Boot Camp VM = activation issue (error 0xc004c003)
                    morts331 Novice

                    Looks like this issue may have been finally resolved.

                     

                    When fusion 8.0.1 first came out I set up a new bootcamp vm and couldn't get it activated in both fusion and direct boot.  After that failed attempt I deleted the vm from fusion and uninstalled vmware tools.  Today I set up a new bootcamp vm and after installing vmware tools windows 10 activated successfully in fusion.  I then directly booted bootcamp and it's still activated. 

                    • 22. Re: Windows 10 + Boot Camp VM = activation issue (error 0xc004c003)
                      raustinat Lurker

                      Sadly not the case. Here's what I did, running VMware 8.0.1 on El Capitan:

                       

                      - Booted my Boot Camp Windows 7. Upgraded to Windows 10. Activated.

                      - Booted OS X. Booted up the Boot Camp VM. Installed VMware tools. Not activated.

                       

                      Here's the kicker:

                       

                      - Created a *new* VM in OS X, this time for Win 7. Installed Win 7. Installed 100s of updates. Installed Windows 10. Activated.

                      - Booted my Boot Camp Windows 7 natively. Still activated.

                      - Booted back to OS X and the Win 10 VM. Still activated.

                      - Booted up the Boot Camp VM. Not activated.

                      - The Win 10 VM is still activated. Boot Camp is still activated.

                       

                      So my current understanding is that it IS possible to have TWO instances of Windows 10 activated on the SAME computer - the native Boot Camp one and the one in the VM.

                       

                      But why, oh why, can I not activate Windows 10 in the Boot Camp VM? The reason can't be the different hardware - physical vs. virtual -, because the virtual Win 7 VM is activated too.

                       

                      To those who say: "Why don't you just use the Win 10 VM, not the Boot Camp VM?" My answer is: I don't want to maintain yet another system aside from OS X and the native Boot Camp Win 10 with OS and program updates, that's why.

                       

                      Any ideas?

                      • 23. Re: Windows 10 + Boot Camp VM = activation issue (error 0xc004c003)
                        jameslmoser Novice

                        It seems that the recent changes Microsoft made that allows Windows 10 to be directly activated using product keys from previous versions of Windows may have fixed this.  I didn't attempt to fix it, but as of today my Boot Camp partition automatically activated after I booted it up within Fusion.

                        • 24. Re: Windows 10 + Boot Camp VM = activation issue (error 0xc004c003)
                          raustinat Lurker

                          James, thanks for the info.

                           

                          Do I understand correctly that you had your Boot Camp partition activated natively but not within Fusion?

                           

                          When it activated today, do you recall what you did? Or did you just boot it up within Fusion?

                           

                          As of right now, my Boot Camp booted up through Fusion is still not activated.

                          • 25. Re: Windows 10 + Boot Camp VM = activation issue (error 0xc004c003)
                            morts331 Novice

                            Try uninstalling vmware tools when you are directly booted in to bootcamp.  Boot back in to os x and delete the bootcamp virtual machine.  Boot back in to bootcamp and see if you are still activated there.  Go back in to os x and set up a new boot camp virtual machine and install vmware tools.  You may have to reboot after installing vmware tools and once you do you should be activated in fusion.

                             

                            This is what I did and I've been activated in both bootcamp and fusion for a couple of weeks now.  I do find that when I first boot in to windows 10 it will say i'm not activated in system properties.  After a few minutes it becomes activated.

                            • 26. Re: Windows 10 + Boot Camp VM = activation issue (error 0xc004c003)
                              raustinat Lurker

                              I booted directly into Boot Camp to learn that now that one is not activated either. It is becoming ridiculous: I had a valid Win 7 installation there that I then upgraded to Win 10.

                               

                              Where it just said "Windows is activated", I now see the litany of product key info with my key being replaced with the generic -3V66T one. When I try to activate it, I get a message in red saying "Windows can't be activated, please try again later". However now I've the error code 0xC004F034, license not found or invalid.

                               

                              I will be trying your method regardless, even though my native Boot Camp section isn't even activated itself anymore.

                               

                              UPDATE: After deleting, recreating the Boot Camp VM and installing VMware Tools, my Boot Camp VM is now activated!!!!! However, I don't dare to reboot natively as that one wasn't activated earlier, see above. And for my purposes, using it in a VM is okay right now. Still a huge mess, everything.

                              • 27. Re: Windows 10 + Boot Camp VM = activation issue (error 0xc004c003)
                                KevinQuincey Lurker

                                +1 on the 0xc004c003 error:

                                I'm getting the exact same error, but for me it's the other way around. Windows 10 Boot Camp image under VM Ware activated fine. In fact it was already activated after I finished the upgrade installation.  But this is probably because I installed the update to windows 10 while in VMWare.  When I reboot back to Boot camp, almost everything works except (1) it's not activated and gives an error 0xc004c003 when I try, and (2) strangely the trackpad doesn't work.  I can plug in a USB mouse fine while I'm booted natively in BootCamp but if anyone knows how I might (re)load the Apple mouse or trackpad driver(s) to get it to work again, it'd be very much appreciative. I tried loading my BootCamp Apple drivers from the USB drive that was made when installing BootCamp but they are only for Windows 7 and won't let me.  My mac is a bit older (2010) and BootCamp doesn't officially support Windows 10 but it's working perfectly under VM Ware so I'm hoping Apple will supply a mouse driver for me and Microsoft will get this licensing for 2 instance on the same machine working figured out soon.

                                Thanks community!

                                • 28. Re: Windows 10 + Boot Camp VM = activation issue (error 0xc004c003)
                                  virbing Lurker

                                  so I think that I have found a solution, although I am still seeing a small problem that hopefully someone else can help with.

                                   

                                  This is how I was able to use the Windows 10 upgrade on both boot camp and the VM using boot camp. fwiw, I am starting with an upgrade version of Windows 7 Pro that I had already installed and activated on both boot camp and the VM boot camp (I used the reset "slmgr /rearm" method to allow the activation on both machines.)

                                   

                                  1. I upgraded my Win 7 Pro Boot Camp partition using the Windows 10 upgrade and activated it.

                                  2. I erased my current VMWare Fusion Boot Camp machine, then added the new Windows 10 boot camp as a new machine.

                                  3. I went to VMWare Tools and added a new virtual disk.

                                  4. I installed my copy of Windows 7 Pro to the new virtual disk and booted from it.

                                  5. I used the downloaded version of Windows 10 media creation tool and installed from that, making sure to not add a Product Key (see http://answers.microsoft.com/en-us/windows/forum/windows_10-windows_install/windows-10-upgrade-problem/d5cb3c55-9efb-4691-8669-8aaab9a7586d for more info)

                                  6. I went back and opened up the Windows activation and it activated as genuine (booted off of the new virtual disk.)

                                  7. I then deleted the virtual disk thereby booting the VMWare Fusion machine off of the boot camp partition.

                                  8. Voila! The boot camp partition was activated in the Fusion machine.

                                  9. I rebooted my MacBook from boot camp and confirmed that the activation was still good there.

                                   

                                  Now I have a couple of issues,

                                  1. It appears as though my Office 2016 install still sees the 2 installations as separate installations. I have an Office subscription with 2 installs so that isn't too much of an issue, especially since I also have a standalone Office 2016 install for my Mac (thanks to the Microsoft Home Use Program.)

                                  2. When I boot up in boot camp, I am presented with a boot error screen. It appears as though the Windows 10 boot still sees both the real install and the install I made to the virtual disk. It was defaulted to the virtual disk so I was having to go back to the boot screen and choose the other Windows install (on Partition 4) to boot into my real partition. I finally figured out how to get to the screen to default to the boot camp partition, but I still see the boot option screen when I first start up the MacBook in boot camp and then it goes away and boot from the proper partition.

                                   

                                  At this point, I am trying to figure out how to eliminate the extra Windows boot partition so it will go directly into the boot camp partition but after trying to figure out how the EFI and Mac Boot Camp deals with partitions, I still can't figure it out. At least it is just an annoyance rather than something that prevents the boot.

                                  • 29. Re: Windows 10 + Boot Camp VM = activation issue (error 0xc004c003)
                                    lsh08 Novice

                                    I think I'm now fully activated in both VMware with my bootcamp partition and when booting into Bootcamp.

                                     

                                    I did an upgrade from my Win8 System Builder license.    I installed as a bootcamp partition and successfully activated.     But I couldn't get the VMWare instance created from the Bootcamp partition to activate.     Still, I never had any problems even though it said it wasn't activated.     95% of the time I run win10 under VMWare.

                                     

                                    So after upgrading Windows 10 to the latest version, I saw something mentioned about activation now working from the Win8 key.

                                    So I launched win10 under VMware and went to settings, Activation, and activated with my Win8 key.       I tried it and it says I'm activated.   

                                    I've booted into Bootcamp and still activated.

                                     

                                    Good luck!

                                    1 2 Previous Next