1 Reply Latest reply on Apr 7, 2016 6:29 AM by dhh111erw

    VIN resets the windows powershell execution policy

    jo.strasser Hot Shot



      we heve installed the VIN in our environment.


      Since that we got troubles if we try to start powershell scripts remotely... as example on a network share.


      We have troubleshoot the issue and have found the cause problem:


      Every time if VIN starts a discovery (so per default every hour) it resets the Windows powershell execution policy!


      We have the need to set the execution policy on "bypass" but the VIN process kills that and set the policy back to "unrestricted"...


      Any ideas?


      Is it possible to configure the value?


      Thanks JO!

        • 1. Re: VIN resets the windows powershell execution policy
          dhh111erw Lurker

          hi - not sure if you are still having issue - had same issue - VMware explained it is the agent task script for hyperic agent. so this will only work if you do NOT use the "deploy hyperic agents" feature:


          from tech support:

          Powershell scripts are being used only by the "deploy hyperic agents" feature in VIN.

          Assuming the VIN is used in order to map the dependencies in the environment
          and not for deploying hyperic agents, we can disable the proactive tasks for
          agents get status on the vms in the environment. It means that the discovery
          will still run and if the you would like to get the agents status you will have
          to trigger it manually from the UI.

          The procedure:

          1. Open shell on vin appliance as root

          2. Connect to VIN DB by running this command

          psql -U vadm -d inception

          3. In the psql prompt you will need to execute the following

          psql.bin (9.0.17)

          Type "help" for help.

          inception=> update bundle_action set is_periodic = 'f' where name =

          UPDATE 1

          4. If everything worked ok, the output will be "UPDATE 1".

          You can always revert back by running the same command with is_periodic='t'.