1 2 Previous Next 26 Replies Latest reply on Apr 2, 2017 11:38 PM by Vindia

    VMware Remote MKS has stopped working

    fholred Lurker

      We are running vcentre v6 and everytime we power on a VM we get the message

       

      'VMware Remote MKS has stopped working' and the console stops working

       

      We then have to log out and log back to get the console to work

       

      Any ideas?

        • 1. Re: VMware Remote MKS has stopped working
          snekkalapudi Expert
          VMware Employees

          Recently, I have resolved mks issues in my lab with help of this KB article - http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=749640 Check if it helps you.

          • 2. Re: VMware Remote MKS has stopped working
            GaneshNetworks Expert

            Make sure, DNS IPs are set in your desktop and it is good to resolve the IP addresses of ESXi / vCenter servers.

            • 3. Re: VMware Remote MKS has stopped working
              RicGibson Lurker

              I experienced the same issue with Vsphere client V6 when opening ESXi consoles.

               

              I am using McAfee SecurityCenter. Opening TCP/UDT Port 902 seems to have resolved the issue.

               

              Per KB article VMware KB:    Network Port Requirements for VMware NSX for vSphere: Port 902 must not be blocked between the vSphere Client and the hosts. The vSphere Client uses this port to display virtual machine consoles.

               

               

              Regards,

              Ric

              • 4. Re: VMware Remote MKS has stopped working
                coolsport00 Enthusiast
                vExpert

                I'm having same issue. If I reboot a VM or power it on, I get this Windows message (on Windows 7) stating VMware Remote MKS has stopped working. We block no ports in our internal network so that's not the issue. I flushed my DNS cached and can ping everything by hostname so that's not the issue either. I just noticed this since we upgraded to vSphere 6. Never experienced this behavior on previous versions of vSphere. Looking for any potential resolutions as well.


                Thanks.


                @coolsport00
                (Shane)

                • 5. Re: VMware Remote MKS has stopped working
                  praveenkv Enthusiast

                  I experience the same issue and followed below steps to fix the issue:

                   

                      1. Log in to vCenter Server directly through Terminal Services or a Remote KVM and attempt a connection using the vSphere Client from this system. If this method works, a firewall may be preventing the console from connecting.

                   

                      2. Configure your firewall to allow communications between the ESXi/ESX host and the workstation running the vSphere Client.

                   

                      Note: If port 903 is not open or cannot be opened in your environment, enable the vmauthd proxy. This forces remote console communication to be sent on port 902 on the Service Console, instead of 903. By enabling this setting there may be degradation in the performance under heavy usage while communicating to the ESXi/ESX host service console.

                   

                       Note: In ESXi 4.x, 5.x and 6.0, vmauthd.server.alwaysProxy is, by default, set to true.

                   

                      To enable the proxy:

                   

                          a. Log into the ESX host's service console as root.

                          b. Open /etc/vmware/config using a text editor.

                          c. Add this line to the file:

                   

                          vmauthd.server.alwaysProxy = "TRUE"

                   

                          d. In ESX, run this command to restart xinetd:

                   

                          service xinetd restart

                   

                      3. Verify the ESXi/ESX firewall policy:

                   

                          For ESXi 5.x and 6.0, see About the ESXi 5.x and 6.0 firewall (2005284).

                          For ESX 3.x to 4.x, see Troubleshooting the firewall policy on an ESX host (1003634).

                   

                      4. Verify that the ESXi/ESX host and the workstation running the vSphere Client are correctly synced to an NTP service. This is required to satisfy SSL handshaking between the vSphere Client or and the ESXi/ESX host. For more information, see Verifying time synchronization across an ESXi/ESX host environment (1003736).

                   

                      5. DNS problems are a common cause of virtual machine console problems. Verify name resolution in your environment. For more information, see:

                   

                          - Identifying issues with and setting up name resolution on ESXi/ESX Server (1003735)

                          - Configuring name resolution for VMware vCenter Server (1003713)

                   

                      After verifying DNS, open a command prompt on the vSphere Client machine and run these commands:

                   

                      ipconfig /flushdns

                      ipconfig /registerdns

                  • 6. Re: VMware Remote MKS has stopped working
                    coolsport00 Enthusiast
                    vExpert

                    Again, this is NOT a firewall issue. vCenter is running in an appliance and my workstation has Windows FW disabled. And again, as I mentioned above, my DNS is fine. And, this happens on my workstation (Win7) here at the office, and on my Win 7 laptop when I VPN in from home. So, it's not isolated to just my work workstation. There's something "buggy" going on that I can't seem to find the resolution for.


                    Thanks.

                    • 7. Re: VMware Remote MKS has stopped working
                      jagdish_rana Enthusiast

                      Hello,

                       

                      Could you please check the below steps and provide a feedback.

                       

                      1. Open a session to the vSphere Web Client.

                        https:// vcenter_server_name:9443/vsphere-client

                      2. Power off the virtual machine. 
                      3. In the vSphere Web Client, right-click the affected virtual machine. 
                      4. Click Configuration > Edit Settings.    
                      5. Click VM options
                      6. Click VMware Remote Console Options, then deselect Limit the number of simultaneous connections to this Virtual Machine
                      7. Click OK
                      8. Power on the virtual machine. 
                      9. Open a new console window to the virtual machine in the vSphere Client to verify.

                      10. To work around this issue, add an entry to the configuration parameters of the virtual machine.

                      To add an entry to the configuration parameters of the virtual machine:

                      1. Power off the virtual machine. 
                      2. Right-click the affected virtual machine and click Edit Settings.   
                      3. Click the Options tab, then click General under Advanced
                      4. Click Configuration Parameters. 
                      5. Look for an entry named RemoteDisplay.maxConnections:

                        • if the entry exists, set the Value to 1 or high
                        • If the entry does not exist, click Add Row to add the parameter. The parameter details are:

                          Name: RemoteDisplay.maxConnectionsValue: 10
                          Note: Value can be set to 1 or more.
                        • Thanks
                      • 8. Re: VMware Remote MKS has stopped working
                        ShirinKumar Enthusiast

                        Hi,

                         

                        Can you please tell the OS running on VM,

                         

                        It may be the issue at the Guest Level Firewall issue, Can you please check at the windows Firewall setting in OS , whether it is allow or deny for Vcenter Service Firewall.

                        • 9. Re: VMware Remote MKS has stopped working
                          coolsport00 Enthusiast
                          vExpert

                          Thank you for the couple replies. Again, this is NOT a firewall issue within the guest, nor is this a "number of connections" issue with the VM. That much I do know. And again...please read my response above - all was fine with having a VM console open during reboot or power on until I upgraded to vSphere6. Once upgraded, I then began having this "MKS Stopped Working" error in Windows. Checking DNS was at least a possibility (though nothing changed there either), but that isn't the issue as I am still having this Windows error after attempting that VMware KB "fix" and it didn't resolve my issue.

                           

                          Any other thoughts/ideas?

                           

                          Thank you.

                           

                          @coolsport00

                           

                          p.s. Sorry for the late reply, but I was at VMworld last week, which...I must say... was a big let down. :/

                          • 10. Re: VMware Remote MKS has stopped working
                            Juspi Lurker

                            Hello,

                             

                            we have here in our environment the same problem. When we start a virtual machine and open the console at the vsphere client, the window is freezing and display the error "VMware Remote MKS has stopped working". When i close the window and start the console again, all is working fine. Only when we restart or start the machine.

                            The Problem we have only in our vCenter 6.0. In the vCenter 5.1 we have no problems with the console.

                             

                            Is this a bug in the current version or give it any solution for the problem?

                             

                            Actual we have a little workaround. The Problem, that is reported, is on the programm "C:\Program Files (x86)\Common Files\VMware\VMware Remote Console Plug-in 5.1\Internet Explorer\vmware-remotemks.exe".

                            Now i have renamed the folder "VMware Remote Console Plug-in 5.1" and gives the folder "VMware Remote Console Plug-in 5.5" the name "VMware Remote Console Plug-in 5.1".

                            When we start the console now, we have no problem any more.

                            • 12. Re: VMware Remote MKS has stopped working
                              coolsport00 Enthusiast
                              vExpert

                              Hi Juspi -

                              I looked a little bit more at my error. My Windows error is an "APPCRASH" for vmware-remotemks.exe. I do go between 2 vSphere versions - 5.5U1 and 6b. Don't believe I have an issue with 5.5. I know I didn't have an issue before I upgraded our "main" environment to 6, then to 6b. I'm thinking there's probably some conflict somewhat like you shared... somehow this exe is a legacy version (5.5 or 5.1). Will dig into it a bit more to see what I can find.

                               

                               

                              mohdhanifk -

                              Not sure you read through the thread. We're not getting a VM Console MKS error. We're getting a Windows crash error. But, thanks for chiming in.

                               

                              I'll update if I find a resolution for my issue, and/or if anyone else has a fix, please post.

                               

                              Regards.


                              Shane (twitter: @coolsport00)

                              • 14. Re: VMware Remote MKS has stopped working
                                coolsport00 Enthusiast
                                vExpert

                                Ok, so I think I resolved this on my own. Wasn't able to pinpoint explicitly what was going on, but I think the issue was conflicting versions of both the VMware Remote Console and vSphere Client installed. Uninstalled everything, reinstalled Client v6 and now working fine.

                                 

                                "Ravi.." - again, that is not the issue we're having. I think that link was posted like 4-5 times in this thread. Goodness.... read the thread people! (gets old, ya know?)

                                 

                                Thanks everyone for the assistance!

                                 

                                Regards,

                                Shane (twitter: @coolsport00)

                                1 2 Previous Next