2 Replies Latest reply on Jul 9, 2015 1:31 AM by Kaylin

    Upgrading vRA from 5.5 to 6

    Kaylin Novice

      Hi Guys,

       

      Im busy upgrading my lab enviroment consisting of ESXi .5.5, vCenter 5.5, vCOPS 5.8, vRA 5.8.1 and SRM 5.8 in preparation for my production enviroment.

       

      I have upgraded both my vCenters to 6 and i am able to manage my 5.5 hosts but im aware vRA 5.8.1 and SRM 5.8 is not compatible with vCenter 6.

       

      So i have updated vRA using the ISO image and the VAMI UI. The update was successful on both sites but for some reason the service starts and stops and i am unable to see the the vRA in the vSphere web interface.

       

      When i go to the administration tab and then vCenter Server Extensions VR Management version is still showing 5.8.1 and status unknown.

       

      Do i need to unregister and re register from vCenter ?

       

      Regards

      Kaylin

        • 1. Re: Upgrading vRA from 5.5 to 6
          Busso Lurker

          Hi Kaylin,

          .

          I just went through more or less the same scenario as you.  But with a client's production environment.

          They were  running vsphere 5.5 u2, View 6.0.1, vRA 5.8 and SRM 5.5.     I performed all upgrade steps in the correct order, but I haven't been able to get vSphere replication and SRM running without losing the configuration.  Which in case of the vRA is n't that bad as it detects the old replica's as seeding points.  And SRM 6.0 is much easier and less labour intensive to configure than the old one 

          What do you need to do:  you need to reconfigure both the vRA appliances (https://<ip addr>:5480).   If you are using self signed certificate, as in my case, you're going to have a problem with the certificate of the appliance.   It was expired and I needed to create a new one for each appliance.

          I suppose that's where my problems started, as even after reconfiguring the appliances I couldn't get it to work.   I could create a connection from site A to site B, but from site B to A wouldn't work.

          I always got "connection error"

          In the end I decided to scratch the vRA's and redeploy them.    Which was great, as after I've configured them, I could make the connection between both sites in both directions, and all was well.  NOT:

          There are another few issues with vSphere Replication 6.

               - Sometimes the web client won't show the destination datastores, and you'll have to restart the webclient on the source site.

               - When I got it to show the datastores, every new job ended with "permission denied", so if you want to add a new replication job, you need to log with the default SSO administrator of your environment, or it won't work.    Believe me, I've tried.

          Additionally, I hope you've read the release notes, as they tell you that the default vSphere Replication roles lose all their rights after an upgrade.  I can't confirm this, as I ended up, removing everything and deploying new vRA's.

          I suggest you read the release notes, as every obstacle I ran into was described in the release notes. (only the thing that only the SSO administrator can create replication jobs might have been explained clearer..

          I can't understand how the guys at VMware managed to make such a mess. vSphere Replication was such a wonderfull product: reliable, quick and easy to setup, and with version 6, the upgrade (or installation)  such an incredible mess.    Though once configured and up&running, it seems to work well. 

           

          Best of luck.

          Kind regards

           

          (p.s. if the service keeps starting and stopping, after you've reconfigured the vRA, you need to configure NTP in the appliance (as explained in the release notes)

          • 2. Re: Upgrading vRA from 5.5 to 6
            Kaylin Novice

            Hi Busso,

             

            Thanks for the update. I actually deleted the appliances and redeployed vRA 6.0 and both appliances registered correctly with vCenter and appeared in the web client and i reseeded.

             

            I haven't created any new jobs yet but ill  keep that in mind when creating new jobs.

             

            Totally agree with you on VMware messing up vSphere Replication with the new release.

             

            Regards

            Kaylin