3 Replies Latest reply on Jun 21, 2015 2:39 AM by VMTOCloud

    What is vLan ?

    vivasindustries Novice

      Hi there i want to ask maybe a stupid question.

       

      What exactly is vLan ?

       

      Does it mean when i set an vLan id of network for the ESXi host the host will use that network as a main to connect to the internet ?

      I am asking this because i can connect to the internet only with PPPOE connection but the ESXi host can not and i have to set up a virtual router which i think will connect to the internet with PPPOE connection and then the ESXi host will use this connection via vLan option.

       

      Am i right ?

       

      Thanks in advance, and sorry for the stupid question ?

        • 1. Re: What is vLan ?
          npadmani Master
          VMware EmployeesvExpert

          What exactly is vLan ?

           

          It's definitely not a stupid question my friend, Take a look at following video, might be helpful

          MicroNugget: What is a VLAN? - YouTube

           

          Does it mean when i set an vLan id of network for the ESXi host the host will use that network as a main to connect to the internet ?

          I am asking this because i can connect to the internet only with PPPOE connection but the ESXi host can not and i have to set up a virtual router which i think will connect to the internet with PPPOE connection and then the ESXi host will use this connection via vLan option.

           

          Am i right ?

          In order to get an answer to above thing, I would recommend, Please try to understand what VLAN is, and see it for yourself if you really need it or not.

          someone has posted video on youtube explaining how to use pfSense as router, see if that helps.

          How to setup PfSense WAN and LAN on ESXI 5.5 - YouTube

          • 2. Re: What is vLan ?
            malleswar77 Enthusiast

            Hi, Please go through the below for better understanding of VLAN.

             

            VLAN :

             

             

            A virtual  local area network (virtual LAN) is the logical grouping of network nodes.  A virtual LAN allows geographically dispersed network nodes to communicate as if they were physically on the same network.

             

             

            VLANs allow network administrators to partition their networks physically and logically without having to run new cables or make major changes in their current network infrastructure.

             

             

            A switch that supports VLANs allows the administrator to select which ports will participate in the VLAN. These ports are then grouped to become one VLAN, and any broadcasts or information passed among these ports will not be seen by the remaining ports on the switch.

             

            >>> How to create or configure VLAN>>>>>> Please see the below:

             

            To configure Virtual Switch (vSwitch) VLAN Tagging (VST) on an ESXi/ESX host:

            1. Assign a VLAN to a portgroup(s). The supported VLAN range is 1-4094.
              Reserved VLAN IDs:
              • VLAN ID 0 (zero) Disables VLAN tagging on port group (EST Mode)
              • VLAN ID 4095 Enables trunking on port group (VGT Mode)

            2. Set the switch NIC teaming policy to Route based on originating virtual port ID (this is set by default).

             

            To configure the physical switch settings:

            1. Define ESXi/ESX VLANs on the physical switch.
            2. Allow the proper range to the ESXi/ESX host.
            3. Set the physical port connection between the ESXi/ESX host and the physical switch to TRUNK mode. ESXi/ESX only supports IEEE 802.1Q (dot1q) trunking.

              • Physical switch is set to TRUNK mode
              • dot1q encapsulation is enabled
              • Spanning-tree is set to portfast trunk (for example, port forwarding, skips other modes)
              • Define VLAN interface
              • Assign IP Range to VLAN interface
              • VLAN Routing – and VLAN Isolation

                Caution: Native VLAN ID on ESXi/ESX VST Mode is not supported. Do not assign a VLAN to a port group that is same as the native VLAN ID of the physical switch. Native VLAN packets are not tagged with the VLAN ID on the outgoing traffic toward the ESXi/ESX host. Therefore, if the ESXi/ESX host is set to VST mode, it drops the packets that are lacking a VLAN tag.

             

            This sample is a supported Cisco Trunk Port configuration:

            interface GigabitEthernet1/2
            switchport                             (Set to layer 2 switching)
            switchport trunk encapsulation dot1q   (ESXi/ESX only supports dot1q, not ISL)
            switchport trunk allowed vlan 10-100   (Allowed VLAN to ESXi/ESX. Ensure ESXi/ESX VLANs are allowed)
            switchport mode trunk                  (Set to Trunk Mode)
            switchport nonegotiate                 (DTP is not supported)
            no ip address
            no cdp enable                          (ESXi/ESX 3.5 or higher supports CDP)
            spanning-tree portfast trunk           (Allows the port to start forwarding packets immediately on linkup)

             

            Note: For more information on configuring your physical network switch, contact your switch vendor.

             

            To assign a VLAN to a port group, there must be a corresponding VLAN interface for each VLAN on a physical switch with a designated IP range.

            For example:

             

            interface Vlan200
            ip address 10.10.100.1 255.255.255.0  (This IP can be used as VLAN 200 Gateway IP)

             

            Note: When the VLAN ID is defined on the physical switch, it can be configured for ESX. If the IP range is assigned to a VLAN, decide if any routing may be required to reach other nodes on the network.

             

            To configure a VLAN on the portgroup using the VMware Infrastructure/vSphere Client:

            1. Click the ESXi/ESX host.
            2. Click the Configuration tab.
            3. Click the Networking link.
            4. Click Properties.
            5. Click the virtual switch / portgroups in the Ports tab and click Edit.
            6. Click the General tab.
            7. Assign a VLAN number in VLAN ID (optional).
            8. Click the NIC Teaming tab.
            9. From the Load Balancing dropdown, choose Route based on originating virtual port ID.
            10. Verify that there is at least one network adapter listed under Active Adapters.
            11. Verify the VST configuration using the ping command to confirm the connection between the ESXi/ESX host and the gateway interfaces and another host on the same VLAN.


            esxcfg-vswitch -p "portgroup_name" -v VLAN_ID virtual_switch_name
            • 3. Re: What is vLan ?
              VMTOCloud Expert

              Divide  the Local Area virtually which will help you to segment the network.

              You are traffic is blocked by firewall there is nothing to do with vLAN.