3 Replies Latest reply on May 13, 2015 10:50 PM by egonzales

    HQ agent with multiple network interfaces uses physical hostname not virtual hostname

    Sascha0815 Lurker

      Hi all,

       

      maybe someone could provide me with a hint on how to solve this setup problem:

       

      I have the following setup:

      - physical server with three virtual network adresses

      Hostnamephysical / virtual NetworkIP
      myhostphys. (bond0)192.168.1.1
      vhost1virt. (bond0:vhost1)192.168.1.10
      vhost2virt. (bond0:vhost2)192.168.1.11
      vhost3virt. (bond0:vhost3)

      192.168.1.12

       

      - One instance of HQ server and HQ agent are running on this server (OS is SuSE Linux 11).

       

      My problem now is that when the agent tries to discover services, it uses the physical hostname (myhost) to resolve its IP address (192.168.1.1).

      But I have the special requirement that it should use vhost3 hostname and (even more important) the corresponding IP address 192.168.1.12.

      I've tried agent.listenIP=192.168.1.12 and agent.setup.agentIP=192.168.1.12, but this has had no influence.

       

      Output of hostname command:

      $> hostname -a

      myhost

      $> hostname -f

      myhost.mydomain.com

      $> hostname -i

      192.168.1.1

       

      Changing /etc/hosts/ so that a local "ping myhost" would resolve to "192.168.1.12" is not an option.

       

      Is there any hidden configuration option where I can tell the HQ server and agent that they are running on vhost3 and not trying to resolve the phys. hostname?

       

      Kind regards,

      Sascha