3 Replies Latest reply on Apr 6, 2017 6:22 AM by leonardo1000

    Error VMware Tools Installation (Shared Folder) - Ubuntu 15.04 [SOLVED!]

    pedromlessa Novice


      Workstation 11.1

      Ubuntu 15.04 Guest OS

      Kernel 3.19.0-15-generic

      VMwareTools-9.9.2-2496486


      When I try to install vmwaretools in my Ubuntu 15.04, I receive the following compilation errors (shared folder feature don't work):

       

      Initializing...

      Making sure services for VMware Tools are stopped.

      Stopping VMware Tools services in the virtual machine:

         Guest operating system daemon:                              done

         VMware User Agent (vmware-user):                          done

         Blocking file system:                                               done

         Unmounting HGFS shares:                                      done

         Guest filesystem driver:                                           done

      Stopping Thinprint services in the virtual machine:

         Stopping Virtual Printing daemon:                              done

       

       

      Before you can compile modules, you need to have the following installed...

       

      make

      gcc

      kernel headers of the running kernel

       

      Searching for GCC...

      Detected GCC binary at "/usr/bin/gcc".

      The path "/usr/bin/gcc" appears to be a valid path to the gcc binary.

      Would you like to change it? [no]

       

      Searching for a valid kernel header path...

      Detected the kernel headers at "/lib/modules/3.19.0-15-generic/build/include".

      The path "/lib/modules/3.19.0-15-generic/build/include" appears to be a valid

      path to the 3.19.0-15-generic kernel headers.

      Would you like to change it? [no]

       

      make: Entering directory '/tmp/modconfig-O5xscq/vmhgfs-only'

      Using kernel build system.

      /usr/bin/make -C /lib/modules/3.19.0-15-generic/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. \

        MODULEBUILDDIR= modules

      make[1]: Entering directory '/usr/src/linux-headers-3.19.0-15-generic'

        CC [M]  /tmp/modconfig-O5xscq/vmhgfs-only/backdoorGcc64.o

        CC [M]  /tmp/modconfig-O5xscq/vmhgfs-only/message.o

        CC [M]  /tmp/modconfig-O5xscq/vmhgfs-only/dir.o

        CC [M]  /tmp/modconfig-O5xscq/vmhgfs-only/rpcout.o

        CC [M]  /tmp/modconfig-O5xscq/vmhgfs-only/filesystem.o

        CC [M]  /tmp/modconfig-O5xscq/vmhgfs-only/cpName.o

        CC [M]  /tmp/modconfig-O5xscq/vmhgfs-only/request.o

        CC [M]  /tmp/modconfig-O5xscq/vmhgfs-only/module.o

      /tmp/modconfig-O5xscq/vmhgfs-only/dir.c: In function ‘HgfsPackDirOpenRequest’:

      /tmp/modconfig-O5xscq/vmhgfs-only/dir.c:417:26: error: ‘struct file’ has no member named ‘f_dentry’

                            file->f_dentry) < 0) {

                                ^

      /tmp/modconfig-O5xscq/vmhgfs-only/dir.c: In function ‘HgfsDirLlseek’:

      /tmp/modconfig-O5xscq/vmhgfs-only/dir.c:707:32: error: ‘struct file’ has no member named ‘f_dentry’

          struct dentry *dentry = file->f_dentry;

                                      ^

      In file included from /tmp/modconfig-O5xscq/vmhgfs-only/dir.c:39:0:

      /tmp/modconfig-O5xscq/vmhgfs-only/dir.c: In function ‘HgfsReaddirNextEntry’:

      /tmp/modconfig-O5xscq/vmhgfs-only/dir.c:993:31: error: ‘struct file’ has no member named ‘f_dentry’

          si = HGFS_SB_TO_COMMON(file->f_dentry->d_inode->i_sb);

                                     ^

      /tmp/modconfig-O5xscq/vmhgfs-only/module.h:89:62: note: in definition of macro ‘HGFS_SB_TO_COMMON’

      #define HGFS_SB_TO_COMMON(sb)             ((HgfsSuperInfo *)(sb)->s_fs_info)

                                                                    ^

      /tmp/modconfig-O5xscq/vmhgfs-only/dir.c:1082:26: error: ‘struct file’ has no member named ‘f_dentry’

                *entryIno = file->f_dentry->d_inode->i_ino;

                                ^

      In file included from /tmp/modconfig-O5xscq/vmhgfs-only/dir.c:30:0:

      /tmp/modconfig-O5xscq/vmhgfs-only/dir.c:1088:44: error: ‘struct file’ has no member named ‘f_dentry’

                *entryIno = compat_parent_ino(file->f_dentry);

                                                  ^

      /tmp/modconfig-O5xscq/vmhgfs-only/./shared/compat_fs.h:120:46: note: in definition of macro ‘compat_parent_ino’

      #define compat_parent_ino(dentry) parent_ino(dentry)

                                                    ^

      /tmp/modconfig-O5xscq/vmhgfs-only/dir.c:1093:52: error: ‘struct file’ has no member named ‘f_dentry’

            *entryIno = HgfsGetFileInode(&entryAttrs, file->f_dentry->d_inode->i_sb);

                                                          ^

      /tmp/modconfig-O5xscq/vmhgfs-only/dir.c: In function ‘HgfsDoReaddir’:

      /tmp/modconfig-O5xscq/vmhgfs-only/dir.c:1173:13: error: ‘struct file’ has no member named ‘f_dentry’

             !(file->f_dentry) ||

                   ^

      /tmp/modconfig-O5xscq/vmhgfs-only/dir.c:1174:13: error: ‘struct file’ has no member named ‘f_dentry’

             !(file->f_dentry->d_inode)) {

                   ^

      scripts/Makefile.build:257: recipe for target '/tmp/modconfig-O5xscq/vmhgfs-only/dir.o' failed

      make[2]: *** [/tmp/modconfig-O5xscq/vmhgfs-only/dir.o] Error 1

      make[2]: ** Esperando que outros processos terminem.

      Makefile:1394: recipe for target '_module_/tmp/modconfig-O5xscq/vmhgfs-only' failed

      make[1]: *** [_module_/tmp/modconfig-O5xscq/vmhgfs-only] Error 2

      make[1]: Leaving directory '/usr/src/linux-headers-3.19.0-15-generic'

      Makefile:120: recipe for target 'vmhgfs.ko' failed

      make: *** [vmhgfs.ko] Error 2

      make: Leaving directory '/tmp/modconfig-O5xscq/vmhgfs-only'

       

      The filesystem driver (vmhgfs module) is used only for the shared folder

      feature. The rest of the software provided by VMware Tools is designed to work

      independently of this feature.

       

      If you wish to have the shared folders feature, you can install the driver by

      running vmware-config-tools.pl again after making sure that gcc, binutils, make

      and the kernel sources for your running kernel are installed on your machine.

      These packages are available on your distribution's installation CD.

      [ Press Enter key to continue ]

       

      The vmxnet driver is no longer supported on kernels 3.3 and greater. Please

      upgrade to a newer virtual NIC. (e.g., vmxnet3 or e1000e)

       

       

       

       

       


      I tried to use these instructions to solve the problem:

      http://rglinuxtech.com/?p=1281

      compiling - VMWare player and Ubuntu 15.04: net driver does not compile anymore, how to fix? - Ask Ubuntu


      However, I don't have the /usr/lib/vmware/modules/source with vmnet.tar file.
      I just have /usr/lib/vmware-tools/modules/source with the following files:
      legacy    vmblock.tar    vmhgfs.tar    vmsync.tar    vmxnet.tar    pvscsi.tar    vmci.tar    vmmemctl.tar    vmxnet3.tar    vsock.tar


      How I resolve this problem?

      Thank You!

        • 1. Re: Error VMware Tools Installation (Shared Folder) - Ubuntu 15.04
          kijitora Novice

          Hi, pedromlessa,

           

          I found this information, and it worked for my case (the steps are a little complicated, though).

           

          rasa/vmware-tools-patches · GitHub

           

          I hope it will help for you, too.

           

          kijitora.

          • 2. Re: Error VMware Tools Installation (Shared Folder) - Ubuntu 15.04
            pedromlessa Novice

            Now It's working for me! :-) Thanks kikitora for the correct answer and Rahul Jha for this tutorial:

             

            Please ensure that latest Workstation 11 is installed.

            Make sure open-vm-tools is not installed.

            sudo apt-get remove open-vm-tools

             

             

            1. Make sure the updates are done:

            sudo apt-get update


            2. Make sure git is installed

            sudo apt-get install git

             

            3. Run the command to get the tools from repository.

            sudo git clone https://github.com/rasa/vmware-tools-patches.git

             

            4. cd to vmware-tools-folder

            cd vmware-tools-patches

             

            5. Run the patch

            sudo ./download-tools.sh

             

            6. Run the following patch

            sudo ./untar-and-patch.sh

             

            7. Run the complie.sh file

            sudo ./compile.sh

            2 people found this helpful
            • 3. Re: Error VMware Tools Installation (Shared Folder) - Ubuntu 15.04
              leonardo1000 Lurker

              This was the main key to solving this problem for me with an Ubuntu 16.04 VMware Player (v. 6.07) VM on Win10 host.  I did find references to a Player version 7.0.  But I thought they said it was a beta and I couldn't find it on the VMware site, so I didn't want to mess with it.

               

              One previous step was needed before doing this though (see 14.04 - Cannot Install VMware Tools in 15.10 VM, due to Easy Install being in progress - Ask Ubuntu  ) before I could get Player to break out of VMware auto-install mode and install the VMware tools "CDROM" to the Ubuntu VM.  Note: after following this link's advice the tools install did give me a warning that the guest VM had "locked" the guest CDROM, but let me override the lock and it  worked OK afterwards.  I did later find a link that another choice to remove autoinst shares might might have been to delete them from the guest VM settings via the Player GUI.

               

              After breaking out of auto-install mode my Ubuntu VM sorted of worked, but I could not get the Player host share feature to work.  It was only after running this procedure that I got the VMware host share feature working properly.    BTW - don't follow this mis-guided soul's advice to add stuff to the fstab ( mount - Enabling shared folders with open-vm-tools - Ask Ubuntu   ).   It may have worked on his host hardware, but I suspect it's unlikely to work on many (most?) others.  My Ubuntu VM wouldn't boot for me afterwards, although on the plus side I learned somethings about Ubuntu safe mode to be able to fix the corrupted fstab.

               

              Only other comment on this procedure is that either step 5 or 6 (don't recall exactly which one) took a very long time to run.  I let it run overnight so I don't know how long it took in the end.  Thanks for great advice from this this link!