1 2 3 Previous Next 33 Replies Latest reply on Jan 27, 2016 4:53 AM by ValentimBR

    gcc 5.1: Failed to get gcc information.

    rakotomandimby Novice

      Running vmware workstation 11 and Archlinux with gcc 5.1:

      [root@dell-i7-mihamina mrakotomandimby]# vmware-modconfig --console --install-all
      Failed to get gcc information.
      [root@dell-i7-mihamina mrakotomandimby]#
      

      But gcc is:

      [mrakotomandimby@dell-i7-mihamina ~]$ gcc --version
      gcc (GCC) 5.1.0
      Copyright (C) 2015 Free Software Foundation, Inc.
      This is free software; see the source for copying conditions.  There is NO
      warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE
      

      .

      What to do?

        • 1. Re: gcc 5.1: Failed to get gcc information.
          everlook Lurker

          I have the same issue with gcc 4.9.2 on arch with VMware 11.0

          • 2. Re: gcc 5.1: Failed to get gcc information.
            willir29 Lurker

            I have the same issue too, with gcc 4.9.2 on arch with VMware Player 7.1

            • 3. Re: gcc 5.1: Failed to get gcc information.
              dariusd Virtuoso
              User ModeratorsVMware Employees

              Hi everyone,

               

              Thanks for letting us know about this problem.  Arch is not an officially supported host OS, but we want it to work for you regardless, so let's try to figure out what's going on...

               

              Can someone please try running (as root) "vmware-modconfig --build-mod vmmon"... that should generate a logfile in /tmp/vmware-root/vmware-<pid>.log... if someone could provide the vmware-<pid>.log corresponding to the vmware-modconfig execution, that'd be great!  (Just compose a reply to this post, and look above the Post Message button for the file attachment facility... please don't copy-and-paste the log contents into the reply.)

               

              (Sorry for being lazy and asking for your help with this instead of reproducing the problem here... I'm away from my main machines and my net connection is rather too slow right now for me to tackle this directly myself...  Thanks for your understanding!)

               

              Cheers,

              --

              Darius

              • 4. Re: gcc 5.1: Failed to get gcc information.
                willir29 Lurker

                Ok. I think I have figured out my problem. It is described here. https://bbs.archlinux.org/viewtopic.php?id=196778

                To summarize it: New arch linux kernel (4.0.1) has been compiled using gcc-5.1, but my gcc is 4.9. And at the time of writing this gcc-5.1 there is only in testing repo.

                2015-05-13T09:19:39.597+03:00| modconfig| I120: Found compiler at "/sbin/gcc"
                2015-05-13T09:19:39.600+03:00| modconfig| I120: Got gcc version "4.9.2".
                2015-05-13T09:19:39.600+03:00| modconfig| I120: GCC major version 4 does not match Kernel GCC major version 5.
                2015-05-13T09:19:39.600+03:00| modconfig| I120: The GCC compiler "/sbin/gcc" cannot be used for the target kernel.
                

                Life is pain .

                • 5. Re: gcc 5.1: Failed to get gcc information.
                  user2727 Lurker

                  Actually, the problem is much more sinister...

                   

                  I have a better Arch linux debug and resolve thread for this problem:

                   

                  https://bbs.archlinux.org/viewtopic.php?id=196915

                   

                  In short, recompiling the kernel using the gcc 4.9 version works.

                   

                  Problem now, because arch is a rolling release, is gcc 5.1.0 is now in core - and the vmhgfs, while compiling, hard locks the VM.  I'm creating another vmware community thread for this one.  Will come back and edit this post with link.

                   

                  EDIT: Here's the thread to track gcc 5.1.0 progress with VMware Tools:

                   

                  Workstation 11.1, Tools 9.9.2 build-2496486: Not compatible with GCC 5.1.0 on linux (Arch, Debian, Ubuntu, etc)

                  • 6. Re: gcc 5.1: Failed to get gcc information.
                    gruna Novice

                    Problem still exist and seems to be not related to a specific distribution.

                    I also needed to update my opensuse to the 4.x kernel and therefore also updated gcc to 5.1.1.

                    I can compile everything, beside vmware workstation where i get above mentioned error.

                     

                    Any advise is appreciated.

                     

                    Br,

                    Gruna

                    • 7. Re: gcc 5.1: Failed to get gcc information.
                      mfelker Expert

                      I have the same problem using openSUSE Tumbleweed.  The entire distro was recompiled with 5.1-23.  Applied the standard vmnet patch but when I compiled using

                      vmware-modconfig --console --install-all

                       

                      I get the same error

                       

                      Failed to get gcc information

                       

                      This needs a fix from VMware for sure.  I am trying to use VMTurbo software and can't because of this fatal installation error.  I have 500GB of VMs I need to access.

                       

                      Please make this a priority fix VMware.  All distros will soon be using the 5.1 compiler.  You may have already run into this in-house

                      • 8. Re: gcc 5.1: Failed to get gcc information.
                        andreas_1 Novice

                        Hi Darius, hi everyone,

                         

                        I have attached the output of "vmware-modconfig --build-mod vmmon" as requested. The log ends as follows:

                         

                        2015-07-03T15:40:40.736+02:00| appLoader| I120: Loading shipped version of libvmwareui.so.0.
                        2015-07-03T15:40:40.859+02:00| appLoader| W110: Unable to load libvmwareui.so.0 from /usr/lib/vmware/lib/libvmwareui.so.0/libvmwareui.so.0: /usr/lib/vmware/lib/libvmwareui.so.0/libvmwareui.so.0: undefined symbol: _ZN4Glib10spawn_syncERKSsRKNS_11ArrayHandleISsNS_17Container_Helpers10TypeTraitsISsEEEENS_10SpawnFlagsERKN4sigc4slotIvNSA_3nilESC_SC_SC_SC_SC_SC_EEPSsSG_Pi
                        2015-07-03T15:40:40.859+02:00| appLoader| W110: Unable to load dependencies for /usr/lib/vmware/lib/libvmware-modconfig.so/libvmware-modconfig.so
                        2015-07-03T15:40:40.859+02:00| appLoader| W110: Unable to execute /usr/lib/vmware/bin/vmware-modconfig.

                         

                        Furthermore:

                         

                        # readelf -Ws libvmwareui.so.0 | grep _ZN4Glib10spawn_syncERKSsRKNS_11ArrayHandleISsNS_17Container_Helpers10TypeTraitsISsEEEENS_10SpawnFlagsERKN4sigc4slotIvNSA_3nilESC_SC_SC_SC_SC_SC_EEPSsSG_Pi
                           471: 0000000000000000     0 FUNC    GLOBAL DEFAULT  UND _ZN4Glib10spawn_syncERKSsRKNS_11ArrayHandleISsNS_17Container_Helpers10TypeTraitsISsEEEENS_10SpawnFlagsERKN4sigc4slotIvNSA_3nilESC_SC_SC_SC_SC_SC_EEPSsSG_Pi

                         

                        Not sure if it helps, but I have also attached the output of "ldd libvmwareui.so.0" (which contains "libvmwarebase.so.0 => not found") and "readelf -Ws libvmwareui.so.0".

                         

                        The output is from the (just upgraded) openSuse Tumbleweed:

                        # uname -a
                        Linux salt 4.0.5-4.g56152db-desktop #1 SMP PREEMPT Thu Jun 18 15:11:06 UTC 2015 (56152db) x86_64 x86_64 x86_64 GNU/Linux
                        # gcc --version
                        gcc (SUSE Linux) 5.1.1 20150622 [gcc-5-branch revision 224722]

                         

                        Having said that, the issue "Failed to get gcc information" was already present on openSuse 13.2 with kernel 4.0.?/gcc 4.8.? and openSuse Tumbleweed/gcc 4.8.?

                         

                        Hope there will be a solution to this issue soon!

                         

                        Regards,

                        Andreas

                         

                        Update: I forgot to mention, this is with VMware Workstation 11.1.2-2780323.x86_64

                        • 9. Re: gcc 5.1: Failed to get gcc information.
                          andreas_1 Novice

                          Still no solution. I was able to compile and install vmmon and vmnet as described by rainerklier in Can not install or run Vmware Player / Workstation on Linux with gcc5.1

                           

                          I could then successfully issue "/etc/init.d/vmware restart".

                           

                          But calling "vmware" exits immediately with "1". Specifically, the following condition in the last if-statement in /usr/bin/vmware fails:

                           

                          "$BINDIR"/vmware-modconfig --appname="VMware Workstation" --icon="vmware-workstation"

                           

                          Return code is 255.

                          • 10. Re: gcc 5.1: Failed to get gcc information.
                            gmoney Novice

                            I haven't been able to find any workaround for this but it's very painful.  I'm running into the same problem (logs match) which isn't surprising given we're both on OpenSUSE Tumbleweed.

                            • 11. Re: gcc 5.1: Failed to get gcc information.
                              mikef@mrf.sonoma.ca.us Lurker

                              Same problem here, openSUSE tumbleweed, Workstation 10, gcc 5.1.1

                              !

                              • 12. Re: gcc 5.1: Failed to get gcc information.
                                ManseEverard Lurker

                                Hi Everyone,

                                 

                                I had the same problem on a linux box used to test the latest software at work.

                                 

                                Thanks to all the replays to this question (and in particular thanks to rainerklier which posted the right sequence of instructions to recompile the modules which failed) i was able to reach the same point of mikef, gmoney and andreas_1.

                                 

                                Before the update to the latest SUSE Tumbleweed (update done yesterday), vmware runned very well on a Tumbleweed snapshot dated 2015-06-12.

                                 

                                So, i tried to revert the following libraries to the version of 2015-06-12 (i have the DVD of course):

                                 

                                libcairo2 (ver. 1.14.2-1.1)

                                libfm-gtk4 (ver. 1.2.3-2.3)

                                libgdk_pixbuf-2_0-0 (ver. 2.31.4-1.1)

                                libgio-2_0-0 (ver. 2.44.1-1.1)

                                libglib-2_0-0 (ver. 2.44.1-1.1)

                                libglibmm-2_4-1 (ver. 2.44.0-1.1)

                                libgtk-2_0.0 (ver. 2.24.28-2.1)

                                libgtkmm-2_4.1 (ver. 2.24.4-6.1)

                                libgwgengui-gtk2-0 (ver. 4.13.1-2.1)

                                 

                                (the version reported is the one that is working).

                                 

                                The dependencies required by libvmwareui.so.0 where satisfied and vmware started again.

                                 

                                Oddly, i had to revert also

                                 

                                libcurl4 (ver. 7.42.1-1.1)

                                 

                                because vmware crushed at runtime...

                                 

                                 

                                I restored also other libraries, but if i'm not wrong the ones that i reported are sufficient.

                                 

                                I hope that this can help.

                                 

                                Best regards.

                                • 13. Re: gcc 5.1: Failed to get gcc information.
                                  andreas_1 Novice

                                  One more piece to the puzzle, since after ManseEverard's reply I looked again.

                                   

                                  The missing symbol I reported earlier is from libgtkmm-2_4.1 (ver. 2.24.4-6.1), which provides the C++ interface for GTK2 (the symbol refers to https://developer.gnome.org/glibmm/stable/group__Spawn.html#ga18eb698a6fbce720473b69dabb67f08b ).

                                   

                                  Demangling the analogous symbol in the current, newer libgtkmm-2_4.1 ver. 2.24.4-6.2 (note the "2" at the end) now has changed "std::string" to "std::__cxx11::basic_string...", which is the C++11 version. Naturally, that is different, since GCC 5 now uses "-std=gnu11" as default.

                                   

                                  Since VMware was compiled with the older "-std=gnu89" C++ bindings, they break on the current Tumbleweed (or any distro with GCC 5 compiled in the default "std=gnu11" mode) (see also GCC5 and the C++11 ABI | Red Hat Developer Blog ).

                                   

                                  At least that is my understanding.

                                   

                                  I assume the only robust solution is that VMware will provide Workstation in two variants - one compiled against the old C++, one against the new C++11 bindings (until all supported versions have made the switch to GCC 5). I don't feel confident in mixing libraries from ABI-different compiler versions, because even if VMware works, who knows what other dependencies would break then.

                                   

                                  Looks complicated to me.

                                   

                                  Update: No solution in sight yet:What’s New in Workstation Technology Preview 2015, published yesterday, mentions support of Ubuntu 15.04 and Fedora 22. Ubuntu 15.04 is compiled with GCC 4.9.2, whereas Fedora 22 is compiled with GCC 5 but chose to use the old ABI. But the upcoming Ubuntu 15.10 will use GCC 5 (with new ABI it seems), as will Fedora 23 (GCC 5 in Fedora | Red Hat Developer Blog ). Let's hope VMware moves quicker.

                                  • 14. Re: gcc 5.1: Failed to get gcc information.
                                    ManseEverard Lurker

                                    You are right andreas_1... the one that i proposed IS a complicated workaround...

                                     

                                    If some programs (vmware) are able to run, other programs (es. gparted) doesn't and i am forced to reinstall the previous version (with the right gcc compiling flag as you observed) to have them working...

                                     

                                    I too hope on a solution from the vmware side, since the use of the new compiler IS the future.

                                    1 2 3 Previous Next