13 Replies Latest reply on Jun 17, 2018 12:55 AM by Nunya1

    Bridging issues in Windows 10 and WS11

    SnapCount1 Novice

      Hi all...

       

      Just wondering if anyone else is having issues with Bridging on Workstation 11.1 and Windows 10 Build 10049?

       

      I have reinstalled twice and made sure that Windows Defender wasnt running (other ppl with bridging issues said that some virus protection software causes issues)  I have no luck with getting bridging to work.

       

      The networking interfaces doesnt have the vmware bridge protocol installed and I am unable to manually get VMnet0 to bridge also.

        • 1. Re: Bridging issues in Windows 10 and WS11
          JRC3 Novice

          I can confirm Bridged Networking is not working.

           

          Steps to produce error:

          1. Remove All Virtual Networks. Apply

          2. Add Network. Apply

          3. Click Bridged.

          Error: Cannon change network to bridged: There are no un-bridged host network adapters.

          4. Leave Host-only - Works

          5. Click NAT. Apply - Works

          6. Uncheck Connect Host and local DHCP for custom. - Works


          Networking GUI in 10 is broken. Can not install Client/Service/Protocols or change properties on ipv4/6.

           

          We probably need a powershell option for vm workstation to add bridging protocol to the adapter.

          • 2. Re: Bridging issues in Windows 10 and WS11
            baskint Lurker

            Confirmed.. This is exactly has been the error I was getting as I went through the update process. I am using WS 11. Not going to 11.1... Tried many things, but finally gave up and restore my Windows 8.1 system to yesterday's copy. Terrible experience. Before that, I uninstalled the application twice with reboots (except I may have the Defender running, but never had any issues with Defender running anyway prior to this).

             

            All my VMWare Network adapters were missing, as well as the vmnetbridge service. Tried several times to start the service, yet it was not registered. I think this is a problem with the installer. Takes out the adapters and fails to register. Note that I have VirtualBox installed, but again, they used to go side-by-side, perhaps not anymore? I don't think VirtualBox is the issue there though. Missing VMWare adapters and bridge connections. Ouch!

             

            Please vet this out as soon as possible. I have never such bad experience with a VMWare Workstation updater before (okay maybe a few other times, where my VMNnet0 's are reconfigured, and adapters were shuffled, but those were easy.

             

            This is a major issue. Hope it is fixed. I will recheck this forum later next week. Unless there is another update, I won't be applying the current update any more. Wasted hours

             

            Baskin

            • 3. Re: Bridging issues in Windows 10 and WS11
              extract Lurker

              I too has the same issue and I apprently tried to revert to 10041 from 10049 and it did not work.

               

              But I tried to these and it worked for me. I stopped all the VM's and in vmware networking removed all the adapters.

              Then tried to run the vmware 11 (latest) setup again and when it asked to install I choose repair and it did repaired and reinstalled the networking and after that I tried to create new virtual adapter and it worked and vm can able to browse internet.

              • 4. Re: Bridging issues in Windows 10 and WS11
                devilion Lurker

                Me too, i'm on windows 10 build 10130

                • 5. Re: Bridging issues in Windows 10 and WS11
                  pasrjones Lurker

                  Upgraded to W10 on 07/29 and have been using WS 11.1 with various VM's without issue, until now.  At a specific customer site I need to use VMnet0 to bridge with a specific guest VM.  Guest runs fine but no VMnet0 and no bridging at all.

                   

                  PLEASE HELP!!

                   

                  UPDATE: Working now.  I tried the "Restore Defaults" button on the Virtual Network Editor and at first I thought it didn't work but it did.  When I first open the Virtual Network Editor, in non-admin mode, VMnet0 doesn't show up so I thought the Restore Defaults didn't work.  I noticed behind the Virtual Network Editor popup that the guest had acquired an address and the only place to do that would have been on VMnet0.  Went into the guest and networking was working bridged.  I went back into the Virtual Network Editor in non-admin and there still wasn't a VMnet0.  When I choose the Admin privileges button the Virtual Network Editor closes and re-opens with the VMnet0 visible.  Is this by design?  Again working now so thanks.

                  • 6. Re: Bridging issues in Windows 10 and WS11
                    Northice Lurker

                    I opened the Virtual Network Editor on my machine and clicked the Restore Defaults button and it fixed everything for me.

                    • 7. Re: Bridging issues in Windows 10 and WS11
                      vershick Lurker

                      Hi all!

                       

                      I had the same problem.

                      My host system was upgrated to W10 today.

                      After that the guest systems lost the communication...

                       

                      And then I go to "Edit" - "Virtual Network Editor" and click "Restore defaults"

                       

                      It reinstalled all necessary network things and then all just working fine!!

                      • 8. Re: Bridging issues in Windows 10 and WS11
                        MROSET Lurker

                        I too experienced the same issue.

                        Restoring the defaults and using the 'Change Settings' ('Administrator') button in the lower right corner option did not bring back VMNET0 for me, at least not directly.

                        However, I did resolve it as follows:

                        1. Remove all Virtual Network adapters

                        2. Run a Repair Install from Add/Remove Programs (WIndows 10 x64) (I'm running the latest Workstation 12 Pro version and update)

                        3. Reboot

                         

                        After the reboot all VMNETs came back (VMNET0 for Bridging, VMNET1 for Host-Only and VMNET8 for NAT)

                         

                        Additional Note:

                        I also had my fair share of connectivity and stability issues after updating to the WIndows 10 - 1511 (Threshold 2) update.

                        For now, I'm still on Threshold 1 (which is close to perfect on my DELL XPS17 notebook), but perhaps the VMWare VMNET issues may be somehow related, and I might retry the 1511 update sometime soon

                        (I've found that retaining connectivity and stability with multiple VPN clients in place and multiple VMNET Virtual Adapters can be a big challenge. Best approach is to uninstall as much as possible in the official way, reboot, and then try the Win10 update again)

                        • 9. Re: Bridging issues in Windows 10 and WS11
                          hokiegeek2 Lurker

                          I am having the same problem and it's *really* bumming me out.  Why hasn't vmware fixed this yet?

                          • 10. Re: Bridging issues in Windows 10 and WS11
                            Hughby Lurker

                            I had similar problems with WS12 and a recent Windows 10 clean install - vmnet0 didn't appear by default, no bridge connections available and the vmware bridge protocol could not be added to my ethernet adapter.

                             

                            The solution turned out to be

                             

                            1) Uninstall Kaspersky Internet Security 2015

                            2) Restore Defaults in Virtual Network Editor - vmnet0 reappeared and was bridged and worked correctly

                            3) Re install Kaspersky - vmnet0 still working. Hurrah!

                            • 11. Re: Bridging issues in Windows 10 and WS11
                              lajo Lurker

                              Hi all.

                               

                              Larger Win10 upgrades sometimes remove the Service "WMWare Bridge protocol" !?

                              Just install the service on the network adaptor again. Don't need any software or restarts...

                               

                              Regards,

                              Lars

                              • 12. Re: Bridging issues in Windows 10 and WS11
                                danietec Novice

                                Unless you have a real good reason to upgrade to Win10 I wouldn't. You're not gaining anything. I did and now my Station11 works with VNnet0 but this is what I done.

                                 

                                1. Set all of the VMnetting back to default and run as Admin button.

                                2.Choose the Phyical Int your using in the drop down.

                                3. Then set you host all on VMnet0 bridge again.

                                4. Ping the host from the CMD run command.

                                 

                                Turn off your updates too. Microsoft updates always changes things you don't want changed.

                                 

                                Hope this helps you.

                                • 13. Re: Bridging issues in Windows 10 and WS11
                                  Nunya1 Lurker

                                  For anyone still having this issue, I finally figured the root cause was from having an advanced firewall such as ZoneAlarm. It was ultimately the reason I was unable to setup bridging. Or make advanced changes to network devices (as suggested in other posts as solutions to this problem).