11 Replies Latest reply on May 26, 2015 1:28 PM by helmi7

    vSwitch not tagging traffic

    AshleyCotter Lurker

      Morning,

       

      I have come across an issue that I am unable resolve nor can I find a solution on the the internet so I thought I would ask here.

       

      I am running Workstation 11 with a GNS3 1.2.3 setup, I have attempted to create a "trunk" from a FastEthernet port using encapsulation 802.1q to my Host Only vmnet adapter on my host machine that is connected to a vswitch that has two port groups configured to tag traffic on vlan 10 and 20.

       

      All very simple but for me, not so much... I can see packets leaving the cisco with the 802.1q tag for either 10 or 20 but I cannot see the vmnet adapter talking 802.1q back.. I have configured IP's on the devices hosted on esxi in the same network as vlan10 and it still is not being tagged.. I see the traffic from one of the vm's in the vlan assigned port group attempting to talk outbound and there are no tags in the packets for 802.1q I can only assume that the vswitch is stripping the tags.

       

      Any help would be appreciated.

       

      --Added a packet capture with comms to and from the router and A VM.

       

      VM 10.10.10.50

      Router IP 10.10.10.254

       

      Message was edited by: AshleyCotter

        • 1. Re: vSwitch not tagging traffic
          AshleyCotter Lurker

          Downgraded to version 10 and the problem is now gone..

           

          There is an issue with how the virtual nics in version 11 handle 802.1q.. I was unable to isolate it but I am confident that someone will be able too.

           

          If you're up for taking a look let me know and I will give you all the HW details that I am using.

           

          All the best

          1 person found this helpful
          • 2. Re: vSwitch not tagging traffic
            yanw Hot Shot
            VMware Employees

            Hi, AshleyCotterAshleyCotter:

             

                Thank you for your feedback and could you please post a detail topological graph ? I guest from your description that you have two host, one is a ESXI host and the other is a Workstation host. On the Workstation host, you have a VM which install the GNS3 1.2.3 software, meanwhile on the ESXI host, you also have a VM which belong to a vSwith port groups vlan 10 or vlan 20, now you want the two VMs to communicate from the "trunk" ? am i right ? or please correct me.

            • 3. Re: vSwitch not tagging traffic
              AshleyCotter Lurker

              Hello,

               

              sorry for the delay with the information that you want..

               

              So I am running windows 8.1 with vmware workstation 11 installed, I have GNS3 version 1.2.3 installed providing networking from the vSwitch using a Host Only adapter configured in workstation, from that adapter I have created a cloud in GNS and created a link from a Trunk port to the Cloud and confugured TWO 802.1q encapsulated interfaces on the cisco

               

              Router Config

               

              interface FastEthernet0/1

              no ip address

              speed auto

              duplex auto

              interface FastEthernet0/1.10

              description VLAN10

              encapsulation dot1Q 10

              ip address 10.10.10.254 255.255.255.0

              ip nat inside

              interface FastEthernet0/1.20

              description VLAN20

              encapsulation dot1Q 20

              ip address 20.20.20.254 255.255.255.0

              ip nat inside

               

              I have thus configured TWO portgroups on the ESXi Host which are both VLAN 10 and 20.

               

              Capturesa.PNG

               

              Now from the packet capture above you will see packets leaving the router destined for either VLAN 10 or 20 being tagged so I know the config on the router is correct, whats happening (and I think this is to do with the Host Only adapter drivers) is that the Host Only adapter is not noticing that the packets have the 802.1q header and it is being either dropped or stripped. I have attempted to communicate out from the ESXi device from one of the VM's and I can see the packets leaving with no 802.1q tags.

               

              I attempted to TAG the VLANs directly on the virtual host only adapter and the same thing was happening, so in short I believe there is something wrong with the Adapters in this version of WorkStation.

               

              I attempted to reinstall and reboot on several attempts to no avail.

               

              I hope this information helps.

              • 4. Re: vSwitch not tagging traffic
                yanw Hot Shot
                VMware Employees

                You aim to let the VM in the ESXi (such as Darn Small Linux2) can access the cloud in your GSN, right ?  Is the ESXi host a Physical device or a VM of Workstation ? If your ESXi host is a physical device , why you use Host Only adapter but not NAT or Bridge for the communication between Workstation host and ESXi host ?

                • 5. Re: vSwitch not tagging traffic
                  helmi7 Lurker

                  I have made the same lab of  Keith Barker and i encountred the same issues with vmware worstation 11, the uplink sends only untagged traffic to gns3 , have you resolve the problem ?

                  Text-to-speech function is limited to 100 characters
                  • 6. Re: vSwitch not tagging traffic
                    yanw Hot Shot
                    VMware Employees

                    Hi, helmi7:

                     

                      Could you please give me a detail topology on your testbed setup ?

                    • 7. Re: vSwitch not tagging traffic
                      yanw Hot Shot
                      VMware Employees

                      1)  Your gns3 install on the same host with Workstation ?

                      2)  Is the ESXi host installed as a VM of Workstation and the ESXi VM's virtual adapter connect as host-only ?

                      • 8. Re: vSwitch not tagging traffic
                        helmi7 Lurker

                        Hi yanwyanw,

                        I found  the solution, the problem reside in the version of vmware worksation 11, it seems like do not send tagged traffic to outside( to gns3), so when i installed vmware workstation 9 and the problem disappear,

                        thanks yanw

                        • 9. Re: vSwitch not tagging traffic
                          yanw Hot Shot
                          VMware Employees

                          Hi, helmi7:

                           

                              Glad to see that you have found the solution. From your description, this issue seems a regression of Workstation11, so i want to learn the detail topology and reproduce steps in order to see if can push the issue to be fixed in the future Workstation release. Unfortunately i am not familiar with GNS3, so maybe need your more detail description about your setup, thanks.

                          • 10. Re: vSwitch not tagging traffic
                            AshleyCotter Lurker

                            From GNS3 we're currently running a router, well emulating a router that is, in my case it was a 7200 series cisco device.

                             

                            I have configured 802.1q encapsulation on one of the interfaces via the router and attached the routers interface to the HOST only adapter that is created in Windows when you install Workstation.

                            Once you have done that you need to configure a VMKernal/Portgroup in the vlan you have created on the Router and test comms.

                             

                            As I have attached previously there are 802.1q packets leaving the GNS emulated 7200 router but they are not being interpreted by the HOST-ONLY Adapter that is installed with workstation 11 nor does the HOST-ONLY adapter then TAG the l2 frames with the 802.1q ID.

                             

                            Do you know what I am attempting to explain now? if not may be best to show you via a skype session if you're available at somepoint.

                            • 11. Re: vSwitch not tagging traffic
                              helmi7 Lurker

                              I made the same lab that you build (esxi hosts in workstaion attached to gns3 throught host only adapter), test your lab with vmware workstaion 9.0.2. it will be fine i have tested,