3 Replies Latest reply on May 13, 2015 10:08 PM by nyteryder79

    VM file corruption problems

    ken1024 Lurker

      I am receiving multiple file corruption errors on newly created VMs.  The following is my configuration:

      • VMWare Workstation version:  10.0.5 and 11
      • Host hardware: Dell Latitude E7440
      • 16 gb RAMLiteon LMT-512L9M-11 MSATA 512gb Solid State Drive (SSD) hard drive
      • Host operating system:  Windows 8.1

       

      Guest configuration:

      • Operating system:  Windows Server 2012 R2
      • Memory:  1024
      • Disk:  20gb, multiple and single hard drive files, space not pre-allocated

       

      The following are the steps needed to reproduce the problem:

      1. Create the VM based on the specification above

      2. Install the guest operating system

      3. Once the setup process is complete, shut down (not restart) the newly created VM

      4. Start the new VM

      5. Open a command prompt as an administrator

      6. Run sfc /scannow (this results in over 20 corrupt, not repairable files)

       

      This has happened on more than three laptops all with the same hardware configuration as described above.

       

      This file corruption has rendered multiple VMs unusable.

       

      Also point out that on the same hardware with a USB 3.0 external non-SSD disk, no corruptions occur. (Indicating that SSD is a factor)

       

      We realize this  may be some type of hardware issue; however, we were not able to replicate the problem using another vendor’s virtualization product.

       

      Any help is greatly appreciated!

        • 1. Re: VM file corruption problems
          RexW Novice

          I am a co-worker with the original poster and I have the same hardware and same issue.

           

          We have discovered that if when you create a VM, you specify SATA as the virtual hard drive controller type instead of SCSI, we don't see the corruptions.

           

          We have also tried using an external SSD USB 3.0 drive without issues. Hyper-V VMs on the same hardware seem to work fine.

           

          The Guest OS doesn't seem to matter (we have seen corruptions on Server 2012 R2, Windows 8.1, and Windows 7 guests)

           

          The specific commonalities that appear to be causing corruptions are:

          • Make and model of laptop listed in the original post
          • Windows 8.1 Host (we haven't tested other host OSs yet)
          • Creating a VM using a virtual SCSI hard disk
          • Creating the virtual hard disk on an internal SSD (we have only tried the model listed in the original post)
          • 2. Re: VM file corruption problems
            jcstaff Lurker

            Thanks - this set of posts got me over the hump. Once I changed my VMWare 11/Fedora 21 disk type option from SCSI to SATA I was good to go. Prior to this single change, I was getting corrupted disks for Fedora 20 and 21 installs using LVM and Standard partitioning schemes. Even the default installation options produced corrupted disk partitions. I am using

            * Laptop, Windows 8.1 Pro (it has an internal SSD that I am *not* using for the VM)

            * Non-SSD host disk connected via USB3 for the guest VM and all media

            * LVM guest partitioning scheme

            * Fedora 21

            * SATA worked the first/only time attempted. SCSI failed eventually every time within 1-2 boots

             

            thanks!

             

            Note: I also give credit to the following page in getting my VM the rest of the way up when it came to troubles with VMWare-tools and shared folders.

            https://github.com/rasa/vmware-tools-patches/#tested-vmware-tools-versions

            • 3. Re: VM file corruption problems
              nyteryder79 Lurker

              I've been having this issue as well.  I'm running VMware Workstation 11.1 on Ubuntu 12.04.  The VM is a Windows 8.1 Pro x64.  I've rebuilt this VM 4x now and after reading your post about the corruption being due to SCSI, I tried rebuilding it with SATA.  So far, so good.  I also noticed that the VMs that I have that have never had this issue were either built with SATA or IDE virtual disks.  I think there's something to this being related to the virtual SCSI controller.  I'll report back if my new Windows 8.1 Pro VM built with SATA causes me any grief.

               

              What's odd, is that this VM worked great up until about 3 weeks ago, then all the corruption started.  It may be related to the newest VMware Tools builds.